aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-09-26 08:31:30 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-09-26 08:31:30 +0000
commit4ff591bc69061a9813d77b89caaaf03721827fdd (patch)
tree7ae0988654c958b0dff0d6dc88bf97076bdd8a78 /science
parent6f25c5fe28e17d2cbba42d82710eda085a829617 (diff)
downloadports-4ff591bc69061a9813d77b89caaaf03721827fdd.tar.gz
ports-4ff591bc69061a9813d77b89caaaf03721827fdd.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/p5-Geo-Coordinates-Converter/Makefile25
-rw-r--r--science/p5-Geo-Coordinates-Converter/distinfo4
-rw-r--r--science/p5-Geo-Coordinates-Converter/pkg-plist1
3 files changed, 19 insertions, 11 deletions
diff --git a/science/p5-Geo-Coordinates-Converter/Makefile b/science/p5-Geo-Coordinates-Converter/Makefile
index ccfee540717a..89c16639b12c 100644
--- a/science/p5-Geo-Coordinates-Converter/Makefile
+++ b/science/p5-Geo-Coordinates-Converter/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: p5-Geo-Coordinates-Converter
-# Date created: Dec 29, 2010
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-Coordinates-Converter
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= science geography perl5
MASTER_SITES= CPAN
#MASTER_SITE_SUBDIR= CPAN:YAPPO
@@ -15,11 +11,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple converter of geo coordinates
-BUILD_DEPENDS= p5-Class-Accessor-Lite>0.0.5:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly \
p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
- p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+ p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Base>0:${PORTSDIR}/devel/p5-Test-Base
PERL_CONFIGURE= yes
@@ -28,4 +28,11 @@ MAN3= Geo::Coordinates::Converter::Datum.3 \
Geo::Coordinates::Converter::Point.3 \
Geo::Coordinates::Converter::Format.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-parent>0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/p5-Geo-Coordinates-Converter/distinfo b/science/p5-Geo-Coordinates-Converter/distinfo
index 4c54cede7ca8..47319fd0ca53 100644
--- a/science/p5-Geo-Coordinates-Converter/distinfo
+++ b/science/p5-Geo-Coordinates-Converter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Geo-Coordinates-Converter-0.11.tar.gz) = 4595da0cc90624eef0ff6dd88fb1891f7eec2388a9304666f5d0b0d57e356b53
-SIZE (Geo-Coordinates-Converter-0.11.tar.gz) = 29841
+SHA256 (Geo-Coordinates-Converter-0.12.tar.gz) = c659c78304bc6a6cf656798b1255e5e4f0d52c20073b9982d9746b766683de2d
+SIZE (Geo-Coordinates-Converter-0.12.tar.gz) = 30288
diff --git a/science/p5-Geo-Coordinates-Converter/pkg-plist b/science/p5-Geo-Coordinates-Converter/pkg-plist
index 844e351175f7..545477f24d3e 100644
--- a/science/p5-Geo-Coordinates-Converter/pkg-plist
+++ b/science/p5-Geo-Coordinates-Converter/pkg-plist
@@ -7,6 +7,7 @@
%%SITE_PERL%%/Geo/Coordinates/Converter/Datum/Wgs72.pm
%%SITE_PERL%%/Geo/Coordinates/Converter/Format/Dms.pm
%%SITE_PERL%%/Geo/Coordinates/Converter/Format/Degree.pm
+%%SITE_PERL%%/Geo/Coordinates/Converter/Format/Milliseconds.pm
%%SITE_PERL%%/Geo/Coordinates/Converter/Point.pm
%%SITE_PERL%%/Geo/Coordinates/Converter/Datum.pm
%%SITE_PERL%%/Geo/Coordinates/Converter/Format.pm