aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-30 20:37:50 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-30 20:37:50 +0000
commit5985a22c6f1dab6475a1258d3873d5d296502558 (patch)
tree01e262a05441d535a377dbe6c8cc6acdd131a840 /science
parenteb176a659d2d2f0666ec4acef2fec47bbce15feb (diff)
downloadports-5985a22c6f1dab6475a1258d3873d5d296502558.tar.gz
ports-5985a22c6f1dab6475a1258d3873d5d296502558.zip
science/nest: fix build on powerpc
LLVM on powerpc doesn't have libomp.
Diffstat (limited to 'science')
-rw-r--r--science/nest/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/science/nest/Makefile b/science/nest/Makefile
index 29fa2aa073b1..ddd6eab25049 100644
--- a/science/nest/Makefile
+++ b/science/nest/Makefile
@@ -15,7 +15,7 @@ BROKEN_i386= https://github.com/nest/nest-simulator/issues/1205
LIB_DEPENDS= libgsl.so:math/gsl \
libltdl.so:devel/libltdl
-USES= cmake compiler:c++11-lang ncurses pkgconfig readline
+USES= cmake ncurses pkgconfig readline
USE_GITHUB= yes
GH_PROJECT= nest-simulator
USE_LDCONFIG= yes
@@ -31,4 +31,12 @@ PYTHON_CMAKE_ON= -DCYTHON_EXECUTABLE:STRING=${PREFIX}/bin/cython-${PYTHON_VER}
PORTDOCS= *
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
+
.include <bsd.port.mk>