aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-11-07 23:56:49 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-11-07 23:56:49 +0000
commit5e079d547d625ffac4ffa3671459a3d54d1468cc (patch)
treebe3ccc106f97a0a000d65a6646eb0fb45eee332a /science
parentf50ef7392160f2720cf5b1817c29c76d12a353da (diff)
downloadports-5e079d547d625ffac4ffa3671459a3d54d1468cc.tar.gz
ports-5e079d547d625ffac4ffa3671459a3d54d1468cc.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/getdp/Makefile47
-rw-r--r--science/getdp/distinfo4
-rw-r--r--science/getdp/pkg-plist77
3 files changed, 54 insertions, 74 deletions
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index a619284427a1..88d36bfa38ae 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: getdp
-# Date created: 25 September 2004
-# Whom: Thierry Thomas <thierry@pompo.net>
-#
+# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-#
PORTNAME= getdp
-PORTVERSION= 1.2.1
-PORTREVISION= 16
+PORTVERSION= 2.2.1
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -19,10 +14,14 @@ COMMENT= A rather general finite element solver using mixed finite elements
LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl \
lapack.4:${PORTSDIR}/math/lapack
+USE_GMAKE= yes
USE_FORTRAN= yes
GNU_CONFIGURE= yes
+# Using --enable-sparskit instead of math/petsc. The maintainer couldn't get
+# the math/petsc to work. This is a bmake/gmake clash.
CONFIGURE_ARGS= --with-gsl-prefix=${LOCALBASE} \
- --with-blas-lapack-prefix=${LOCALBASE}
+ --with-blas-lapack-prefix=${LOCALBASE} \
+ --enable-sparskit
WANT_PERL= yes
MAKE_JOBS_UNSAFE= yes
@@ -30,37 +29,19 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= getdp.1
-EXAMPLES= Magnetostatics.pro README solver.par test.geo test.msh test.pro
-
-.if defined(WITH_MULTIHARMONIC)
-CONFIGURE_ARGS+= --enable-multiharmonic
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if !defined(NOPORTDOCS)
-ALL_TARGET= all doc
-BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
- dvips:${PORTSDIR}/print/dvipsk-tetex \
- texi2pdf:${PORTSDIR}/print/texinfo
-USE_PERL5_BUILD= yes
-.endif
-
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/getdp
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${DOCSDIR} && ${TAR} xfz ${WRKSRC}/${PORTNAME}-${PORTVERSION}-doc.tgz
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/demos/|} ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ cd ${WRKSRC}/doc && ${FIND} -s ${WRKSRC}/doc/* | ${SED} -e 's#${WRKSRC}/doc/##' | ${CPIO} -pmud -R ${BINOWN}:${BINGRP} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ cd ${WRKSRC}/demos && ${FIND} -s ${WRKSRC}/demos/* | ${SED} -e 's#${WRKSRC}/demos/##' | ${CPIO} -pmud -R ${BINOWN}:${BINGRP} ${EXAMPLESDIR}
.endif
+.include <bsd.port.pre.mk>
+
.if defined(MAINTAINER_MODE)
regression-test: install
- cd ${WRKSRC}/demos && ${PORTNAME} test.pro -solve MagSta_phi
+ cd ${WRKSRC}/demos && yes "" | ${PORTNAME} magnet.pro -solve MagSta_phi
.endif
.include <bsd.port.post.mk>
diff --git a/science/getdp/distinfo b/science/getdp/distinfo
index dcbd75748e00..469fb8ac3622 100644
--- a/science/getdp/distinfo
+++ b/science/getdp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (getdp-1.2.1-source.tgz) = 93b3af4f0ee9ff857863413765ecbbbad53810b7cc0798960d1b7738148691a3
-SIZE (getdp-1.2.1-source.tgz) = 1425314
+SHA256 (getdp-2.2.1-source.tgz) = a76cc7a774ffdd7172bead4e9e5d7791d6e071dfd676452e14384779e42edca7
+SIZE (getdp-2.2.1-source.tgz) = 1464022
diff --git a/science/getdp/pkg-plist b/science/getdp/pkg-plist
index 826b43b707a0..7f6b26df7d1d 100644
--- a/science/getdp/pkg-plist
+++ b/science/getdp/pkg-plist
@@ -1,47 +1,46 @@
bin/getdp
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/Makefile
%%PORTDOCS%%%%DOCSDIR%%/README.win32
-%%PORTDOCS%%%%DOCSDIR%%/VERSIONS
+%%PORTDOCS%%%%DOCSDIR%%/VERSIONS.txt
%%PORTDOCS%%%%DOCSDIR%%/getdp.1
+%%PORTDOCS%%%%DOCSDIR%%/getdp.bib
+%%PORTDOCS%%%%DOCSDIR%%/getdp.html
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Core.fig
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Core.geo
%%PORTDOCS%%%%DOCSDIR%%/texinfo/Core.jpg
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Core.pdf
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Core.txt
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/CoreMassive.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/CoreSta.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/EleSta_v.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Integration_Lib.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Jacobian_Lib.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/MagDyn_av_2D.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/MagSta_a_2D.pro
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Strip.fig
%%PORTDOCS%%%%DOCSDIR%%/texinfo/Strip.jpg
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp-full.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp-info.tgz
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp.pdf
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp.ps
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp.txt
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_1.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_10.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_11.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_12.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_13.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_14.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_15.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_16.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_17.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_18.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_2.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_3.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_4.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_5.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_6.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_7.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_8.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_9.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_abt.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_fot.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_ovr.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp_toc.html
-%%PORTDOCS%%%%DOCSDIR%%/texinfo/index.html
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Strip.pdf
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/Strip.txt
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/getdp.texi
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/mStrip.geo
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/mStrip.pro
%%PORTDOCS%%%%DOCSDIR%%/texinfo/objects-wrap.jpg
-%%PORTDOCS%%%%EXAMPLESDIR%%/Magnetostatics.pro
-%%PORTDOCS%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/solver.par
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.geo
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.pro
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/objects-wrap.pdf
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/objects-wrap.tex
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/objects-wrap.txt
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/objects.fig
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/objects.tex
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/texinfo.tex
+%%PORTDOCS%%%%DOCSDIR%%/texinfo/texinfo.tex.orig
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Magnetostatics.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/magnet.geo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/magnet.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/magnet.pro
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/magnet.txt
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/texinfo
%%PORTDOCS%%@dirrm %%DOCSDIR%%