aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-12-23 19:11:12 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-12-23 19:11:12 +0000
commit6bec834a464e936fcb6eafcf2b3c3ef4c2c2eff4 (patch)
treea92c0760fdc6946fb746b4a6dd05c22cc4465254 /science
parent6e2fa0573bdbe896a47e2e1d3e49cd84e62d1555 (diff)
downloadports-6bec834a464e936fcb6eafcf2b3c3ef4c2c2eff4.tar.gz
ports-6bec834a464e936fcb6eafcf2b3c3ef4c2c2eff4.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/flounder/Makefile60
-rw-r--r--science/flounder/files/patch-Fl_Gnuplot.cc13
-rw-r--r--science/flounder/files/patch-Glarea.cc11
-rw-r--r--science/flounder/files/patch-IGBheader.cc45
-rw-r--r--science/flounder/files/patch-RenderEPS.h17
-rw-r--r--science/flounder/pkg-plist2
6 files changed, 106 insertions, 42 deletions
diff --git a/science/flounder/Makefile b/science/flounder/Makefile
index fceba98f4b34..8bf193e0c0ec 100644
--- a/science/flounder/Makefile
+++ b/science/flounder/Makefile
@@ -1,14 +1,9 @@
-# ex:ts=8
-# Ports collection Makefile for: flounder
-# Date created: Oct 14, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= flounder
PORTVERSION= 0.40
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= science
MASTER_SITES= http://www.enel.ucalgary.ca/People/vigmond/flounder/
EXTRACT_SUFX= .tgz
@@ -16,35 +11,52 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A quick way to visualize regularly spaced 4D data
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- gif:${PORTSDIR}/graphics/giflib \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
+ png15:${PORTSDIR}/graphics/png \
+ fltk:${PORTSDIR}/x11-toolkits/fltk
+
+OPTIONS_DEFINE= GNUPLOT GRACE
+OPTIONS_DEFAULT=GNUPLOT GRACE
+GRACE_DESC= Plotting via GRACE
USE_GL= glut
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lstdc++
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+PLIST_FILES= bin/flounder bin/igbhead
-.if !defined(WITHOUT_PLOT)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUPLOT}
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
CONFIGURE_ARGS+= --enable-gnuplot
.endif
-.if !defined(WITHOUT_GRACE)
+.if ${PORT_OPTIONS:MGRACE}
BUILD_DEPENDS+= xmgrace:${PORTSDIR}/math/grace
RUN_DEPENDS+= xmgrace:${PORTSDIR}/math/grace
CONFIGURE_ARGS+= --enable-grace
.endif
post-patch:
- ${REINPLACE_CMD} -e "s|-lungif|-lgif|" ${WRKSRC}/configure
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha"
-BROKEN= Does not compile on alpha
-.endif
-
-.include <bsd.port.post.mk>
+ @${REINPLACE_CMD} -e \
+ 's|-lungif|-lgif|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|cmdline.o.*|cmdline.o| ; \
+ /getopt.o/d ; \
+ /getopt1.o/d ; \
+ s|g++ |$$(CXX) | ; \
+ s|-g | |' ${WRKSRC}/utils/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|^main(|int main(|' ${WRKSRC}/utils/igbhead.cc
+
+do-install:
+ cd ${WRKSRC}/src && ${INSTALL_PROGRAM} flounder ${PREFIX}/bin
+ cd ${WRKSRC}/utils && ${INSTALL_PROGRAM} igbhead ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/flounder/files/patch-Fl_Gnuplot.cc b/science/flounder/files/patch-Fl_Gnuplot.cc
index 96a1e754336e..7eed076d864d 100644
--- a/science/flounder/files/patch-Fl_Gnuplot.cc
+++ b/science/flounder/files/patch-Fl_Gnuplot.cc
@@ -1,6 +1,11 @@
---- src/Fl_Gnuplot.cc.orig Tue Oct 15 03:59:41 2002
-+++ src/Fl_Gnuplot.cc Tue Oct 15 04:02:05 2002
-@@ -44,6 +44,7 @@
+--- src/Fl_Gnuplot.cc.orig 2002-12-20 03:56:35.000000000 +0900
++++ src/Fl_Gnuplot.cc 2012-10-23 23:22:44.000000000 +0900
+@@ -39,11 +39,11 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
+-#include <fstream.h>
+ #include <unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>
@@ -8,7 +13,7 @@
#include "FL/fl_draw.H"
#include "FL/fl_ask.H"
-@@ -53,12 +54,14 @@
+@@ -53,12 +53,14 @@
#define N_ENTRIES 8192
diff --git a/science/flounder/files/patch-Glarea.cc b/science/flounder/files/patch-Glarea.cc
new file mode 100644
index 000000000000..115aa1248112
--- /dev/null
+++ b/science/flounder/files/patch-Glarea.cc
@@ -0,0 +1,11 @@
+--- src/Glarea.cc.orig 2002-12-20 03:56:35.000000000 +0900
++++ src/Glarea.cc 2012-12-12 23:16:47.000000000 +0900
+@@ -918,7 +918,7 @@
+ igbname = fname + ".gz";
+ if( (in=gzopen( igbname.c_str(), "r" )) == NULL ) {
+ igbname = fname + ".igb.gz";
+- if( (in=fopen( igbname.c_str(), "rb" )) == NULL )
++ if( (in=(gzFile)fopen( igbname.c_str(), "rb" )) == NULL )
+ return 1;
+ }
+ }
diff --git a/science/flounder/files/patch-IGBheader.cc b/science/flounder/files/patch-IGBheader.cc
index 102c34e373b9..73f7207bef0a 100644
--- a/science/flounder/files/patch-IGBheader.cc
+++ b/science/flounder/files/patch-IGBheader.cc
@@ -1,13 +1,52 @@
--- src/IGBheader.cc.orig Tue Oct 15 02:15:19 2002
+++ src/IGBheader.cc Tue Oct 15 02:15:44 2002
-@@ -17,7 +17,10 @@
+@@ -17,8 +17,11 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
#include<stdlib.h>
+#include <iostream>
#include "IGBheader.h"
-+
-+using namespace std;
++using namespace std;
++
/* -------------- Bits de statut pour Header_Read et Header_Write ------ */
+ #define MOT_CLEF_INV 2
+@@ -756,7 +759,7 @@
+ if (bool_comment) {
+ comment = v_comment;
+ while (*comment != NULL) {
+- n_car = gzprintf(file, "#%.80s\r\n", *comment++);
++ n_car = gzprintf((gzFile)file, "#%.80s\r\n", *comment++);
+ if (n_car==0) {
+ if (!Header_Quiet) {
+ fprintf(stderr, "\nHeader_Write: Erreur a l'ecriture \n");
+@@ -861,7 +864,7 @@
+ }
+
+ /* --- lit le caractere suivant --- */
+- in = gzgetc( file ) ;
++ in = gzgetc( (gzFile)file ) ;
+
+ /* --- (EOF dans l'entete) --> erreur --- */
+ if ( in == -1 ) {
+@@ -1318,8 +1321,8 @@
+ }
+ }
+
+- if (gztell(file)!=1024) {
+- gzseek( file, 1024, SEEK_SET );
++ if (gztell((gzFile)file)!=1024) {
++ gzseek( (gzFile)file, 1024, SEEK_SET );
+ if (!Header_Quiet) {
+ fprintf(stderr,
+ "\nATTENTION: etiquette de grandeur non-standard \n");
+@@ -1335,7 +1338,7 @@
+
+ if (bool_vect_z) {
+ v_vect_z = (float *)malloc(v_z*sizeof(float));
+- gzread(file, v_vect_z, sizeof(float)*v_z);
++ gzread((gzFile)file, v_vect_z, sizeof(float)*v_z);
+ }
+
+ return( statut ) ;
diff --git a/science/flounder/files/patch-RenderEPS.h b/science/flounder/files/patch-RenderEPS.h
index b81b62a0866f..718932b0a1a7 100644
--- a/science/flounder/files/patch-RenderEPS.h
+++ b/science/flounder/files/patch-RenderEPS.h
@@ -1,11 +1,10 @@
---- src/RenderEPS.h.orig Tue Oct 15 00:35:11 2002
-+++ src/RenderEPS.h Tue Oct 15 00:35:26 2002
-@@ -23,6 +23,8 @@
+--- src/RenderEPS.h.orig 2002-12-19 13:37:24.000000000 +0900
++++ src/RenderEPS.h 2012-10-23 23:23:41.000000000 +0900
+@@ -20,6 +20,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
#include <GL/gl.h>
#include <string>
-
-+using namespace std;
-+
- #define FB_BUFSIZE 1000000
-
- class RenderEPS {
+ using namespace std;
diff --git a/science/flounder/pkg-plist b/science/flounder/pkg-plist
deleted file mode 100644
index 50843b692ba3..000000000000
--- a/science/flounder/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/flounder
-bin/igbhead