aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 22:08:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 22:08:22 +0000
commit70311449fae75ffea4fd9f53366895a06b4bc897 (patch)
treedcad9bcb676fb6eb1edd275685eb3589f7f31419 /science
parent8a35140e06cecbb04d9d78df50ee65c13425e141 (diff)
downloadports-70311449fae75ffea4fd9f53366895a06b4bc897.tar.gz
ports-70311449fae75ffea4fd9f53366895a06b4bc897.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/InsightToolkit/Makefile15
-rw-r--r--science/dlpoly-classic/Makefile20
-rw-r--r--science/gramps/Makefile21
-rw-r--r--science/hdf5-18/Makefile20
-rw-r--r--science/liblinear/Makefile21
-rw-r--r--science/libsvm/Makefile19
-rw-r--r--science/mbdyn/Makefile29
-rw-r--r--science/netcdf/Makefile19
-rw-r--r--science/netcdf4/Makefile21
-rw-r--r--science/omnetpp/Makefile24
-rw-r--r--science/paraview/Makefile11
-rw-r--r--science/xmds/Makefile15
12 files changed, 103 insertions, 132 deletions
diff --git a/science/InsightToolkit/Makefile b/science/InsightToolkit/Makefile
index 84886baec099..46113085dbd1 100644
--- a/science/InsightToolkit/Makefile
+++ b/science/InsightToolkit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: Insight Toolkit
-# Date created: 10 Aug 2006
-# Whom: bacon@smithers.neuro.mcw.edu
-#
+# Created by: bacon@smithers.neuro.mcw.edu
# $FreeBSD$
-#
PORTNAME= InsightToolkit
PORTVERSION= 2.8.1
@@ -14,8 +10,9 @@ MASTER_SITES= SF/itk/itk/2.8
MAINTAINER= jwbacon@tds.net
COMMENT= Insight Toolkit
-OPTIONS= EXAMPLES "Build examples (very time consuming)" off \
- TESTING "Build testing programs (very time consuming)" off
+OPTIONS_DEFINE= EXAMPLES TESTING
+#OPTIONS= EXAMPLES "Build examples (very time consuming)" off \
+# TESTING "Build testing programs (very time consuming)" off
USE_LDCONFIG= ${PREFIX}/lib/InsightToolkit
NO_PACKAGE= License does not allow redistribution of binaries
@@ -27,11 +24,11 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if !defined(WITH_EXAMPLES)
+.if ! ${PORT_OPTIONS:MEXAMPLES}
CMAKE_ARGS+= "-DBUILD_EXAMPLES:BOOL=OFF"
.endif
-.if !defined(WITH_TESTING)
+.if ! ${PORT_OPTIONS:MTESTING}
CMAKE_ARGS+= "-DBUILD_TESTING:BOOL=OFF"
.endif
diff --git a/science/dlpoly-classic/Makefile b/science/dlpoly-classic/Makefile
index 9b97af950a43..6085be753296 100644
--- a/science/dlpoly-classic/Makefile
+++ b/science/dlpoly-classic/Makefile
@@ -1,11 +1,5 @@
-############################################################################
-# New ports collection Makefile for: dlpoly-classic
-# Date created: 21 Jan 2010
-# Whom: Jason Bacon <jwbacon@tds.net>
-#
+# Created by: Jason Bacon <jwbacon@tds.net>
# $FreeBSD$
-#
-############################################################################
PORTNAME= dlpoly
PORTVERSION= 1.8
@@ -20,7 +14,9 @@ COMMENT= Molecular dynamics simulation package
BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpif90:${PORTSDIR}/net/openmpi
RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
-OPTIONS= GUI "Install Java GUI" on
+OPTIONS_DEFINE= GUI DOCS EXAMPLES
+OPTIONS_DEFAULT= GUI
+GUI_DESC= Install Java GUI
USE_GMAKE= yes
USE_FORTRAN= yes
@@ -33,7 +29,7 @@ MPIF90= ${LOCALBASE}/mpi/openmpi/bin/mpif90
.include <bsd.port.options.mk>
-.if defined(WITH_GUI)
+.if ${PORT_OPTIONS:MGUI}
USE_JAVA= yes
PLIST_FILES+= bin/dlpoly-gui \
${DATADIR_REL}/GUI.jar
@@ -61,16 +57,16 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/execute/dlpoly-classic ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/execute/dlpoly-classic-mpi ${PREFIX}/bin
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manual/* ${DOCSDIR}
.endif
-.ifndef(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/execute ${EXAMPLESDIR}
${RM} ${EXAMPLESDIR}/execute/dlpoly*
.endif
-.if defined(WITH_GUI)
+.if ${PORT_OPTIONS:MGUI}
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/java/GUI.jar ${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/dlpoly-gui ${PREFIX}/bin
diff --git a/science/gramps/Makefile b/science/gramps/Makefile
index 21eca70b12c0..b1b0291d0235 100644
--- a/science/gramps/Makefile
+++ b/science/gramps/Makefile
@@ -31,27 +31,28 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= gramps.1
MANLANG= "" cs fr nl pl sv
-OPTIONS= ENCHANT "Spellchecking support" off \
- PYWEBKITGTK "Use webkit backend for Geographic view" on \
- GRAPHVIZ "Use graphviz for graphs creating" on \
- EXIV "Managing exiv metadata support" on
+OPTIONS_DEFINE= ENCHANT PYWEBKITGTK GRAPHVIZ EXIV
+OPTIONS_DEFAULT= PYWEBKITGTK GRAPHVIZ EXIV
+ENCHANT_DESC= Spellchecking support
+PYWEBKITGTK_DESC= Use webkit backend for Geographic view
+EXIV_DESC= Managing exiv metadata support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MENCHANT}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enchant>=0:${PORTSDIR}/textproc/py-enchant
.endif
-.if defined(WITH_PYWEBKITGTK)
+.if ${PORT_OPTIONS:MPYWEBKITGTK}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:${PORTSDIR}/www/py-webkitgtk
.endif
-.if defined(WITH_GRAPHVIZ)
+.if ${PORT_OPTIONS:MGRAPHVIZ}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}graphviz>-0:${PORTSDIR}/graphics/py-graphviz
.endif
-.if defined(WITH_EXIV)
+.if ${PORT_OPTIONS:MEXIV}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}exiv2>=0.1.3:${PORTSDIR}/graphics/py-exiv2
.endif
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 00b10cfff0ff..2844c72ec0e9 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hdf5-18
-# Date created: Nov 20, 2008
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= hdf5
PORTVERSION= 1.8.9
@@ -29,17 +25,17 @@ CONFIGURE_ARGS= --enable-cxx \
--with-pthread=/usr \
--with-zlib=/usr
-OPTIONS= DEBUG "Debug" off \
- FORTRAN "Fortran support" off \
- SZIP "SZIP support" off
+OPTIONS_DEFINE= DEBUG FORTRAN SZIP EXAMPLES
+FORTRAN_DESC= Fortran support
+SZIP_DESC= SZIP support
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug=all --disable-production
.endif
-.if defined(WITH_FORTRAN)
+.if ${PORT_OPTIONS:MFORTRAN}
USE_FORTRAN= yes
CONFIGURE_ENV+= F9X=${FC}
CONFIGURE_ARGS+=--enable-fortran
@@ -48,7 +44,7 @@ PLIST_SUB+= FORTRAN=""
PLIST_SUB+= FORTRAN="@comment "
.endif
-.if defined(WITH_SZIP)
+.if ${PORT_OPTIONS:MSZIP}
LIB_DEPENDS+= sz:${PORTSDIR}/science/szip
CONFIGURE_ARGS+=--with-szlib=${LOCALBASE}
.endif
@@ -66,7 +62,7 @@ post-patch:
-e 's|(INSTALL)|(INSTALL_DATA)|' \
`${FIND} ${WRKSRC} -regex '.*/examples/Makefile.in'`
@${REINPLACE_CMD} -e 's|\[ -a|\[ -f|g' `${FIND} ${WRKSRC} -name \*.sh\*`
-.if defined(NOPORTEXAMPLES)
+.if ! ${PORT_OPTIONS:MEXAMPLES}
@${REINPLACE_CMD} -e '/^install:/ s|install-examples||' ${WRKSRC}/Makefile.in
.endif
diff --git a/science/liblinear/Makefile b/science/liblinear/Makefile
index 28ff34e483ce..5319784b353c 100644
--- a/science/liblinear/Makefile
+++ b/science/liblinear/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: liblr
-# Date created: May 14 2007
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= liblinear
PORTVERSION= 1.80
@@ -18,21 +14,22 @@ COMMENT= A library for Large Linear Classification
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-OPTIONS= OCFLAGS "Use optimized CFLAGS" On
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
USE_ZIP= yes
TXT_DOCS= COPYRIGHT README
-.if !defined(NOPORTDOCS)
-PORTDOCS= ${TXT_DOCS}
-.endif
-
PLIST_FILES= bin/train bin/predict
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_OCFLAGS)
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= ${TXT_DOCS}
+.endif
+
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
# same as LIBLINEAR itself
CFLAGS= -Wall -O3
.endif
@@ -42,7 +39,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/predict ${PREFIX}/bin
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
for f in ${TXT_DOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
diff --git a/science/libsvm/Makefile b/science/libsvm/Makefile
index 30483a402fd5..e186a30d1f04 100644
--- a/science/libsvm/Makefile
+++ b/science/libsvm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: libsvm
-# Date created: Oct 28 2001
-# Whom: Chia-Hsing Yu <me@davidyu.org>
-#
+# Created by: Chia-Hsing Yu <me@davidyu.org>
# $FreeBSD$
-#
PORTNAME= libsvm
PORTVERSION= 3.10
@@ -19,7 +15,8 @@ COMMENT= A library for Support Vector Machines
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-OPTIONS= OCFLAGS "Use optimized CFLAGS" On
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
USE_ZIP= yes
@@ -47,13 +44,13 @@ SUB_LIST= DATADIR=${DATADIR}
.endif
-.if !defined(NOPORTDOCS)
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= ${TXT_DOCS}
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_OCFLAGS)
+.if ${PORT_OPTIONS:MOCFLAGS}
# same as LIBSVM itself
CFLAGS= -Wall -Wconversion -O3
.endif
@@ -86,7 +83,7 @@ do-install:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
for f in ${TXT_DOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 2bcf129fbaa2..7fe1d8eb1e56 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mbdyn
-# Date created: 2005-01-30
-# Whom: Kay Lehmann <kay_lehmann@web.de>
-#
+# Created by: Kay Lehmann <kay_lehmann@web.de>
# $FreeBSD$
-#
PORTNAME= mbdyn
PORTVERSION= 1.4.0
@@ -26,11 +22,12 @@ CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/suitesparse
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --program-prefix=''
-OPTIONS= MPI "Enable mpich-support" off \
- METIS "Enable metis-support" off \
- CHACO "Enable chaco-support" off \
- GINAC "Enable GiNaC-support (not implemented yet)" off \
- TCL "Enable tcl-support (not implemented yet)" off
+OPTIONS_DEFINE= MPI METIS CHACO GINAC TCL
+MPI_DESC= Enable mpich-support
+METIS_DESC= Enable metis-support
+CHACO_DESC= Enable chaco-support
+GINAC_DESC= Enable GiNaC-support (not implemented yet)
+TCL_DESC= Enable tcl-support (not implemented yet)
.include <bsd.port.pre.mk>
@@ -55,18 +52,18 @@ CONFIGURE_ARGS+= --with-blas=atlas
LAPACK_LIBS= -lalapack
.endif
-.if defined(WITH_MPI)
+.if ${PORT_OPTIONS:MMPI}
LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpi=yes --enable-schur
CPPFLAGS+= -I${LOCALBASE}/include
-. if !defined(WITH_METIS)
+. if ! ${PORT_OPTIONS:MMETIS}
WITH_CHACO= yes
. endif
.else
CONFIGURE_ARGS+= --with-mpi=no
.endif
-.if defined(WITH_METIS)
+.if ${PORT_OPTIONS:MMETIS}
LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
CONFIGURE_ARGS+= --with-metis=yes
CPPFLAGS+= -I${LOCALBASE}/include/metis
@@ -74,14 +71,14 @@ CPPFLAGS+= -I${LOCALBASE}/include/metis
CONFIGURE_ARGS+= --with-metis=no
.endif
-.if defined(WITH_CHACO)
+.if ${PORT_OPTIONS:MCHACO}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libchaco.a:${PORTSDIR}/math/chaco
CONFIGURE_ARGS+= --with-chaco=yes
.else
CONFIGURE_ARGS+= --with-chaco=no
.endif
-.if defined(WITH_GINAC)
+.if ${PORT_OPTIONS:MGINAC}
LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4 \
ginac:${PORTSDIR}/math/GiNaC
CONFIGURE_ARGS+= --with-ginac=yes
@@ -90,7 +87,7 @@ CPPFLAGS+= -I${LOCALBASE}/include/metis
CONFIGURE_ARGS+= --with-ginac=no
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
IGNORE= you enabled Tcl-support, which is not implemented yet
LIB_DEPENDS+= tcl84:${PORTSDIR}/lang/tcl84
CONFIGURE_ARGS+= --with-tcl=yes
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index b3cf850f4c33..3a4853f9cc1e 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: netcdf
-# Date created: 29 July 1999
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= netcdf
PORTVERSION= 3.6.3
@@ -29,17 +25,18 @@ INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3
-OPTIONS= FORTRAN "Build library for Fortran" off
+OPTIONS_DEFINE= FORTRAN DOCS
+FORTRAN_DESC= Build library for Fortran
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--enable-docs-install
.else
CONFIGURE_ARGS+=--disable-docs-install
.endif
-.include <bsd.port.options.mk>
-
-.if defined(WITH_FORTRAN)
+.if ${PORT_OPTIONS:MFORTRAN}
CPPFLAGS+= -DpgiFortran
CONFLICTS+= netcdf-3.*
MAN3+= netcdf_f77.3 netcdf_f90.3
@@ -59,7 +56,7 @@ post-patch:
@${REINPLACE_CMD} -e \
'271 s/\(info_docs\).*/html_docs\)/' \
${WRKSRC}/man4/Makefile.in
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '790 s/install-docDATA //' \
${WRKSRC}/man/Makefile.in
.endif
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index 170714f0cf4a..27929379774b 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: netcdf4
-# Date created: 2008-11-11
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
# $FreeBSD$
-#
PORTNAME= netcdf
PORTVERSION= 4.1.3
@@ -20,9 +16,10 @@ CONFLICTS= hdf-4.* netcdf-3.*
LATEST_LINK?= netcdf4
PORTSCOUT= limit:^4\.
-OPTIONS= DAP "Build DAP client and remote testing" off \
- FORTRAN "Build library for Fortran" off \
- SZIP "SZIP support (required if HDF5 was built with SZIP)" off
+OPTIONS_DEFINE= DAP FORTRAN SZIP
+DAP_DESC= Build DAP client and remote testing
+FORTRAN_DESC= Build library for Fortran
+SZIP_DESC= SZIP support (required if HDF5 was built with SZIP)
CONFIGURE_ARGS= --enable-cxx --enable-cxx-4 --enable-netcdf-4 --enable-shared \
--with-hdf5=${LOCALBASE} --with-zlib=/usr
@@ -41,7 +38,7 @@ MAN3= netcdf.3
.include <bsd.port.options.mk>
-.if defined(WITH_DAP)
+.if ${PORT_OPTIONS:MDAP}
CONFIGURE_ARGS+=--enable-dap --with-curl=${LOCALBASE} \
--with-curl-config=${LOCALBASE}/bin/curl-config
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
@@ -49,7 +46,7 @@ LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--disable-dap
.endif
-.if defined(WITH_FORTRAN)
+.if ${PORT_OPTIONS:MFORTRAN}
CPPFLAGS+= -DpgiFortran
CONFLICTS+= netcdf-4.*
MAN3+= netcdf_f77.3 netcdf_f90.3
@@ -62,7 +59,7 @@ CONFLICTS+= netcdf-ftn-4.*
PLIST_SUB+= FORTRAN="@comment "
.endif
-.if defined(WITH_SZIP)
+.if ${PORT_OPTIONS:MSZIP}
CONFIGURE_ARGS+=--with-szlib=${LOCALBASE}
LIB_DEPENDS+= sz.2:${PORTSDIR}/science/szip
.endif
@@ -74,7 +71,7 @@ post-configure:
.endfor
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/man4 && ${INSTALL_DATA} *.html *.pdf *.txt ${DOCSDIR}/
.endif
diff --git a/science/omnetpp/Makefile b/science/omnetpp/Makefile
index 5a6705c773e1..fc498965e14a 100644
--- a/science/omnetpp/Makefile
+++ b/science/omnetpp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: omnetpp
-# Date created: 29 October 2004
-# Whom: bkoenig
-#
+# Created by: bkoenig
# $FreeBSD$
-#
PORTNAME= omnetpp
PORTVERSION= 3.3
@@ -40,21 +36,23 @@ PLIST= ${WRKDIR}/pkg-plist
INCLDIR= ${PREFIX}/include/${PORTNAME}
INCLDIR_REL= ${INCLDIR:S,^${PREFIX}/,,}
-OPTIONS= MAGICK "Install ImageMagick for EPS-JPG conversion" ON \
- GRAPHVIZ "Install Graphviz for generating diagrams" ON \
- DOXYGEN "Install Doxygen to create the API reference" ON
+OPTIONS_DEFINE= MAGICK GRAPHVIZ DOXYGEN DOCS
+OPTIONS_DEFAULT= MAGICK GRAPHVIZ DOXYGEN
+MAGICK_DESC= Install ImageMagick for EPS-JPG conversion
+GRAPHVIZ_DESC= Install Graphviz for generating diagrams
+DOXYGEN_DESC= Install Doxygen to create the API reference
.include <bsd.port.pre.mk>
-.if defined(WITH_MAGICK)
+.if ${PORT_OPTIONS:MMAGICK}
depend+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
-.if defined(WITH_GRAPHVIZ)
+.if ${PORT_OPTIONS:MGRAPHVIZ}
depend+= dot:${PORTSDIR}/graphics/graphviz
.endif
-.if defined(WITH_DOXYGEN)
+.if ${PORT_OPTIONS:MDOXYGEN}
depend+= doxygen:${PORTSDIR}/devel/doxygen
.endif
@@ -86,7 +84,7 @@ pre-install:
${FIND} -s bitmaps -type f | ${SED} "s,^,%%DATADIR%%/," >> ${PLIST}; \
${FIND} -s -d bitmaps -type d | ${SED} "s,^,@dirrm %%DATADIR%%/," >> ${PLIST} \
)
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@(cd ${WRKSRC}; \
${FIND} -s doc/ -type f | ${SED} "s,^doc/,%%DOCSDIR%%/," >> ${PLIST}; \
${FIND} -s -d doc/ -type d | ${SED} "s,^doc/,@dirrm %%DOCSDIR%%/," >> ${PLIST} \
@@ -127,7 +125,7 @@ do-install:
${FIND} . -type d -exec ${MKDIR} ${DATADIR}/bitmaps/{} \; ;\
${FIND} . -type f | ${XARGS} -I% ${INSTALL_DATA} % ${DATADIR}/bitmaps/% \
)
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@(cd ${WRKSRC}/doc;\
${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; ;\
${FIND} . -type f | ${XARGS} -I% ${INSTALL_DATA} % ${DOCSDIR}/% \
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index c833c4c78937..163849c9de13 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -51,8 +51,9 @@ CMAKE_ARGS+= -DPARAVIEW_USE_SYSTEM_HDF5=1 \
# -DPARAVIEW_ENABLE_PYTHON:BOOL=ON
# -DVTK_PYTHON_SETUP_ARGS:STRING='--prefix="${PREFIX}"' \
-OPTIONS= OSMESA "Use Mesa for off-screen rendering" Off \
- GL2PS "Install support conversion OpenGL to PostScript" On
+OPTIONS_DEFINE= OSMESA GL2PS DOCS
+OSMESA_DESC= Use Mesa for off-screen rendering
+GL2PS_DESC= Install support conversion OpenGL to PostScript
# VTKMPEG2 "Install patented MPEG2 encoder module" Off \
VERMAJORMINOR= ${PORTVERSION:R}
@@ -60,20 +61,20 @@ VERMAJORMINOR= ${PORTVERSION:R}
.include <bsd.port.options.mk>
# Simple solution to avoid lots of patching to support NOPORTDOCS
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CMAKE_ARGS+= -DPV_INSTALL_DOC_DIR=${DOCSDIR}
.else
CMAKE_ARGS+= -DPV_INSTALL_DOC_DIR=${WRKDIR}
.endif
-.if defined(WITH_OSMESA)
+.if ${PORT_OPTIONS:MOSMESA}
LIB_DEPENDS+= OSMesa32.7:${PORTSDIR}/graphics/libosmesa
CMAKE_ARGS+= -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
-DOSMESA_INCLUDE_DIR:PATH=${LOCALBASE}/include/Mesa \
-DOSMESA_LIBRARY:FILEPATH=${LOCALBASE}/lib/libOSMesa32.so
.endif
-.if defined(WITH_GL2PS)
+.if ${PORT_OPTIONS:MGL2PS}
LIB_DEPENDS+= gl2ps.1:${PORTSDIR}/print/gl2ps
CMAKE_ARGS+= -DVTK_USE_GL2PS:BOOL=ON
PLIST_SUB+= GL2PS=""
diff --git a/science/xmds/Makefile b/science/xmds/Makefile
index b10288c72c58..6202dc560f1e 100644
--- a/science/xmds/Makefile
+++ b/science/xmds/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xmds
-# Date created: 2006-07-17
-# Whom: EelVex
-#
+# Created by: EelVex
# $FreeBSD$
-#
PORTNAME= xmds
PORTVERSION= 1.6
@@ -16,13 +12,14 @@ COMMENT= XMDS is a code generator that integrates equations;
MAN1= loadxsil.1 xmds.1 xsil2graphics.1
-OPTIONS= FFTW3 "Use fftw3 instead of fftw2" Off
+OPTIONS_DEFINE= FFTW3
+FFTW3_DESC= Use fftw3 instead of fftw2
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FFTW3)
+.if ${PORT_OPTIONS:MFFTW3}
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
CONFIGURE_ARGS= --enable-fftw3 --with-fftw3-path=${LOCALBASE}
.else
@@ -30,4 +27,4 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw.h:${PORTSDIR}/math/fftw
CONFIGURE_ARGS= --with-fftw-path=${LOCALBASE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>