aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-14 14:22:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-06-14 14:22:35 +0000
commit70c3cafabfc119f037a15dd26aeca0f8c5c1bc30 (patch)
tree692847f647a1b96449a239ba5bd5dfa3d12c6edc /science
parente86d5fc3ca48b71ecc2d9b543e3e287599065b97 (diff)
downloadports-70c3cafabfc119f037a15dd26aeca0f8c5c1bc30.tar.gz
ports-70c3cafabfc119f037a15dd26aeca0f8c5c1bc30.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/liblinear/Makefile29
-rw-r--r--science/liblinear/distinfo6
-rw-r--r--science/liblinear/pkg-descr24
3 files changed, 24 insertions, 35 deletions
diff --git a/science/liblinear/Makefile b/science/liblinear/Makefile
index a1c0c046c257..b4f841b39605 100644
--- a/science/liblinear/Makefile
+++ b/science/liblinear/Makefile
@@ -2,37 +2,20 @@
# $FreeBSD$
PORTNAME= liblinear
-PORTVERSION= 2.11
+PORTVERSION= 2.30
CATEGORIES= science math
-MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/liblinear/ \
- http://www.csie.ntu.edu.tw/~cjlin/liblinear/oldfiles/
+MASTER_SITES= https://www.csie.ntu.edu.tw/~cjlin/liblinear/ \
+ https://www.csie.ntu.edu.tw/~cjlin/liblinear/oldfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library for Large Linear Classification
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-USES= zip
-
-PORTDOCS= COPYRIGHT README
-
-PLIST_FILES= bin/train bin/predict
-
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
-OPTIONS_DEFAULT=OPTIMIZED_CFLAGS
-
-# same as LIBLINEAR itself
-OPTIMIZED_CFLAGS_CFLAGS= -Wall -O3
+PLIST_FILES= bin/predict bin/train
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/train ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/predict ${STAGEDIR}${PREFIX}/bin
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- for f in ${PORTDOCS}; do \
- ${INSTALL_DATA} ${WRKSRC}/$$f ${STAGEDIR}${DOCSDIR}; \
- done
+ ${INSTALL_PROGRAM} ${WRKSRC}/predict ${WRKSRC}/train ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/science/liblinear/distinfo b/science/liblinear/distinfo
index c4fb1d0d8218..96975de69aef 100644
--- a/science/liblinear/distinfo
+++ b/science/liblinear/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497777405
-SHA256 (liblinear-2.11.zip) = f1f263f4b22530f07d298a1c4812d675ed879e4f7d3801abc9a637f62a505ce0
-SIZE (liblinear-2.11.zip) = 522832
+TIMESTAMP = 1591281350
+SHA256 (liblinear-2.30.tar.gz) = 881c7039c6cf93119c781fb56263de91617b3eca8c3951f2c19a3797de95c6ac
+SIZE (liblinear-2.30.tar.gz) = 526468
diff --git a/science/liblinear/pkg-descr b/science/liblinear/pkg-descr
index f765f91d8913..fbf26fa3b5ff 100644
--- a/science/liblinear/pkg-descr
+++ b/science/liblinear/pkg-descr
@@ -1,14 +1,20 @@
LIBLINEAR is a linear classifier for data with millions of instances and
-features. It supports L2-regularized classifiers (L2-loss linear SVM,
-L1-loss linear SVM, and logistic regression), L1-regularized classifiers
-(L2-loss linear SVM and logistic regression).
+features. It supports:
+- L2-regularized classifiers
+- L2-loss linear SVM, L1-loss linear SVM, and logistic regression (LR)
+- L1-regularized classifiers (after version 1.4)
+- L2-loss linear SVM and logistic regression (LR)
+- L2-regularized support vector regression (after version 1.9)
+- L2-loss linear SVR and L1-loss linear SVR.
-Main features of LIBLINEAR include
-
-- Same data format as LIBSVM and similar usage
-- One-vs-the rest and Crammer & Singer multi-class classification
-- Cross validation for model selection
+Main features of LIBLINEAR include:
+- Same data format as LIBSVM, our general-purpose SVM solver, and also similar
+ usage
+- Multi-class classification: 1) one-vs-the rest, 2) Crammer & Singer
+- Cross validation for model evaulation
+- Automatic parameter selection
- Probability estimates (logistic regression only)
- Weights for unbalanced data
+- MATLAB/Octave, Java, Python, Ruby interfaces
-WWW: http://www.csie.ntu.edu.tw/~cjlin/liblinear/
+WWW: https://www.csie.ntu.edu.tw/~cjlin/liblinear/