aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-04-14 15:59:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-04-14 19:07:35 +0000
commit8f98d16693a03cc5102e9f6518035692910ea999 (patch)
treec8527975f879fa6af1b2b8f8f84ee19f9605d543 /science
parent47f81be6be22735bb62e686a5481bf4b602938bd (diff)
downloadports-8f98d16693a03cc5102e9f6518035692910ea999.tar.gz
ports-8f98d16693a03cc5102e9f6518035692910ea999.zip
science/tinker: update 8.10.5 → 8.11.1
Reported by: portscout
Diffstat (limited to 'science')
-rw-r--r--science/tinker/Makefile13
-rw-r--r--science/tinker/distinfo6
-rw-r--r--science/tinker/files/patch-make_Makefile18
-rw-r--r--science/tinker/pkg-plist6
4 files changed, 28 insertions, 15 deletions
diff --git a/science/tinker/Makefile b/science/tinker/Makefile
index 72b6a296d2c6..6de3707bb4d7 100644
--- a/science/tinker/Makefile
+++ b/science/tinker/Makefile
@@ -1,6 +1,5 @@
PORTNAME= tinker
-DISTVERSION= 8.10.5
-PORTREVISION= 1
+DISTVERSION= 8.11.1
CATEGORIES= science
MASTER_SITES= https://dasher.wustl.edu/tinker/downloads/
@@ -78,6 +77,16 @@ post-install-EXAMPLES-on:
0README *.make *.dyn *.int *.frac *.key *.seq *.pdb *.xyz \
${STAGEDIR}${EXAMPLESDIR}
+do-test:
+ ${RM} -r ${WRKSRC}/bin
+ ${LN} -s ${STAGEDIR}${PREFIX}/bin ${WRKSRC}/bin
+ cd ${WRKSRC}/test && \
+ for test_run in *.run; do \
+ ${ECHO} "Running test $${test_run} ..." && \
+ ./$${test_run} && \
+ ${ECHO} "Test $${test_run} suceeded"; \
+ done
+
benchmarks: stage
.for n in 1 2 3 4 5 6 7 8 9
@cd ${BUILD_WRKSRC}/../bench && ./bench${n}.run
diff --git a/science/tinker/distinfo b/science/tinker/distinfo
index 3237f17d500a..7f0aa845abc3 100644
--- a/science/tinker/distinfo
+++ b/science/tinker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1686102562
-SHA256 (tinker-8.10.5.tar.gz) = 4673783f1d8f369c9e90add6f8be4aeb8a6969525fd8c09b6f97b7ca93294e94
-SIZE (tinker-8.10.5.tar.gz) = 70068463
+TIMESTAMP = 1713071651
+SHA256 (tinker-8.11.1.tar.gz) = cdbf2dfb5e43c3438b27ac8b767c9290ae2948e62333149babd72a6811963731
+SIZE (tinker-8.11.1.tar.gz) = 74273877
diff --git a/science/tinker/files/patch-make_Makefile b/science/tinker/files/patch-make_Makefile
index 4781c07cc428..e1f412c1b22f 100644
--- a/science/tinker/files/patch-make_Makefile
+++ b/science/tinker/files/patch-make_Makefile
@@ -1,15 +1,15 @@
---- make/Makefile.orig 2023-03-09 06:01:09 UTC
+--- make/Makefile.orig 2024-04-08 01:19:41 UTC
+++ make/Makefile
-@@ -87,7 +87,7 @@ APBS_LIBS = -lapbsmainroutines -lapbs -lmaloc -lapbsbl
+@@ -86,7 +86,7 @@ F77FLAGS = -c
+
F77 = gfortran
F77FLAGS = -c
- #OPTFLAGS = -Ofast -march=native -fopenmp
--OPTFLAGS = -Ofast -mssse3 -fopenmp
+-OPTFLAGS = -Ofast -march=native -fopenmp
+OPTFLAGS = -Ofast $(PORT_SIMD_FLAGS) -fopenmp
- #OPTFLAGS = -Og -fbacktrace -fcheck=bounds -Wunused -Wmaybe-uninitialized
+ #OPTFLAGS = -Ofast -fopenmp
+ #OPTFLAGS = -Og -g -fbacktrace -fcheck=bounds -Wunused -Wmaybe-uninitialized
LIBDIR = -L. -L$(TINKER_LIBDIR)/macos
- LIBS =
-@@ -818,136 +818,136 @@ listing:
+@@ -829,138 +829,138 @@ rename_bin:
cat *.f *.c > tinker.txt
rename_bin:
@@ -63,6 +63,7 @@
- mv testpair.x $(BINDIR)/testpair
- mv testpol.x $(BINDIR)/testpol
- mv testrot.x $(BINDIR)/testrot
+- mv testsurf.x $(BINDIR)/testsurf
- mv testvir.x $(BINDIR)/testvir
- mv timer.x $(BINDIR)/timer
- mv timerot.x $(BINDIR)/timerot
@@ -127,6 +128,7 @@
+ ${BSD_INSTALL_PROGRAM} testpair.x $(BINDIR)/testpair
+ ${BSD_INSTALL_PROGRAM} testpol.x $(BINDIR)/testpol
+ ${BSD_INSTALL_PROGRAM} testrot.x $(BINDIR)/testrot
++ ${BSD_INSTALL_PROGRAM} testsurf.x $(BINDIR)/testsurf
+ ${BSD_INSTALL_PROGRAM} testvir.x $(BINDIR)/testvir
+ ${BSD_INSTALL_PROGRAM} timer.x $(BINDIR)/timer
+ ${BSD_INSTALL_PROGRAM} timerot.x $(BINDIR)/timerot
@@ -193,6 +195,7 @@
- mv testpair.x $(BINDIR)/testpair.exe
- mv testpol.x $(BINDIR)/testpol.exe
- mv testrot.x $(BINDIR)/testrot.exe
+- mv testsurf.x $(BINDIR)/testsurf.exe
- mv testvir.x $(BINDIR)/testvir.exe
- mv timer.x $(BINDIR)/timer.exe
- mv timerot.x $(BINDIR)/timerot.exe
@@ -257,6 +260,7 @@
+ ${BSD_INSTALL_PROGRAM} testpair.x $(BINDIR)/testpair.exe
+ ${BSD_INSTALL_PROGRAM} testpol.x $(BINDIR)/testpol.exe
+ ${BSD_INSTALL_PROGRAM} testrot.x $(BINDIR)/testrot.exe
++ ${BSD_INSTALL_PROGRAM} testsurf.x $(BINDIR)/testsurf.exe
+ ${BSD_INSTALL_PROGRAM} testvir.x $(BINDIR)/testvir.exe
+ ${BSD_INSTALL_PROGRAM} timer.x $(BINDIR)/timer.exe
+ ${BSD_INSTALL_PROGRAM} timerot.x $(BINDIR)/timerot.exe
diff --git a/science/tinker/pkg-plist b/science/tinker/pkg-plist
index 93c386919f9f..04f2dc7f3175 100644
--- a/science/tinker/pkg-plist
+++ b/science/tinker/pkg-plist
@@ -48,6 +48,7 @@ bin/testhess
bin/testpair
bin/testpol
bin/testrot
+bin/testsurf
bin/testvir
bin/timer
bin/timerot
@@ -63,7 +64,6 @@ bin/xyzint
bin/xyzmol2
bin/xyzpdb
%%DATADIR%%/params/0README
-%%DATADIR%%/params/amber14sb.prm
%%DATADIR%%/params/amber94.prm
%%DATADIR%%/params/amber96.prm
%%DATADIR%%/params/amber98.prm
@@ -72,6 +72,7 @@ bin/xyzpdb
%%DATADIR%%/params/amoeba04.prm
%%DATADIR%%/params/amoeba09.prm
%%DATADIR%%/params/amoebabio09.prm
+%%DATADIR%%/params/amoebabio18-hfc23.prm
%%DATADIR%%/params/amoebabio18.prm
%%DATADIR%%/params/amoebail22.prm
%%DATADIR%%/params/amoebanuc17.prm
@@ -83,7 +84,6 @@ bin/xyzpdb
%%DATADIR%%/params/charmm22.prm
%%DATADIR%%/params/charmm22cmap.prm
%%DATADIR%%/params/dang.prm
-%%DATADIR%%/params/hippo19.prm
%%DATADIR%%/params/hoch.prm
%%DATADIR%%/params/iwater.prm
%%DATADIR%%/params/mm2.prm
@@ -92,7 +92,6 @@ bin/xyzpdb
%%DATADIR%%/params/mmff.prm
%%DATADIR%%/params/oplsaa.prm
%%DATADIR%%/params/oplsaal.prm
-%%DATADIR%%/params/oplsaam.prm
%%DATADIR%%/params/oplsua.prm
%%DATADIR%%/params/smoothaa.prm
%%DATADIR%%/params/smoothua.prm
@@ -100,6 +99,7 @@ bin/xyzpdb
%%DATADIR%%/params/water03.prm
%%DATADIR%%/params/water14.prm
%%DATADIR%%/params/water21.prm
+%%DATADIR%%/params/water22.prm
%%DATADIR%%/test/0README
%%DATADIR%%/test/anion.dat
%%DATADIR%%/test/anion.dyn0