aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-01 17:55:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-01 17:55:16 +0000
commita8773182a366503f62cb9c2346808a17a036116f (patch)
tree8b0178a65278c72e45173d01569f8bf4520b1425 /science
parentabad2a84ee5af37151dbd90c9fd22da219298132 (diff)
downloadports-a8773182a366503f62cb9c2346808a17a036116f.tar.gz
ports-a8773182a366503f62cb9c2346808a17a036116f.zip
science/dakota: Fix build on i386
Reported by: fallout
Notes
Notes: svn path=/head/; revision=566874
Diffstat (limited to 'science')
-rw-r--r--science/dakota/Makefile17
-rw-r--r--science/dakota/files/patch-packages_external_JEGA_eddy_threads_src_thread.cpp13
2 files changed, 24 insertions, 6 deletions
diff --git a/science/dakota/Makefile b/science/dakota/Makefile
index cd3e92187864..9224c7e2c45b 100644
--- a/science/dakota/Makefile
+++ b/science/dakota/Makefile
@@ -102,11 +102,16 @@ post-install:
.endfor
do-test: # from Additional Test Suites @ https://dakota.sandia.gov/content/additional-test-suites (many tests are known to fail)
- # minimal set of fast-running tests that should NOT FAIL (may DIFF, depending on platform / compiler)
- cd ${WRKSRC}/test && ./dakota_test.perl
- # test suite that should PASS on any supported platform (NO DIFF or FAIL)
- cd ${WRKSRC}/test && ./dakota_test.perl --label-regex=AcceptanceTest
- # run all Dakota tests active in this build (should PASS or DIFF)
- cd ${WRKSRC}/test && ./dakota_test.perl --label-regex=dakota_
+ ## minimal set of fast-running tests that should NOT FAIL (may DIFF, depending on platform / compiler)
+ #cd ${WRKSRC}/test && ./dakota_test.perl
+ ## test suite that should PASS on any supported platform (NO DIFF or FAIL)
+ #cd ${WRKSRC}/test && ./dakota_test.perl --label-regex=AcceptanceTest
+ ## run all Dakota tests active in this build (should PASS or DIFF)
+ #cd ${WRKSRC}/test && ./dakota_test.perl --label-regex=dakota_
+ # Tests should be this way, but this fails:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DDAKOTA_ENABLE_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ (cd ${WRKSRC} && ctest -j 4 -L FastTest -LE Diff)
.include <bsd.port.mk>
diff --git a/science/dakota/files/patch-packages_external_JEGA_eddy_threads_src_thread.cpp b/science/dakota/files/patch-packages_external_JEGA_eddy_threads_src_thread.cpp
new file mode 100644
index 000000000000..77c162a983d6
--- /dev/null
+++ b/science/dakota/files/patch-packages_external_JEGA_eddy_threads_src_thread.cpp
@@ -0,0 +1,13 @@
+- Fix i386 build.
+
+--- packages/external/JEGA/eddy/threads/src/thread.cpp.orig 2021-03-01 17:15:15 UTC
++++ packages/external/JEGA/eddy/threads/src/thread.cpp
+@@ -152,7 +152,7 @@ thread::sleep(
+ )
+ {
+ struct timespec ts = {
+- msecs/1000, static_cast<long>((msecs%1000)*1000000)
++ time_t(msecs/1000), static_cast<long>((msecs%1000)*1000000)
+ };
+
+ #if defined(EDDY_WINDOWS)