aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:54:49 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:54:49 +0000
commita9fce93a032b6c812d46699fc0f566287038ac7b (patch)
treee74f638aa43c0ee6c43cae59c6b179094adbc788 /science
parent4d719d47558df1f0b0205fc034ae7f41ebe2ef88 (diff)
downloadports-a9fce93a032b6c812d46699fc0f566287038ac7b.tar.gz
ports-a9fce93a032b6c812d46699fc0f566287038ac7b.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/elmerfront/Makefile37
-rw-r--r--science/elmerfront/distinfo3
-rw-r--r--science/elmerfront/files/patch-include+ecif_mesh.h9
-rw-r--r--science/elmerfront/pkg-descr9
-rw-r--r--science/elmerfront/pkg-plist92
6 files changed, 151 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 79ea00261a97..861a0fa1f43b 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -22,6 +22,7 @@
SUBDIR += elmer-hutiter
SUBDIR += elmer-matc
SUBDIR += elmer-meshgen2d
+ SUBDIR += elmerfront
SUBDIR += elmergrid
SUBDIR += euler
SUBDIR += fastcap
diff --git a/science/elmerfront/Makefile b/science/elmerfront/Makefile
new file mode 100644
index 000000000000..c6005f099eb5
--- /dev/null
+++ b/science/elmerfront/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: elmerfront
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= front
+PORTVERSION= 4.0.6
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer
+
+MAINTAINER= giffunip@asme.org
+COMMENT= Graphical User Interface for the ELMER FEM package
+
+BUILD_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
+ ${LOCALBASE}/lib/libmatc.a:${PORTSDIR}/science/elmer-matc \
+ ${LOCALBASE}/lib/libeioc.a:${PORTSDIR}/science/elmer-eio
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
+ ElmerSolver:${PORTSDIR}/science/elmer-fem \
+ ${MACHINE_ARCH}-portbld-freebsd${OSREL}-ElmerMesh2D:${PORTSDIR}/science/elmer-meshgen2d
+
+# Elmer avoids the new C++ headers because they cause problems
+# on older systems (Irix)
+CXXFLAGS+= -Wno-deprecated
+
+USE_GCC= 3.4
+USE_GL= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+ALL_TARGET=
+
+DATADIR= ${PREFIX}/share/elmerfront
+PLIST_SUB= ARCH=${MACHINE_ARCH}
+
+.include <bsd.port.mk>
diff --git a/science/elmerfront/distinfo b/science/elmerfront/distinfo
new file mode 100644
index 000000000000..5fd084cc778d
--- /dev/null
+++ b/science/elmerfront/distinfo
@@ -0,0 +1,3 @@
+MD5 (front-4.0.6.tar.gz) = d525d374ff16d2e344e3e8851376ee55
+SHA256 (front-4.0.6.tar.gz) = 54092864e6edc7af6536ec8f40281eb3ee75d0d710c1bb0449b0dd4649c64d18
+SIZE (front-4.0.6.tar.gz) = 923765
diff --git a/science/elmerfront/files/patch-include+ecif_mesh.h b/science/elmerfront/files/patch-include+ecif_mesh.h
new file mode 100644
index 000000000000..f3709e82fcfa
--- /dev/null
+++ b/science/elmerfront/files/patch-include+ecif_mesh.h
@@ -0,0 +1,9 @@
+--- include/ecif_mesh.h.orig Tue Feb 7 20:21:53 2006
++++ include/ecif_mesh.h Tue Feb 7 20:22:24 2006
+@@ -218,4 +218,4 @@
+ static int elementNodesBuffer[27];
+ };
+
+-#endif
+\ No newline at end of file
++#endif
diff --git a/science/elmerfront/pkg-descr b/science/elmerfront/pkg-descr
new file mode 100644
index 000000000000..2d891a60d7b4
--- /dev/null
+++ b/science/elmerfront/pkg-descr
@@ -0,0 +1,9 @@
+ElmerFront - the Graphical User Interface.
+
+ElmerFront is a tool for initializing the computational process in Elmer.
+It communicates with external software producing geometrical data, i.e.,
+CAD files and computational meshes. ElmerFront generates its own finite
+element meshes, allows the user to build mathematical models graphically,
+and finally produces input data for ElmerSolver.
+
+WWW: http://www.csc.fi/elmer/elmerfront/
diff --git a/science/elmerfront/pkg-plist b/science/elmerfront/pkg-plist
new file mode 100644
index 000000000000..d52844257a1a
--- /dev/null
+++ b/science/elmerfront/pkg-plist
@@ -0,0 +1,92 @@
+bin/%%ARCH%%-portbld-freebsd%%OSREL%%-ElmerFront
+%%DATADIR%%/lib/SOLVER.KEYWORDS
+%%DATADIR%%/lib/SolverAdaptiveFields.edf
+%%DATADIR%%/lib/SolverGeneric1Fields.edf
+%%DATADIR%%/lib/SolverGeneric2Fields.edf
+%%DATADIR%%/lib/SolverGeneric3Fields.edf
+%%DATADIR%%/lib/SolverGeneric4Fields.edf
+%%DATADIR%%/lib/SolverLinearFields.edf
+%%DATADIR%%/lib/SolverMultiGridFields.edf
+%%DATADIR%%/lib/SolverNonlinearFields.edf
+%%DATADIR%%/lib/elements.def
+%%DATADIR%%/lib/front.edf
+%%DATADIR%%/lib/procedure.stub.txt
+%%DATADIR%%/lib/rgb.txt
+@dirrm %%DATADIR%%/lib
+%%DATADIR%%/tcl/A
+%%DATADIR%%/tcl/ecif_tcl_mainScript.tcl
+%%DATADIR%%/tcl/ecif_tcl_mainScript.tcl.in
+%%DATADIR%%/tcl/ecif_tcl_namespaces.tcl
+%%DATADIR%%/tcl/ecif_tk_aboutBox.tcl
+%%DATADIR%%/tcl/ecif_tk_bodyDisplayPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_bodyInfoPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_bodyPropertiesPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_boundariesPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_boundaryDisplayPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_calculatorPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_constantPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_coordinatePanel.tcl
+%%DATADIR%%/tcl/ecif_tk_datafilePanel.tcl
+%%DATADIR%%/tcl/ecif_tk_equationVariablesPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_initGlobalArries.tcl
+%%DATADIR%%/tcl/ecif_tk_initMenus.tcl
+%%DATADIR%%/tcl/ecif_tk_inputFileInfoPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_labelDisplayPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_matcDefinitionsPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_meshDefinePanel.tcl
+%%DATADIR%%/tcl/ecif_tk_meshSelectPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_modelInfoPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_modelParameterPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_modelPropertiesPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_postFileSelectPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_procedureEntryPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_processTablePanel.tcl
+%%DATADIR%%/tcl/ecif_tk_processorPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_procsDataField.tcl
+%%DATADIR%%/tcl/ecif_tk_procsInterface.tcl
+%%DATADIR%%/tcl/ecif_tk_procsList.tcl
+%%DATADIR%%/tcl/ecif_tk_procsListBox.tcl
+%%DATADIR%%/tcl/ecif_tk_procsMenuExec.tcl
+%%DATADIR%%/tcl/ecif_tk_procsMessage.tcl
+%%DATADIR%%/tcl/ecif_tk_procsObject.tcl
+%%DATADIR%%/tcl/ecif_tk_procsPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_procsPanelCheck.tcl
+%%DATADIR%%/tcl/ecif_tk_procsUserDefined.tcl
+%%DATADIR%%/tcl/ecif_tk_procsUtil.tcl
+%%DATADIR%%/tcl/ecif_tk_procsWidget.tcl
+%%DATADIR%%/tcl/ecif_tk_screenParams.tcl
+%%DATADIR%%/tcl/ecif_tk_simulationParameterPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_solverControlPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_solverOrderPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_solverParameterPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_standardPanelCheck.tcl
+%%DATADIR%%/tcl/ecif_tk_standardPanelCreate.tcl
+%%DATADIR%%/tcl/ecif_tk_standardPanelExec.tcl
+%%DATADIR%%/tcl/ecif_tk_standardPanelInit.tcl
+%%DATADIR%%/tcl/ecif_tk_systemInfoPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_tableEntryPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_timestepPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_userSettingsPanel.tcl
+%%DATADIR%%/tcl/ecif_tk_vertexDisplayPanel.tcl
+%%DATADIR%%/tcl/front.edf
+%%DATADIR%%/tcl/images/bodies.gif
+%%DATADIR%%/tcl/images/boundaries.gif
+%%DATADIR%%/tcl/images/display.gif
+%%DATADIR%%/tcl/images/down.gif
+%%DATADIR%%/tcl/images/draw.gif
+%%DATADIR%%/tcl/images/left.gif
+%%DATADIR%%/tcl/images/mesh.gif
+%%DATADIR%%/tcl/images/right.gif
+%%DATADIR%%/tcl/images/rmx.gif
+%%DATADIR%%/tcl/images/rmy.gif
+%%DATADIR%%/tcl/images/rotateLeft.gif
+%%DATADIR%%/tcl/images/rotateRight.gif
+%%DATADIR%%/tcl/images/rpx.gif
+%%DATADIR%%/tcl/images/rpy.gif
+%%DATADIR%%/tcl/images/scaledown.gif
+%%DATADIR%%/tcl/images/scaleup.gif
+%%DATADIR%%/tcl/images/up.gif
+@dirrm %%DATADIR%%/tcl/images
+%%DATADIR%%/tcl/tkgetdir.tcl
+@dirrm %%DATADIR%%/tcl
+@dirrm %%DATADIR%%