aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-04-07 14:25:15 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-04-07 15:05:55 +0000
commitc71776b7673dd9fcbc84a187f2c76ab813f939f5 (patch)
treeb62bef720a86121756c4efae5179d96458e0434c /science
parentff9b4950645a8910bc7f36d1ad6434205ab993ef (diff)
downloadports-c71776b7673dd9fcbc84a187f2c76ab813f939f5.tar.gz
ports-c71776b7673dd9fcbc84a187f2c76ab813f939f5.zip
astro/py-spktype01 et al.: fix the dependency on PYNUMPY
Some ports, like astro/py-spktype01, uses the undefined variable ${NUMPY} in their _DEPENDS fields and this must be replaced by the correct ${PYNUMPY}. PR: 254740 Reported by: Bojan Petrovic Approved by: QA blanket for the ports that I do not maintain
Diffstat (limited to 'science')
-rw-r--r--science/py-PyFR/Makefile3
-rw-r--r--science/py-chempy/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/science/py-PyFR/Makefile b/science/py-PyFR/Makefile
index 6c3951d78399..de7928e34d91 100644
--- a/science/py-PyFR/Makefile
+++ b/science/py-PyFR/Makefile
@@ -1,5 +1,6 @@
PORTNAME= PyFR
DISTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= http://www.pyfr.org/download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}mako>=1.0.0:textproc/py-mako@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mpi4py>=2.0:net/py-mpi4py@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytools>=2016.2.1:devel/py-pytools@${PY_FLAVOR} \
- ${NUMPY}
+ ${PYNUMPY}
USES= python:3.3+ shebangfix zip
SHEBANG_FILES= setup.py pyfr/__main__.py
diff --git a/science/py-chempy/Makefile b/science/py-chempy/Makefile
index 38283f3c028f..34befbaa797c 100644
--- a/science/py-chempy/Makefile
+++ b/science/py-chempy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= chempy
DISTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,7 +22,7 @@ PY_DEPENDS= \
${PYTHON_PKGNAMEPREFIX}scipy>=1.0.1:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sym>=0.3.4:math/py-sym@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sympy>=1.1.1:math/py-sympy@${PY_FLAVOR} \
- ${NUMPY}
+ ${PYNUMPY}
BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \