aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-04-11 03:46:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-04-11 08:17:15 +0000
commitced925f70cd14fcb7f46ffc812d6ac24f6eced46 (patch)
tree7d61e3276c0ba6f046d0edac096c47a41857a399 /science
parent762217a6dd7572ca63ef8a3b7371d06489060d10 (diff)
downloadports-ced925f70cd14fcb7f46ffc812d6ac24f6eced46.tar.gz
ports-ced925f70cd14fcb7f46ffc812d6ac24f6eced46.zip
science/kplib: Fix build by removing -Werror promoting a warrning to an error
Reported by: fallout
Diffstat (limited to 'science')
-rw-r--r--science/kplib/files/patch-CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/science/kplib/files/patch-CMakeLists.txt b/science/kplib/files/patch-CMakeLists.txt
index 99cbeca9ee61..27ccdfd27aad 100644
--- a/science/kplib/files/patch-CMakeLists.txt
+++ b/science/kplib/files/patch-CMakeLists.txt
@@ -1,8 +1,16 @@
---- CMakeLists.txt.orig 2022-07-21 22:39:52 UTC
+- removal of -Werror is to quiet this warning promoted to error:
+- error: variable length arrays in C++ are a Clang extension [-Werror,-Wvla-cxx-extension]
+- 612 | int oppedArray[size][size];
+- | ^~~~
+
+--- CMakeLists.txt.orig 2023-04-09 05:04:30 UTC
+++ CMakeLists.txt
-@@ -4,7 +4,7 @@ project(kplib)
+@@ -2,9 +2,9 @@ project(kplib)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror -fPIC")
+ project(kplib)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror -fPIC")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -fPIC")
set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g") # Debug mode.
-set(CMAKE_CXX_FLAGS_RELEASE "-O3 -march=native") # Default optimization.
+set(CMAKE_CXX_FLAGS_RELEASE "-O3") # Default optimization.