aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-06 20:47:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-06 20:47:09 +0000
commitcfabac98ce36514390531ff7a9b056c303c47ee5 (patch)
tree3617d4e497b6805c553d2a99391fe8ee55b3ba53 /science
parentd659e3af041edf79aac462af9c066bcda2efda2b (diff)
downloadports-cfabac98ce36514390531ff7a9b056c303c47ee5.tar.gz
ports-cfabac98ce36514390531ff7a9b056c303c47ee5.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/py-eccodes/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/science/py-eccodes/Makefile b/science/py-eccodes/Makefile
index 40dae4f6b409..d83fe2e6d80b 100644
--- a/science/py-eccodes/Makefile
+++ b/science/py-eccodes/Makefile
@@ -17,8 +17,15 @@ LIB_DEPENDS= libeccodes.so:science/eccodes
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cffi>=0:devel/py-cffi@${PY_FLAVOR} \
${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-flakes>=0:devel/py-pytest-flakes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
USES= python:3.5+
USE_PYTHON= autoplist concurrent distutils
+do-test:
+ cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs -v
+
.include <bsd.port.mk>