aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2017-05-02 02:46:41 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2017-05-02 02:46:41 +0000
commitd659563a0ad74ec742069aa7580092efcb99a573 (patch)
tree6624469ba0e3e881f9192cf657182b5c6b651587 /science
parent1eb5560d8bc69d45e97bf43369ab8f964a1b928f (diff)
downloadports-d659563a0ad74ec742069aa7580092efcb99a573.tar.gz
ports-d659563a0ad74ec742069aa7580092efcb99a573.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/iboview/Makefile39
-rw-r--r--science/iboview/distinfo3
-rw-r--r--science/iboview/files/patch-main.pro43
-rw-r--r--science/iboview/files/patch-src_Common_CxNumpyArray.cpp10
-rw-r--r--science/iboview/files/patch-src_Common_CxStorageDevice.h10
-rw-r--r--science/iboview/pkg-descr7
7 files changed, 113 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 2c39cbee4948..65b5dd26f21e 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -63,6 +63,7 @@
SUBDIR += hdf5
SUBDIR += hdf5-18
SUBDIR += hs-bio
+ SUBDIR += iboview
SUBDIR += isaac-cfd
SUBDIR += jstrack
SUBDIR += kalzium
diff --git a/science/iboview/Makefile b/science/iboview/Makefile
new file mode 100644
index 000000000000..7af2ed8c2825
--- /dev/null
+++ b/science/iboview/Makefile
@@ -0,0 +1,39 @@
+# Created by: Johannes Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= iboview
+PORTVERSION= 20150427
+CATEGORIES= science
+MASTER_SITES= http://www.iboview.org/bin/
+DISTNAME= ibo-view.20150427
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= Program for analyzing molecular electronic structure
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= qt5-buildtools>=0:devel/qt5-buildtools \
+ libGLU>=0:graphics/libGLU \
+ boost-libs>=0:devel/boost-libs
+LIB_DEPENDS= libgcc_s.so:lang/gcc \
+ libGL.so:graphics/libGL
+RUN_DEPENDS= libGLU>=0:graphics/libGLU \
+ boost-libs>=0:devel/boost-libs
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON_amd64= only builds and is supported on amd64
+
+USES= tar:bz2 qmake:outsource blaslapack:openblas
+USE_QT5= core gui widgets opengl script svg
+
+PLIST_FILES= bin/iboview
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%_GCC_RUNTIME%%|${LOCALBASE}/lib/gcc${GCC_DEFAULT}|g' \
+ ${WRKSRC}/main.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/iboview ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/iboview/distinfo b/science/iboview/distinfo
new file mode 100644
index 000000000000..68ccf528844f
--- /dev/null
+++ b/science/iboview/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1493172588
+SHA256 (ibo-view.20150427.tar.bz2) = 2a67b7c82ba957d016eef202453bdfc2278d5752dc7000b4b809812bd7945aed
+SIZE (ibo-view.20150427.tar.bz2) = 5169203
diff --git a/science/iboview/files/patch-main.pro b/science/iboview/files/patch-main.pro
new file mode 100644
index 000000000000..f266099d6cdc
--- /dev/null
+++ b/science/iboview/files/patch-main.pro
@@ -0,0 +1,43 @@
+--- main.pro.orig 2015-04-27 21:30:39 UTC
++++ main.pro
+@@ -1,5 +1,5 @@
+ # /usr/bin/qmake-qt4 -o Makefile main.pro && make -j 4
+-MKLDIR = $$(MKLROOT)
++#MKLDIR = $$(MKLROOT)
+ # MKLDIR = /opt/intel/composerxe/mkl
+ # ^- FIXME: adjust path of MKL here if MKLROOT environment variable is not set.
+ # (e.g.,
+@@ -8,8 +8,9 @@ MKLDIR = $$(MKLROOT)
+
+ # LIBS += -L$$MKLDIR/lib/em64t -lmkl_intel_ilp64 -lmkl_sequential -lmkl_core -lmkl_lapack -Wl,-rpath,$$MKLDIR/lib/em64t
+ # LIBS += -L$$MKLDIR/lib/intel64 -lmkl_gf_ilp64 -lmkl_sequential -lmkl_core -Wl,-rpath,$$MKLDIR/lib/intel64
+-LIBS += -L$$MKLDIR/lib/intel64 -fopenmp -lmkl_gf_ilp64 -lmkl_gnu_thread -lmkl_core -Wl,-rpath,$$MKLDIR/lib/intel64
++#LIBS += -L$$MKLDIR/lib/intel64 -fopenmp -lmkl_gf_ilp64 -lmkl_gnu_thread -lmkl_core -Wl,-rpath,$$MKLDIR/lib/intel64
+ # LIBS += -LC:\Users\cgk\Develop\Libraries\OpenBLAS\bin -lopenblas
++LIBS += -Wl,-rpath=%%_GCC_RUNTIME%% %%_GCC_RUNTIME%%/libgcc_s.so -lopenblas
+
+ # MICROSCF = ../wmme
+
+@@ -52,14 +53,14 @@ HEADERS += $$GL/glew.h $$GL/glxew.h $$GL/wglew.h
+ # from.)
+
+ # OpenMP
+-msvc {
+- QMAKE_CXXFLAGS += /openmp
+- QMAKE_LFLAGS += /openmp
+-}
+-!msvc {
+- QMAKE_CXXFLAGS += -fopenmp
+- QMAKE_LFLAGS += -fopenmp
+-}
++#msvc {
++# QMAKE_CXXFLAGS += /openmp
++# QMAKE_LFLAGS += /openmp
++#}
++#!msvc {
++# QMAKE_CXXFLAGS += -fopenmp
++# QMAKE_LFLAGS += -fopenmp
++#}
+ # ^- warning: need to replace all OpenMP loop variables by "int". Otherwise won't work
+ # in vc or gcc <= 4.4 (unsigned integral types only allowed since OpenMP 3.0... wtf
+ # were they thinking?!)
diff --git a/science/iboview/files/patch-src_Common_CxNumpyArray.cpp b/science/iboview/files/patch-src_Common_CxNumpyArray.cpp
new file mode 100644
index 000000000000..02498540c50c
--- /dev/null
+++ b/science/iboview/files/patch-src_Common_CxNumpyArray.cpp
@@ -0,0 +1,10 @@
+--- src/Common/CxNumpyArray.cpp.orig 2015-04-27 21:30:38 UTC
++++ src/Common/CxNumpyArray.cpp
+@@ -22,6 +22,7 @@
+ */
+
+ #include <stdint.h>
++#include <string>
+ #include "CxNumpyArray.h"
+
+ #ifdef _MSC_VER
diff --git a/science/iboview/files/patch-src_Common_CxStorageDevice.h b/science/iboview/files/patch-src_Common_CxStorageDevice.h
new file mode 100644
index 000000000000..7f8ad8e0488e
--- /dev/null
+++ b/science/iboview/files/patch-src_Common_CxStorageDevice.h
@@ -0,0 +1,10 @@
+--- src/Common/CxStorageDevice.h.orig 2017-04-30 20:26:11 UTC
++++ src/Common/CxStorageDevice.h
+@@ -26,6 +26,7 @@
+
+ #include <vector>
+ #include <map>
++#include <stdlib.h>
+ #include "CxTypes.h"
+
+ namespace ct {
diff --git a/science/iboview/pkg-descr b/science/iboview/pkg-descr
new file mode 100644
index 000000000000..03fd8e0cd427
--- /dev/null
+++ b/science/iboview/pkg-descr
@@ -0,0 +1,7 @@
+Program for analyzing molecular electronic structure
+
+Iboview can visualize electronic structure from first-principles DFT,
+in terms of intuitive concepts (partial charges, bond orders,
+bond orbitals), even in systems with complex or unusual bonding.
+
+WWW: http://www.iboview.org/