aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-04-25 11:14:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-04-25 11:14:36 +0000
commite1c55894090980ca001936366276f36135fc0afe (patch)
tree28292bbf04b9001c3dac531fb093bd6229b97f06 /science
parentf6257de2c32fcd99df23c68a5b47da9da93207f2 (diff)
downloadports-e1c55894090980ca001936366276f36135fc0afe.tar.gz
ports-e1c55894090980ca001936366276f36135fc0afe.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/kst/Makefile8
-rw-r--r--science/kst/distinfo6
-rw-r--r--science/kst/files/patch-kst__src__widgets__Makefile.am32
-rw-r--r--science/kst/pkg-plist13
-rw-r--r--science/kst2/Makefile8
-rw-r--r--science/kst2/distinfo6
-rw-r--r--science/kst2/files/patch-kst__src__widgets__Makefile.am32
-rw-r--r--science/kst2/pkg-plist13
8 files changed, 104 insertions, 14 deletions
diff --git a/science/kst/Makefile b/science/kst/Makefile
index 79f63dd87f9f..036ba51dec48 100644
--- a/science/kst/Makefile
+++ b/science/kst/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= kst
-PORTVERSION= 1.8.0
-PORTREVISION= 4
+PORTVERSION= 1.9.1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/apps/KDE3.x/scientific
@@ -30,7 +29,7 @@ OPTIONS= NETCDF "Enable netcdf file support" off \
MAN1= kst.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_NETCDF)
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
@@ -53,6 +52,7 @@ pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${SH} admin/cvs.sh dist)
@${REINPLACE_CMD} -e 's|@kde_widgetdir@|@prefix@/lib/kde3/plugins/designer|' \
${WRKSRC}/kst/src/widgets/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|et||;/^SUBDIRS/s|pt||' ${WRKSRC}/doc/Makefile.in
.if !defined(WITH_NETCDF)
@${REINPLACE_CMD} -e 's| netcdf||g' ${WRKSRC}/kst/src/datasources/Makefile.in
.endif
@@ -60,4 +60,4 @@ pre-configure:
@${REINPLACE_CMD} -e 's| cdf||g' ${WRKSRC}/kst/src/datasources/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/kst/distinfo b/science/kst/distinfo
index 422bfbd7b7dc..7272633828a0 100644
--- a/science/kst/distinfo
+++ b/science/kst/distinfo
@@ -1,3 +1,3 @@
-MD5 (kst-1.8.0.tar.gz) = fd137c317d46e268cff630e2a9bc3461
-SHA256 (kst-1.8.0.tar.gz) = 6210c18967442c5509ccf80684199255a67c3569aeb2176685647702f9c2a8bb
-SIZE (kst-1.8.0.tar.gz) = 21378284
+MD5 (kst-1.9.1.tar.gz) = d378d5a88b8bd26a746146facd07811d
+SHA256 (kst-1.9.1.tar.gz) = 948c87300bfd45063a0dfb6aac96f6e561dd94b18f6115fac21ea2629f528b4a
+SIZE (kst-1.9.1.tar.gz) = 22630137
diff --git a/science/kst/files/patch-kst__src__widgets__Makefile.am b/science/kst/files/patch-kst__src__widgets__Makefile.am
new file mode 100644
index 000000000000..acc4f8bd50ea
--- /dev/null
+++ b/science/kst/files/patch-kst__src__widgets__Makefile.am
@@ -0,0 +1,32 @@
+--- ./kst/src/widgets/Makefile.am.orig 2010-03-29 15:24:46.000000000 +0400
++++ ./kst/src/widgets/Makefile.am 2010-04-24 00:28:43.386713647 +0400
+@@ -12,7 +12,7 @@
+ # If you wish to have access to the widgets in the Qt designer uncomment
+ # the line below, and all other lines starting with ###, and rebuild.
+ #
+-# kde_widget_LTLIBRARIES = kstwidgets.la
++kde_widget_LTLIBRARIES = kstwidgets.la
+
+ libkstwidgets_la_SOURCES = \
+ kstbackbuffer.cpp \
+@@ -39,16 +39,16 @@
+ libkstwidgets_la_LDFLAGS = -version-info @KST_LIBKST_VERSION@ $(all_libraries) -no-undefined
+ libkstwidgets_la_LIBADD = $(LIB_KIO) ../libkstmath/libkstmath.la
+
+-### kstwidgets_la_LDFLAGS = $(KDE_PLUGIN) -module $(all_libraries)
+-### kstwidgets_la_LIBADD = libkstwidgets.la
+-### kstwidgets_la_SOURCES = kstwidgets.cpp
++kstwidgets_la_LDFLAGS = $(KDE_PLUGIN) -module $(all_libraries)
++kstwidgets_la_LIBADD = libkstwidgets.la
++kstwidgets_la_SOURCES = kstwidgets.cpp
+
+ METASOURCES=AUTO
+
+ # set the include path for X, qt and KDE
+ INCLUDES=-I$(top_srcdir)/kst/src/extdate -I$(top_srcdir)/kst/src/libkst -I../libkst -I$(top_srcdir)/kst/src/libkstmath -I$(top_srcdir) $(KMDI_INCLUDES) $(all_includes)
+
+-### kstwidgets.lo: curveappearancewidget.h curveplacementwidget.h datarangewidget.h editmultiplewidget.h fftoptionswidget.h matrixselector.h scalarselector.h stringselector.h vectorselector.h comboboxselection.h
++kstwidgets.lo: curveappearancewidget.h curveplacementwidget.h datarangewidget.h editmultiplewidget.h fftoptionswidget.h matrixselector.h scalarselector.h stringselector.h vectorselector.h comboboxselection.h
+ scalarselector.lo: comboboxselection.h
+ vectorselector.lo: comboboxselection.h
+ matrixselector.lo: comboboxselection.h
diff --git a/science/kst/pkg-plist b/science/kst/pkg-plist
index 7a14323ce1c3..cecc82f4e793 100644
--- a/science/kst/pkg-plist
+++ b/science/kst/pkg-plist
@@ -1,6 +1,7 @@
bin/d2asc
bin/kst
bin/kstcmd
+bin/planckDateRange
include/kst_export.h
include/kstdatasource.h
include/kstdateparser.h
@@ -136,9 +137,15 @@ lib/kde3/kstobject_periodogram.so
lib/kde3/kstobject_phase.a
lib/kde3/kstobject_phase.la
lib/kde3/kstobject_phase.so
+lib/kde3/kstobject_planckLatestDate.a
+lib/kde3/kstobject_planckLatestDate.la
+lib/kde3/kstobject_planckLatestDate.so
lib/kde3/kstobject_polynomial.a
lib/kde3/kstobject_polynomial.la
lib/kde3/kstobject_polynomial.so
+lib/kde3/kstobject_reverse.a
+lib/kde3/kstobject_reverse.la
+lib/kde3/kstobject_reverse.so
lib/kde3/kstobject_shift.a
lib/kde3/kstobject_shift.la
lib/kde3/kstobject_shift.so
@@ -360,6 +367,7 @@ share/doc/HTML/da/kst/tutorial.docbook
share/doc/HTML/de/kst/dcop-chapter.docbook
share/doc/HTML/de/kst/intro-chapter.docbook
share/doc/HTML/de/kst/license-chapter.docbook
+share/doc/HTML/en/kst/CMakeLists.txt
share/doc/HTML/en/kst/Diagram-kst-data-datatypes.png
share/doc/HTML/en/kst/Diagram-kst-data-framesconcept.png
share/doc/HTML/en/kst/Diagram-kst-data-matrix.png
@@ -385,6 +393,7 @@ share/doc/HTML/en/kst/Formula-kst-linefitequation.png
share/doc/HTML/en/kst/Formula-kst-linefitsumofsquaredresiduals.png
share/doc/HTML/en/kst/Formula-kst-lorentzianfitequation.png
share/doc/HTML/en/kst/Formula-kst-lowpass.png
+share/doc/HTML/en/kst/Formula-kst-normalization.png
share/doc/HTML/en/kst/Formula-kst-polynomialfitequation.png
share/doc/HTML/en/kst/Formula-kst-sinusoidfitequation.png
share/doc/HTML/en/kst/Formulat-kst-DFT-freq.png
@@ -521,8 +530,10 @@ share/doc/HTML/en/kst/Screenshot-kst-plugins-highpassfilter.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-interpolation-eg.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-interpolationakimaspline.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-noiseaddition.png
+share/doc/HTML/en/kst/Screenshot-kst-plugins-normalization.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-periodogram.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-phase.png
+share/doc/HTML/en/kst/Screenshot-kst-plugins-reverse.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-shift.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-statistics.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-syncbin.png
@@ -1033,7 +1044,9 @@ share/services/kst/kstobject_noise_addition.desktop
share/services/kst/kstobject_normalization.desktop
share/services/kst/kstobject_periodogram.desktop
share/services/kst/kstobject_phase.desktop
+share/services/kst/kstobject_planckLatestDate.desktop
share/services/kst/kstobject_polynomial.desktop
+share/services/kst/kstobject_reverse.desktop
share/services/kst/kstobject_shift.desktop
share/services/kst/kstobject_spectral_normalization.desktop
share/services/kst/kstobject_statistics.desktop
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 79f63dd87f9f..036ba51dec48 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= kst
-PORTVERSION= 1.8.0
-PORTREVISION= 4
+PORTVERSION= 1.9.1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/apps/KDE3.x/scientific
@@ -30,7 +29,7 @@ OPTIONS= NETCDF "Enable netcdf file support" off \
MAN1= kst.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_NETCDF)
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
@@ -53,6 +52,7 @@ pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${SH} admin/cvs.sh dist)
@${REINPLACE_CMD} -e 's|@kde_widgetdir@|@prefix@/lib/kde3/plugins/designer|' \
${WRKSRC}/kst/src/widgets/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|et||;/^SUBDIRS/s|pt||' ${WRKSRC}/doc/Makefile.in
.if !defined(WITH_NETCDF)
@${REINPLACE_CMD} -e 's| netcdf||g' ${WRKSRC}/kst/src/datasources/Makefile.in
.endif
@@ -60,4 +60,4 @@ pre-configure:
@${REINPLACE_CMD} -e 's| cdf||g' ${WRKSRC}/kst/src/datasources/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/kst2/distinfo b/science/kst2/distinfo
index 422bfbd7b7dc..7272633828a0 100644
--- a/science/kst2/distinfo
+++ b/science/kst2/distinfo
@@ -1,3 +1,3 @@
-MD5 (kst-1.8.0.tar.gz) = fd137c317d46e268cff630e2a9bc3461
-SHA256 (kst-1.8.0.tar.gz) = 6210c18967442c5509ccf80684199255a67c3569aeb2176685647702f9c2a8bb
-SIZE (kst-1.8.0.tar.gz) = 21378284
+MD5 (kst-1.9.1.tar.gz) = d378d5a88b8bd26a746146facd07811d
+SHA256 (kst-1.9.1.tar.gz) = 948c87300bfd45063a0dfb6aac96f6e561dd94b18f6115fac21ea2629f528b4a
+SIZE (kst-1.9.1.tar.gz) = 22630137
diff --git a/science/kst2/files/patch-kst__src__widgets__Makefile.am b/science/kst2/files/patch-kst__src__widgets__Makefile.am
new file mode 100644
index 000000000000..acc4f8bd50ea
--- /dev/null
+++ b/science/kst2/files/patch-kst__src__widgets__Makefile.am
@@ -0,0 +1,32 @@
+--- ./kst/src/widgets/Makefile.am.orig 2010-03-29 15:24:46.000000000 +0400
++++ ./kst/src/widgets/Makefile.am 2010-04-24 00:28:43.386713647 +0400
+@@ -12,7 +12,7 @@
+ # If you wish to have access to the widgets in the Qt designer uncomment
+ # the line below, and all other lines starting with ###, and rebuild.
+ #
+-# kde_widget_LTLIBRARIES = kstwidgets.la
++kde_widget_LTLIBRARIES = kstwidgets.la
+
+ libkstwidgets_la_SOURCES = \
+ kstbackbuffer.cpp \
+@@ -39,16 +39,16 @@
+ libkstwidgets_la_LDFLAGS = -version-info @KST_LIBKST_VERSION@ $(all_libraries) -no-undefined
+ libkstwidgets_la_LIBADD = $(LIB_KIO) ../libkstmath/libkstmath.la
+
+-### kstwidgets_la_LDFLAGS = $(KDE_PLUGIN) -module $(all_libraries)
+-### kstwidgets_la_LIBADD = libkstwidgets.la
+-### kstwidgets_la_SOURCES = kstwidgets.cpp
++kstwidgets_la_LDFLAGS = $(KDE_PLUGIN) -module $(all_libraries)
++kstwidgets_la_LIBADD = libkstwidgets.la
++kstwidgets_la_SOURCES = kstwidgets.cpp
+
+ METASOURCES=AUTO
+
+ # set the include path for X, qt and KDE
+ INCLUDES=-I$(top_srcdir)/kst/src/extdate -I$(top_srcdir)/kst/src/libkst -I../libkst -I$(top_srcdir)/kst/src/libkstmath -I$(top_srcdir) $(KMDI_INCLUDES) $(all_includes)
+
+-### kstwidgets.lo: curveappearancewidget.h curveplacementwidget.h datarangewidget.h editmultiplewidget.h fftoptionswidget.h matrixselector.h scalarselector.h stringselector.h vectorselector.h comboboxselection.h
++kstwidgets.lo: curveappearancewidget.h curveplacementwidget.h datarangewidget.h editmultiplewidget.h fftoptionswidget.h matrixselector.h scalarselector.h stringselector.h vectorselector.h comboboxselection.h
+ scalarselector.lo: comboboxselection.h
+ vectorselector.lo: comboboxselection.h
+ matrixselector.lo: comboboxselection.h
diff --git a/science/kst2/pkg-plist b/science/kst2/pkg-plist
index 7a14323ce1c3..cecc82f4e793 100644
--- a/science/kst2/pkg-plist
+++ b/science/kst2/pkg-plist
@@ -1,6 +1,7 @@
bin/d2asc
bin/kst
bin/kstcmd
+bin/planckDateRange
include/kst_export.h
include/kstdatasource.h
include/kstdateparser.h
@@ -136,9 +137,15 @@ lib/kde3/kstobject_periodogram.so
lib/kde3/kstobject_phase.a
lib/kde3/kstobject_phase.la
lib/kde3/kstobject_phase.so
+lib/kde3/kstobject_planckLatestDate.a
+lib/kde3/kstobject_planckLatestDate.la
+lib/kde3/kstobject_planckLatestDate.so
lib/kde3/kstobject_polynomial.a
lib/kde3/kstobject_polynomial.la
lib/kde3/kstobject_polynomial.so
+lib/kde3/kstobject_reverse.a
+lib/kde3/kstobject_reverse.la
+lib/kde3/kstobject_reverse.so
lib/kde3/kstobject_shift.a
lib/kde3/kstobject_shift.la
lib/kde3/kstobject_shift.so
@@ -360,6 +367,7 @@ share/doc/HTML/da/kst/tutorial.docbook
share/doc/HTML/de/kst/dcop-chapter.docbook
share/doc/HTML/de/kst/intro-chapter.docbook
share/doc/HTML/de/kst/license-chapter.docbook
+share/doc/HTML/en/kst/CMakeLists.txt
share/doc/HTML/en/kst/Diagram-kst-data-datatypes.png
share/doc/HTML/en/kst/Diagram-kst-data-framesconcept.png
share/doc/HTML/en/kst/Diagram-kst-data-matrix.png
@@ -385,6 +393,7 @@ share/doc/HTML/en/kst/Formula-kst-linefitequation.png
share/doc/HTML/en/kst/Formula-kst-linefitsumofsquaredresiduals.png
share/doc/HTML/en/kst/Formula-kst-lorentzianfitequation.png
share/doc/HTML/en/kst/Formula-kst-lowpass.png
+share/doc/HTML/en/kst/Formula-kst-normalization.png
share/doc/HTML/en/kst/Formula-kst-polynomialfitequation.png
share/doc/HTML/en/kst/Formula-kst-sinusoidfitequation.png
share/doc/HTML/en/kst/Formulat-kst-DFT-freq.png
@@ -521,8 +530,10 @@ share/doc/HTML/en/kst/Screenshot-kst-plugins-highpassfilter.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-interpolation-eg.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-interpolationakimaspline.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-noiseaddition.png
+share/doc/HTML/en/kst/Screenshot-kst-plugins-normalization.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-periodogram.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-phase.png
+share/doc/HTML/en/kst/Screenshot-kst-plugins-reverse.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-shift.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-statistics.png
share/doc/HTML/en/kst/Screenshot-kst-plugins-syncbin.png
@@ -1033,7 +1044,9 @@ share/services/kst/kstobject_noise_addition.desktop
share/services/kst/kstobject_normalization.desktop
share/services/kst/kstobject_periodogram.desktop
share/services/kst/kstobject_phase.desktop
+share/services/kst/kstobject_planckLatestDate.desktop
share/services/kst/kstobject_polynomial.desktop
+share/services/kst/kstobject_reverse.desktop
share/services/kst/kstobject_shift.desktop
share/services/kst/kstobject_spectral_normalization.desktop
share/services/kst/kstobject_statistics.desktop