aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:11:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:11:56 +0000
commite40cb3d1c8feb71dfb9e64fc0aab900e9f15c1a9 (patch)
treeec63d765808c1b987d52bcea7df8f6bedda8b6f1 /science
parentc9ecdc03654110d7c4589f9ad30cfefc147e7253 (diff)
downloadports-e40cb3d1c8feb71dfb9e64fc0aab900e9f15c1a9.tar.gz
ports-e40cb3d1c8feb71dfb9e64fc0aab900e9f15c1a9.zip
Simplify Makefile
- Use shared OPENMPI_DESC - Remove OPENMPI3 option
Notes
Notes: svn path=/head/; revision=567626
Diffstat (limited to 'science')
-rw-r--r--science/pnetcdf/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index 2d2d6bdf1c5f..acd7ebf277e2 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -16,7 +16,7 @@ USES= fortran gmake pathfix perl5 tar:bzip2
USE_PERL5= build
CFLAGS+= -fPIC
-CONFIGURE_ARGS= ac_cv_fc_compiler_nag=no
+CONFIGURE_ARGS= --with-mpi=${MPI_HOME} ac_cv_fc_compiler_nag=no
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
@@ -26,17 +26,11 @@ CONFLICTS_INSTALL= hdf-4.*
OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= MPI
-OPTIONS_SINGLE_MPI= OPENMPI OPENMPI3 MPICH
+OPTIONS_SINGLE_MPI= OPENMPI MPICH
OPTIONS_DEFAULT=OPENMPI
-OPENMPI_DESC= Parallel processing support via Open MPI (current)
-OPENMPI3_DESC= Parallel processing support via Open MPI 3.x
-
-MPICH_CONFIGURE_ON= --with-mpi=${LOCALBASE}
-MPICH_LIB_DEPENDS= libmpich.so:net/mpich
-OPENMPI_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi
-OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
-OPENMPI3_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi3
-OPENMPI3_LIB_DEPENDS= libmpi.so:net/openmpi3
+
+MPICH_USES= mpi:mpich
+OPENMPI_USES= mpi:openmpi
.include <bsd.port.pre.mk>