aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-07-27 13:00:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-07-27 13:16:51 +0000
commite74986e25e061eb40be766759d89e545bab74089 (patch)
treef4f79216a658b843f6b439725b708771efe07795 /science
parent6e956b306e96701704da249305ab3dbfc6b823ed (diff)
downloadports-e74986e25e061eb40be766759d89e545bab74089.tar.gz
ports-e74986e25e061eb40be766759d89e545bab74089.zip
science/py-PubChemPy: New port: Simple Python wrapper around the PubChem PUG REST API
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-PubChemPy/Makefile18
-rw-r--r--science/py-PubChemPy/distinfo3
-rw-r--r--science/py-PubChemPy/files/example.py5
-rw-r--r--science/py-PubChemPy/pkg-descr6
5 files changed, 33 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 7cf6897ba403..0981b0aa016a 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -220,6 +220,7 @@
SUBDIR += py-MDAnalysis
SUBDIR += py-MDAnalysisTests
SUBDIR += py-OpenFermion
+ SUBDIR += py-PubChemPy
SUBDIR += py-PyFR
SUBDIR += py-SimpleSpectral
SUBDIR += py-abipy
diff --git a/science/py-PubChemPy/Makefile b/science/py-PubChemPy/Makefile
new file mode 100644
index 000000000000..a187183c085d
--- /dev/null
+++ b/science/py-PubChemPy/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= PubChemPy
+DISTVERSION= 1.0.4
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simple Python wrapper around the PubChem PUG REST API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-PubChemPy/distinfo b/science/py-PubChemPy/distinfo
new file mode 100644
index 000000000000..5f989603e6df
--- /dev/null
+++ b/science/py-PubChemPy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627390335
+SHA256 (PubChemPy-1.0.4.tar.gz) = 24e9dc2fc90ab153b2764bf805e510b1410700884faf0510a9e7cf0d61d8ed0e
+SIZE (PubChemPy-1.0.4.tar.gz) = 29767
diff --git a/science/py-PubChemPy/files/example.py b/science/py-PubChemPy/files/example.py
new file mode 100644
index 000000000000..1154ac1f1622
--- /dev/null
+++ b/science/py-PubChemPy/files/example.py
@@ -0,0 +1,5 @@
+from pubchempy import get_compounds, Compound
+comp = Compound.from_cid(1423)
+print(comp.isomeric_smiles)
+comps = get_compounds('Aspirin', 'name')
+print(comps[0].xlogp)
diff --git a/science/py-PubChemPy/pkg-descr b/science/py-PubChemPy/pkg-descr
new file mode 100644
index 000000000000..75d7c85cf972
--- /dev/null
+++ b/science/py-PubChemPy/pkg-descr
@@ -0,0 +1,6 @@
+PubChemPy provides a way to interact with PubChem in Python. It allows chemical
+searches by name, substructure and similarity, chemical standardization,
+conversion between chemical file formats, depiction and retrieval of chemical
+properties.
+
+WWW: https://github.com/mcs07/PubChemPy