aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:47:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:52 +0000
commitf6656e1d8323b17d1fe3bfd49b9d0d872d343cdc (patch)
tree27f618eeaa99caa3e801f1befe7ba0d4e22e3a66 /science
parent5d805bddeaf471555cab2cba50da157975f1e05d (diff)
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-asdf-transform-schemas/Makefile30
-rw-r--r--science/py-asdf-transform-schemas/distinfo3
-rw-r--r--science/py-asdf-transform-schemas/pkg-descr5
4 files changed, 39 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 1fda6bc5fc13..528822ddd742 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -251,6 +251,7 @@
SUBDIR += py-access
SUBDIR += py-asdf
SUBDIR += py-asdf-standard
+ SUBDIR += py-asdf-transform-schemas
SUBDIR += py-ase
SUBDIR += py-avogadrolibs
SUBDIR += py-cdo
diff --git a/science/py-asdf-transform-schemas/Makefile b/science/py-asdf-transform-schemas/Makefile
new file mode 100644
index 000000000000..45f6cc9d5a83
--- /dev/null
+++ b/science/py-asdf-transform-schemas/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= asdf-transform-schemas
+PORTVERSION= 0.2.2
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= asdf_transform_schemas-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= ASDF schemas for transforms
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asdf-standard>=1.0.1:science/py-asdf-standard@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=3:devel/py-importlib-resources@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/py-asdf-transform-schemas/distinfo b/science/py-asdf-transform-schemas/distinfo
new file mode 100644
index 000000000000..164b2a45fb57
--- /dev/null
+++ b/science/py-asdf-transform-schemas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646057860
+SHA256 (asdf_transform_schemas-0.2.2.tar.gz) = f71a9309ed3ebd09b1937ae857c94cec92887870440eb3e9868bbbed72656b15
+SIZE (asdf_transform_schemas-0.2.2.tar.gz) = 50356
diff --git a/science/py-asdf-transform-schemas/pkg-descr b/science/py-asdf-transform-schemas/pkg-descr
new file mode 100644
index 000000000000..8c2b03d8f6bb
--- /dev/null
+++ b/science/py-asdf-transform-schemas/pkg-descr
@@ -0,0 +1,5 @@
+This package provides ASDF schemas for validating transform tags. Users should
+not need to install this directly; instead, install an implementation package
+such as asdf-astropy, which includes asdf-transform-schemas as a dependency.
+
+WWW: https://github.com/asdf-format/asdf-transform-schemas