aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-24 07:39:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-24 07:39:06 +0000
commitfb181fc51b0cbda9688d8eeafba9ca40fe7fc1d7 (patch)
treea844ef709a3e0f5fc15ae1d3a2db788f5b26d530 /science
parenta26d4c8c0cc1c2a28c8c7cdd37ab957606c067ed (diff)
downloadports-fb181fc51b0cbda9688d8eeafba9ca40fe7fc1d7.tar.gz
ports-fb181fc51b0cbda9688d8eeafba9ca40fe7fc1d7.zip
New port: science/libecpint: Library for the evaluation of integrals over effective core potentials
Notes
Notes: svn path=/head/; revision=566452
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/libecpint/Makefile31
-rw-r--r--science/libecpint/distinfo3
-rw-r--r--science/libecpint/pkg-descr7
-rw-r--r--science/libecpint/pkg-plist35
5 files changed, 77 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 2aa8c91622fc..bda8f56e11bf 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -121,6 +121,7 @@
SUBDIR += libccp4
SUBDIR += libcint
SUBDIR += libctl
+ SUBDIR += libecpint
SUBDIR += libefp
SUBDIR += libgeodecomp
SUBDIR += libghemical
diff --git a/science/libecpint/Makefile b/science/libecpint/Makefile
new file mode 100644
index 000000000000..2023436d096a
--- /dev/null
+++ b/science/libecpint/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= libecpint
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.5
+CATEGORIES= science devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for the evaluation of integrals over effective core potentials
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpugixml.so:textproc/pugixml
+
+USES= cmake compiler:c++11-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= robashaw
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= LIBECPINT_BUILD_TESTS LIBECPINT_BUILD_DOCS
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DLIBECPINT_BUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ctest
+
+.include <bsd.port.mk>
diff --git a/science/libecpint/distinfo b/science/libecpint/distinfo
new file mode 100644
index 000000000000..3aaebb5fcfde
--- /dev/null
+++ b/science/libecpint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614151277
+SHA256 (robashaw-libecpint-v1.0.5_GH0.tar.gz) = 3ad5ff342b1bc870f5992c296e8bd8aa590c21a9b14333958c601f8916d6f532
+SIZE (robashaw-libecpint-v1.0.5_GH0.tar.gz) = 1313876
diff --git a/science/libecpint/pkg-descr b/science/libecpint/pkg-descr
new file mode 100644
index 000000000000..99e385a1f9cf
--- /dev/null
+++ b/science/libecpint/pkg-descr
@@ -0,0 +1,7 @@
+Libecpint is a C++ library for the efficient evaluation of integrals over
+ab initio effective core potentials, using a mixture of generated, recursive
+code and Gauss-Chebyshev quadrature. It is designed to be standalone and
+generic, and is now in its first stable release. If you experience any problems
+please raise an issue here; contributions and suggestions are also welcome.
+
+WWW: https://github.com/robashaw/libecpint
diff --git a/science/libecpint/pkg-plist b/science/libecpint/pkg-plist
new file mode 100644
index 000000000000..45d1b03ff717
--- /dev/null
+++ b/science/libecpint/pkg-plist
@@ -0,0 +1,35 @@
+include/libecpint.hpp
+include/libecpint/angular.hpp
+include/libecpint/api.hpp
+include/libecpint/bessel.hpp
+include/libecpint/config.hpp
+include/libecpint/config.hpp.in
+include/libecpint/ecp.hpp
+include/libecpint/ecpint.hpp
+include/libecpint/gaussquad.hpp
+include/libecpint/gshell.hpp
+include/libecpint/mathutil.hpp
+include/libecpint/multiarr.hpp
+include/libecpint/qgen.hpp
+include/libecpint/radial.hpp
+lib/cmake/ecpint/ecpint-config-version.cmake
+lib/cmake/ecpint/ecpint-config.cmake
+lib/cmake/ecpint/ecpint-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ecpint/ecpint-targets.cmake
+lib/libFaddeeva.so
+lib/libFaddeeva.so.1
+lib/libecpint.so
+lib/libecpint.so.1
+%%DATADIR%%/parseecp.py
+%%DATADIR%%/raw/ecp10mdf.ecp
+%%DATADIR%%/raw/ecp28mdf.ecp
+%%DATADIR%%/raw/ecp46mdf.ecp
+%%DATADIR%%/raw/ecp60mdf.ecp
+%%DATADIR%%/raw/ecp78mdf.ecp
+%%DATADIR%%/raw/lanl2dz.ecp
+%%DATADIR%%/xml/ecp10mdf.xml
+%%DATADIR%%/xml/ecp28mdf.xml
+%%DATADIR%%/xml/ecp46mdf.xml
+%%DATADIR%%/xml/ecp60mdf.xml
+%%DATADIR%%/xml/ecp78mdf.xml
+%%DATADIR%%/xml/lanl2dz.xml