aboutsummaryrefslogtreecommitdiff
path: root/security/1password-client
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2017-09-06 22:50:07 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2017-09-06 22:50:07 +0000
commitf7eb3ac4b7cbc2485727b9273f987989b0db5b07 (patch)
tree52a11bf599bf0cc4c0e9765f252b39d693018933 /security/1password-client
parent5703d29e995b78f21cb0c33135f62497b80bbc90 (diff)
downloadports-f7eb3ac4b7cbc2485727b9273f987989b0db5b07.tar.gz
ports-f7eb3ac4b7cbc2485727b9273f987989b0db5b07.zip
Add the official 1Password CLI client. It is provided by AgileBits as precompiled
binaries. Its binary is named op, but this port is being called 1password-client to avoid conflict with security/op. The binary name itself still conflicts though. WWW: https://support.1password.com/command-line-getting-started/
Notes
Notes: svn path=/head/; revision=449379
Diffstat (limited to 'security/1password-client')
-rw-r--r--security/1password-client/Makefile40
-rw-r--r--security/1password-client/distinfo7
-rw-r--r--security/1password-client/pkg-descr4
3 files changed, 51 insertions, 0 deletions
diff --git a/security/1password-client/Makefile b/security/1password-client/Makefile
new file mode 100644
index 000000000000..04b42ce5f0ee
--- /dev/null
+++ b/security/1password-client/Makefile
@@ -0,0 +1,40 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= 1password-client
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= https://cache.agilebits.com/dist/1P/op/pkg/v${PORTVERSION}/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= 1Password CLI client
+
+ONLY_FOR_ARCHS= amd64 arm i386
+
+USES= zip
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/op
+CONFLICTS_INSTALL= security/op
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/op ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+DISTNAME= op_freebsd_amd64_v${PORTVERSION}
+.elif ${ARCH} == "aarch64"
+DISTNAME= op_freebsd_arm_v${PORTVERSION}
+.elif ${ARCH} == "i386"
+DISTNAME= op_freebsd_386_v${PORTVERSION}
+.endif
+
+.if ${.TARGETS} == "makesum"
+DISTFILES= op_freebsd_amd64_v${PORTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_arm_v${PORTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_386_v${PORTVERSION}${EXTRACT_SUFX}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/1password-client/distinfo b/security/1password-client/distinfo
new file mode 100644
index 000000000000..1991e73b98eb
--- /dev/null
+++ b/security/1password-client/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1504738054
+SHA256 (op_freebsd_amd64_v0.1.zip) = ea0272132580269ba515b078024f99200ebcebe039779ee104a4abc1d034a5c5
+SIZE (op_freebsd_amd64_v0.1.zip) = 2190194
+SHA256 (op_freebsd_arm_v0.1.zip) = d0155036027b83e3c2097d9fc84bfbe42abf4ce69a90a66152c969c73e5208cd
+SIZE (op_freebsd_arm_v0.1.zip) = 2044076
+SHA256 (op_freebsd_386_v0.1.zip) = 4ff645ae808aa5332a69c6e124685d6db1ac35b9f9548c2d017f8d20f7e0a7dc
+SIZE (op_freebsd_386_v0.1.zip) = 2028491
diff --git a/security/1password-client/pkg-descr b/security/1password-client/pkg-descr
new file mode 100644
index 000000000000..2cafee44ef3a
--- /dev/null
+++ b/security/1password-client/pkg-descr
@@ -0,0 +1,4 @@
+This is a command-line interface to the 1Password password management
+service.
+
+WWW: https://support.1password.com/command-line-getting-started/