aboutsummaryrefslogtreecommitdiff
path: root/security/2fa
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-14 17:35:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-14 17:35:44 +0000
commitbb05e08a40ef40ca3bfda79120691eda7b0535be (patch)
treec796edf9ac142cb170dcc62dfbf1bcb5e6cad206 /security/2fa
parent38211887276f1f8854a18347ded9f347a7c25a43 (diff)
downloadports-bb05e08a40ef40ca3bfda79120691eda7b0535be.tar.gz
ports-bb05e08a40ef40ca3bfda79120691eda7b0535be.zip
security/2fa: Unbreak by adding GOCACHE=off
Using ${MAKE_ENV} helped many other Go ports, but not this one. Now added GOCACHE=off that turns the cache off. Approved by: portmgr (port compliance, infrastructure)
Notes
Notes: svn path=/head/; revision=464513
Diffstat (limited to 'security/2fa')
-rw-r--r--security/2fa/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/2fa/Makefile b/security/2fa/Makefile
index 8346462b39a8..5705a4df154a 100644
--- a/security/2fa/Makefile
+++ b/security/2fa/Makefile
@@ -23,10 +23,10 @@ PLIST_FILES= bin/2fa
PORTDOCS= README.md
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} GOPATH=${WRKSRC} go build -o ${PORTNAME}
+ @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} ${MAKE_ENV} GOCACHE=off GOPATH=${WRKSRC} go build -o ${PORTNAME}
do-test:
- @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} GOPATH=${WRKSRC} go test
+ @cd ${WRKSRC}/${GH_SUBDIR} && ${SETENV} ${MAKE_ENV} GOCACHE=off GOPATH=${WRKSRC} go test
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin