aboutsummaryrefslogtreecommitdiff
path: root/security/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-01-10 13:44:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-01-10 13:44:01 +0000
commit50fa7f9a0847d5c3c1860d69a2ec5088a81918b1 (patch)
treeb8447521c5429bde9c0f3b26224fff14d68df28c /security/Makefile
parent411535c7cf802c3615af62dcfdb0dfd66cc300be (diff)
downloadports-50fa7f9a0847d5c3c1860d69a2ec5088a81918b1.tar.gz
ports-50fa7f9a0847d5c3c1860d69a2ec5088a81918b1.zip
PyCryptodome is a fork of PyCrypto. It brings the following
enhancements with respect to the last official version of PyCrypto (2.6.1): * Authenticated encryption modes (GCM, CCM, EAX, SIV, OCB) * Accelerated AES on Intel platforms via AES-NI * First class support for PyPy * SHA-3 (including SHAKE XOFs) and BLAKE2 hash algorithms * Salsa20 and ChaCha20 stream ciphers * scrypt and HKDF * Deterministic DSA * Password-protected PKCS#8 key containers * Shamir's Secret Sharing scheme * Random numbers get sourced directly from the OS (and not from a CSPRNG in userspace) * Simplified install process, including better support for Windows * Cleaner RSA and DSA key generation (largely based on FIPS 186-4) * Major clean ups and simplification of the code base WWW: https://pypi.python.org/pypi/pycryptodome/ PR: 206095 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=405696
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 55c99b1908b9..18c2718b9917 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -850,6 +850,7 @@
SUBDIR += py-pyaff4
SUBDIR += py-pyclamd
SUBDIR += py-pycrypto
+ SUBDIR += py-pycryptodome
SUBDIR += py-pycryptopp
SUBDIR += py-pydeep
SUBDIR += py-pyelliptic