aboutsummaryrefslogtreecommitdiff
path: root/security/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-07 06:59:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-07 06:59:09 +0000
commitb5b94131964b53c8dbac9923abcf951d57406477 (patch)
treee5894d975a2608cb091d53c9076ad170b7364bb5 /security/Makefile
parent5a4241644719286e614b11063f0f26b2b4949eda (diff)
downloadports-b5b94131964b53c8dbac9923abcf951d57406477.tar.gz
ports-b5b94131964b53c8dbac9923abcf951d57406477.zip
PBKDF2 is a secure password hashing algorithm that uses the techniques of
"key strengthening" to make the complexity of a brute-force attack arbitrarily high. PBKDF2 uses any other cryptographic hash or cipher (by convention, usually HMAC-SHA1, but Crypt::PBKDF2 is fully pluggable), and allows for an arbitrary number of iterations of the hashing function, and a nearly unlimited output hash size (up to 2**32 - 1 times the size of the output of the backend hash). The hash is salted, as any password hash should be, and the salt may also be of arbitrary size. See also: RFC2898, PKCS#5 version 2.0: http://tools.ietf.org/html/rfc2898 WWW: http://search.cpan.org/dist/Crypt-PBKDF2/ PR: ports/146847 Submitted by: Victor Popov <v.a.popov at gmail.com>
Notes
Notes: svn path=/head/; revision=256005
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 410ae4831036..f7d1a9696db4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -445,6 +445,7 @@
SUBDIR += p5-Crypt-OpenSSL-RSA
SUBDIR += p5-Crypt-OpenSSL-Random
SUBDIR += p5-Crypt-OpenSSL-X509
+ SUBDIR += p5-Crypt-PBKDF2
SUBDIR += p5-Crypt-PGPSimple
SUBDIR += p5-Crypt-PassGen
SUBDIR += p5-Crypt-PasswdMD5