aboutsummaryrefslogtreecommitdiff
path: root/security/acme.sh
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-12-23 17:08:16 +0000
committerDan Langille <dvl@FreeBSD.org>2017-12-23 17:08:16 +0000
commit51fbb0627f6323ae83e536314ad5b0d977d6c684 (patch)
treea1e37f41da3e6c9fab927397a5cc04e6e247544f /security/acme.sh
parent09b6812547e9fa0db74614e0e838573911793ba1 (diff)
downloadports-51fbb0627f6323ae83e536314ad5b0d977d6c684.tar.gz
ports-51fbb0627f6323ae83e536314ad5b0d977d6c684.zip
Add standalone option to pull in socat
PR: 224549 Reported by: ferrao@if.ufrj.br
Notes
Notes: svn path=/head/; revision=457087
Diffstat (limited to 'security/acme.sh')
-rw-r--r--security/acme.sh/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/acme.sh/Makefile b/security/acme.sh/Makefile
index 67e0ad303c37..32d80e470a9c 100644
--- a/security/acme.sh/Makefile
+++ b/security/acme.sh/Makefile
@@ -2,6 +2,7 @@
PORTNAME= acme.sh
PORTVERSION= 2.7.5
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= dvl@FreeBSD.org
@@ -15,12 +16,15 @@ GH_ACCOUNT= Neilpang
USERS= acme
GROUPS= acme
-OPTIONS_DEFINE= DOCS BINDTOOLS
+OPTIONS_DEFINE= DOCS BINDTOOLS STANDALONE
OPTIONS_SINGLE= HTTP
OPTIONS_SINGLE_HTTP= CURL WGET
OPTIONS_DEFAULT= CURL
BINDTOOLS_DESC= Depend on bind-tools for nsupdate
BINDTOOLS_RUN_DEPENDS= ${LOCALBASE}/bin/nsupdate:dns/bind-tools
+STANDALONE_DESC= Standalone mode requres SOCAT
+STANDALONE_RUN_DEPENDS= socat>0:net/socat
+
CURL_DESC= Depend on cURL for HTTP(S) queries
WGET_DESC= Depend on Wget for HTTP(S) queries