aboutsummaryrefslogtreecommitdiff
path: root/security/acme.sh
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2019-02-25 22:31:39 +0000
committerDan Langille <dvl@FreeBSD.org>2019-02-25 22:31:39 +0000
commitff59172aad816ee481bdbb529503c6f35cf76201 (patch)
treea01ce9bcbb217494ac7f4ad59a3db5b02acaf785 /security/acme.sh
parentb6a4dec374484928507fd02930358a1b9c584def (diff)
downloadports-ff59172aad816ee481bdbb529503c6f35cf76201.tar.gz
ports-ff59172aad816ee481bdbb529503c6f35cf76201.zip
Upgrade to 2.8.0
Add a C to the syslog.conf example and comment it out Make this pass testport by moving stuff from pkg-install into the Makefile PR: 228829,236041,228791 Submitted by: Lapo Luchini <lapo@lapo.it>,Frank Wall <fw@moov.de>,Mark Felder <feld@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=493903
Diffstat (limited to 'security/acme.sh')
-rw-r--r--security/acme.sh/Makefile9
-rw-r--r--security/acme.sh/distinfo6
-rw-r--r--security/acme.sh/files/account.conf.sample5
-rw-r--r--security/acme.sh/files/acme.sh.conf3
-rw-r--r--security/acme.sh/files/pkg-install.in33
-rw-r--r--security/acme.sh/pkg-plist23
6 files changed, 38 insertions, 41 deletions
diff --git a/security/acme.sh/Makefile b/security/acme.sh/Makefile
index 222aff808dfe..6af5c526217f 100644
--- a/security/acme.sh/Makefile
+++ b/security/acme.sh/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= acme.sh
-PORTVERSION= 2.7.9
-PORTREVISION= 1
+PORTVERSION= 2.8.0
CATEGORIES= security
MAINTAINER= dvl@FreeBSD.org
@@ -36,14 +35,18 @@ WGET_RUN_DEPENDS= wget:ftp/wget
PORTDOCS= README.md
-SUB_FILES= pkg-install pkg-message
+SUB_FILES= pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/deploy ${STAGEDIR}${EXAMPLESDIR}/dnsapi
+ ${MKDIR} ${STAGEDIR}/var/db/acme/.acme.sh ${STAGEDIR}/var/db/acme/certs
( cd ${WRKSRC} && ${COPYTREE_BIN} deploy ${STAGEDIR}${EXAMPLESDIR} )
( cd ${WRKSRC} && ${COPYTREE_BIN} dnsapi ${STAGEDIR}${EXAMPLESDIR} )
${INSTALL_DATA} ${FILESDIR}/acme.sh.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/account.conf.sample ${STAGEDIR}/var/db/acme/.acme.sh
+ ${RLN} ${STAGEDIR}/${EXAMPLESDIR}/deploy ${STAGEDIR}/var/db/acme/.acme.sh
+ ${RLN} ${STAGEDIR}/${EXAMPLESDIR}/dnsapi ${STAGEDIR}/var/db/acme/.acme.sh
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/security/acme.sh/distinfo b/security/acme.sh/distinfo
index ac6599b87159..e1265c675112 100644
--- a/security/acme.sh/distinfo
+++ b/security/acme.sh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531986286
-SHA256 (Neilpang-acme.sh-2.7.9_GH0.tar.gz) = 25f8eef1a53584e3ebc653e1ae7763362ca97c40bb476ab7fee01aa50fa3a101
-SIZE (Neilpang-acme.sh-2.7.9_GH0.tar.gz) = 110323
+TIMESTAMP = 1551126720
+SHA256 (Neilpang-acme.sh-2.8.0_GH0.tar.gz) = 51d20c71e513e9fde0114de9ba3ada4e392e395981fb8d598b0ea610e183f009
+SIZE (Neilpang-acme.sh-2.8.0_GH0.tar.gz) = 127638
diff --git a/security/acme.sh/files/account.conf.sample b/security/acme.sh/files/account.conf.sample
new file mode 100644
index 000000000000..768d5c7e0834
--- /dev/null
+++ b/security/acme.sh/files/account.conf.sample
@@ -0,0 +1,5 @@
+NSUPDATE_SERVER="mydns.example.org"
+NSUPDATE_KEY="/var/db/acme/Kmydns.example.org.+165+59977.key"
+DEFAULT_DNS_SLEEP="10"
+CERT_HOME="/var/db/acme/certs"
+LOG_FILE='/var/log/acme.sh.log'
diff --git a/security/acme.sh/files/acme.sh.conf b/security/acme.sh/files/acme.sh.conf
index f2d26e670a96..0f6a19728544 100644
--- a/security/acme.sh/files/acme.sh.conf
+++ b/security/acme.sh/files/acme.sh.conf
@@ -1,6 +1,7 @@
# acme.sh configuration file for newsyslog.conf
+# commented out by default
#
# see newsyslog.conf(5) for details
#
# logfilename [owner:group] mode count size when flags [/pid_file] [sig_num]
-/var/log/acme.sh.log acme:acme 640 90 * @T00 B
+#/var/log/acme.sh.log acme:acme 640 90 * @T00 BC
diff --git a/security/acme.sh/files/pkg-install.in b/security/acme.sh/files/pkg-install.in
deleted file mode 100644
index ea3802a04f3a..000000000000
--- a/security/acme.sh/files/pkg-install.in
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-if [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d ~acme/.acme.sh ]; then
- /usr/bin/install -d -o acme -g acme -m 750 ~acme/.acme.sh
- fi
-
- if [ ! -d ~acme/certs ]; then
- /usr/bin/install -d -o acme -g acme -m 750 ~acme/certs
- fi
-
- if [ ! -d ~acme/.acme.sh/deploy ]; then
- /bin/ln -sf %%EXAMPLESDIR%%/deploy ~acme/.acme.sh
- fi
-
- if [ ! -d ~acme/.acme.sh/dnsapi ]; then
- /bin/ln -sf %%EXAMPLESDIR%%/dnsapi ~acme/.acme.sh
- fi
-
- if [ ! -f ~acme/.acme.sh/account.conf.sample ]; then
-
- /bin/cat << EOF >> ~acme/.acme.sh/account.conf.sample
-NSUPDATE_SERVER="mydns.example.org"
-NSUPDATE_KEY="/var/db/acme/Kmydns.example.org.+165+59977.key"
-DEFAULT_DNS_SLEEP="10"
-CERT_HOME="/var/db/acme/certs"
-LOG_FILE='/var/log/acme.sh.log'
-EOF
- /bin/chmod 640 ~acme/.acme.sh/account.conf.sample
- fi
-fi
diff --git a/security/acme.sh/pkg-plist b/security/acme.sh/pkg-plist
index 827714b6de88..0ef4c8108b78 100644
--- a/security/acme.sh/pkg-plist
+++ b/security/acme.sh/pkg-plist
@@ -6,6 +6,7 @@ sbin/acme.sh
%%EXAMPLESDIR%%/deploy/dovecot.sh
%%EXAMPLESDIR%%/deploy/exim4.sh
%%EXAMPLESDIR%%/deploy/fritzbox.sh
+%%EXAMPLESDIR%%/deploy/gitlab.sh
%%EXAMPLESDIR%%/deploy/haproxy.sh
%%EXAMPLESDIR%%/deploy/keychain.sh
%%EXAMPLESDIR%%/deploy/kong.sh
@@ -14,6 +15,7 @@ sbin/acme.sh
%%EXAMPLESDIR%%/deploy/nginx.sh
%%EXAMPLESDIR%%/deploy/opensshd.sh
%%EXAMPLESDIR%%/deploy/pureftpd.sh
+%%EXAMPLESDIR%%/deploy/qiniu.sh
%%EXAMPLESDIR%%/deploy/ssh.sh
%%EXAMPLESDIR%%/deploy/strongswan.sh
%%EXAMPLESDIR%%/deploy/unifi.sh
@@ -21,6 +23,7 @@ sbin/acme.sh
%%EXAMPLESDIR%%/deploy/vsftpd.sh
%%EXAMPLESDIR%%/dnsapi/README.md
%%EXAMPLESDIR%%/dnsapi/dns_acmedns.sh
+%%EXAMPLESDIR%%/dnsapi/dns_active24.sh
%%EXAMPLESDIR%%/dnsapi/dns_ad.sh
%%EXAMPLESDIR%%/dnsapi/dns_ali.sh
%%EXAMPLESDIR%%/dnsapi/dns_autodns.sh
@@ -28,6 +31,7 @@ sbin/acme.sh
%%EXAMPLESDIR%%/dnsapi/dns_azure.sh
%%EXAMPLESDIR%%/dnsapi/dns_cf.sh
%%EXAMPLESDIR%%/dnsapi/dns_cloudns.sh
+%%EXAMPLESDIR%%/dnsapi/dns_conoha.sh
%%EXAMPLESDIR%%/dnsapi/dns_cx.sh
%%EXAMPLESDIR%%/dnsapi/dns_cyon.sh
%%EXAMPLESDIR%%/dnsapi/dns_da.sh
@@ -35,15 +39,20 @@ sbin/acme.sh
%%EXAMPLESDIR%%/dnsapi/dns_dnsimple.sh
%%EXAMPLESDIR%%/dnsapi/dns_do.sh
%%EXAMPLESDIR%%/dnsapi/dns_dp.sh
+%%EXAMPLESDIR%%/dnsapi/dns_dpi.sh
%%EXAMPLESDIR%%/dnsapi/dns_dreamhost.sh
%%EXAMPLESDIR%%/dnsapi/dns_duckdns.sh
%%EXAMPLESDIR%%/dnsapi/dns_dyn.sh
%%EXAMPLESDIR%%/dnsapi/dns_dynu.sh
%%EXAMPLESDIR%%/dnsapi/dns_euserv.sh
+%%EXAMPLESDIR%%/dnsapi/dns_exoscale.sh
%%EXAMPLESDIR%%/dnsapi/dns_freedns.sh
%%EXAMPLESDIR%%/dnsapi/dns_gandi_livedns.sh
+%%EXAMPLESDIR%%/dnsapi/dns_gcloud.sh
%%EXAMPLESDIR%%/dnsapi/dns_gd.sh
+%%EXAMPLESDIR%%/dnsapi/dns_gdnsdk.sh
%%EXAMPLESDIR%%/dnsapi/dns_he.sh
+%%EXAMPLESDIR%%/dnsapi/dns_hostingde.sh
%%EXAMPLESDIR%%/dnsapi/dns_infoblox.sh
%%EXAMPLESDIR%%/dnsapi/dns_inwx.sh
%%EXAMPLESDIR%%/dnsapi/dns_ispconfig.sh
@@ -51,21 +60,33 @@ sbin/acme.sh
%%EXAMPLESDIR%%/dnsapi/dns_knot.sh
%%EXAMPLESDIR%%/dnsapi/dns_lexicon.sh
%%EXAMPLESDIR%%/dnsapi/dns_linode.sh
+%%EXAMPLESDIR%%/dnsapi/dns_linode_v4.sh
%%EXAMPLESDIR%%/dnsapi/dns_loopia.sh
%%EXAMPLESDIR%%/dnsapi/dns_lua.sh
%%EXAMPLESDIR%%/dnsapi/dns_me.sh
%%EXAMPLESDIR%%/dnsapi/dns_myapi.sh
+%%EXAMPLESDIR%%/dnsapi/dns_mydnsjp.sh
+%%EXAMPLESDIR%%/dnsapi/dns_namecheap.sh
%%EXAMPLESDIR%%/dnsapi/dns_namecom.sh
%%EXAMPLESDIR%%/dnsapi/dns_namesilo.sh
+%%EXAMPLESDIR%%/dnsapi/dns_neodigit.sh
+%%EXAMPLESDIR%%/dnsapi/dns_netcup.sh
%%EXAMPLESDIR%%/dnsapi/dns_nsone.sh
%%EXAMPLESDIR%%/dnsapi/dns_nsupdate.sh
%%EXAMPLESDIR%%/dnsapi/dns_ovh.sh
%%EXAMPLESDIR%%/dnsapi/dns_pdns.sh
+%%EXAMPLESDIR%%/dnsapi/dns_pointhq.sh
%%EXAMPLESDIR%%/dnsapi/dns_selectel.sh
%%EXAMPLESDIR%%/dnsapi/dns_servercow.sh
%%EXAMPLESDIR%%/dnsapi/dns_tele3.sh
%%EXAMPLESDIR%%/dnsapi/dns_unoeuro.sh
%%EXAMPLESDIR%%/dnsapi/dns_vscale.sh
%%EXAMPLESDIR%%/dnsapi/dns_yandex.sh
-%%EXAMPLESDIR%%/dnsapi/dns_zonomi.sh
%%EXAMPLESDIR%%/dnsapi/dns_zilore.sh
+%%EXAMPLESDIR%%/dnsapi/dns_zonomi.sh
+@sample(acme,acme,0640) /var/db/acme/.acme.sh/account.conf.sample
+/var/db/acme/.acme.sh/deploy
+/var/db/acme/.acme.sh/dnsapi
+@dir(acme,acme,0750) /var/db/acme/.acme.sh
+@dir(acme,acme,0750) /var/db/acme/certs
+@dir(acme,acme,0750) /var/db/acme