aboutsummaryrefslogtreecommitdiff
path: root/security/acmetool
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-04-05 13:00:02 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-04-05 13:00:02 +0000
commit38cff13b4af05f6477ed30bc6086262e09f69bf4 (patch)
tree09bff91689ddbac28b931dd7c0daf7eae044d6dc /security/acmetool
parent66f50ab9b1315717d1d5e8c02eaf4f5092d9316f (diff)
downloadports-38cff13b4af05f6477ed30bc6086262e09f69bf4.tar.gz
ports-38cff13b4af05f6477ed30bc6086262e09f69bf4.zip
New port, security/acmetool: An automatic certificate acquisition tool for
ACME (Let's Encrypt) WWW: https://github.com/hlandau/acme PR: 216779 Submitted by: samm@os2.kiev.ua (maintainer) Reviewed by: mat Approved by: swills (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D10280
Notes
Notes: svn path=/head/; revision=437781
Diffstat (limited to 'security/acmetool')
-rw-r--r--security/acmetool/Makefile63
-rw-r--r--security/acmetool/distinfo55
-rw-r--r--security/acmetool/pkg-descr7
-rw-r--r--security/acmetool/pkg-message5
-rw-r--r--security/acmetool/pkg-plist6
5 files changed, 136 insertions, 0 deletions
diff --git a/security/acmetool/Makefile b/security/acmetool/Makefile
new file mode 100644
index 000000000000..6df1357c4b27
--- /dev/null
+++ b/security/acmetool/Makefile
@@ -0,0 +1,63 @@
+# $FreeBSD$
+
+PORTNAME= acmetool
+PORTVERSION= 0.0.59
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= CLI tool for automatically acquiring certificates from ACME servers
+
+LICENSE= MIT
+
+BUILD_DEPENDS= go>=1.4:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= hlandau
+GH_PROJECT= acme
+GH_SUBDIR= src/github.com/hlandau/acme
+GH_TUPLE= alecthomas:template:a0175ee:template/src/github.com/alecthomas/template \
+ alecthomas:units:2efee857:units/src/github.com/alecthomas/units \
+ hlandau:goutils:0cdb66a:goutils/src/github.com/hlandau/goutils \
+ hlandau:buildinfo:337a29b:buildinfo/src/github.com/hlandau/buildinfo \
+ hlandau:dexlogconfig:244f29b:dexlogconfig/src/github.com/hlandau/dexlogconfig \
+ hlandau:xlog:197ef79:xlog/src/github.com/hlandau/xlog \
+ hlandau:easyconfig:v1.0.15:easyconfig/src/gopkg.in/hlandau/easyconfig.v1 \
+ jmhodges:clock:880ee4c:clock/src/github.com/jmhodges/clock \
+ mattn:go-isatty:30a891c:go_isatty/src/github.com/mattn/go-isatty \
+ mattn:go-runewidth:14207d2:go_runewidth/src/github.com/mattn/go-runewidth \
+ coreos:go-systemd:e97b35f:go_systemd/src/github.com/coreos/go-systemd \
+ ogier:pflag:45c278ab:pflag/src/github.com/ogier/pflag \
+ peterhellberg:link:24c1495e:link/src/github.com/peterhellberg/link \
+ satori:go.uuid:b061729:go_uuid/src/github.com/satori/go.uuid \
+ shiena:ansicolor:a422bbe9:ansi_color/src/github.com/shiena/ansicolor \
+ golang:crypto:bed1280:crypto/src/golang.org/x/crypto \
+ golang:net:41bba8d:net/src/golang.org/x/net \
+ alecthomas:kingpin:v2.2.3:kingpin/src/gopkg.in/alecthomas/kingpin.v2 \
+ mitchellh:go-wordwrap:ad45545:go_wordwrap/src/github.com/mitchellh/go-wordwrap \
+ cheggaaa:pb:v1.0.11:pb_v1/src/gopkg.in/cheggaaa/pb.v1 \
+ go-yaml:yaml:a3f3340:go_yaml/src/gopkg.in/yaml.v2 \
+ hlandau:svcutils:v1.0.10:svcutils/src/gopkg.in/hlandau/svcutils.v1 \
+ hlandau:service:v2.0.16:service/src/gopkg.in/hlandau/service.v2 \
+ hlandau:configurable:v1.0.1:configurable/src/gopkg.in/hlandau/configurable.v1 \
+ tylerb:graceful:v1.2.15:graceful/src/gopkg.in/tylerb/graceful.v1 \
+ square:go-jose:v1.1.0:go_jose/src/gopkg.in/square/go-jose.v1
+
+do-build:
+ cd ${WRKSRC}/src/github.com/hlandau/acme ; \
+ ${SETENV} GOPATH=${WRKSRC} \
+ go build -o ${WRKSRC}/bin/${PORTNAME} -ldflags "\
+ -X github.com/hlandau/acme/hooks.DefaultPath=${PREFIX}/libexec/acme/hooks \
+ -X github.com/hlandau/acme/storage.RecommendedPath=/var/db/acme \
+ -X github.com/hlandau/buildinfo.BuildInfo=${PORTNAME}-v${PORTVERSION}-freebsd-ports \
+ "\
+ github.com/hlandau/acme/cmd/acmetool
+ ${WRKSRC}/bin/${PORTNAME} --help-man > ${WRKSRC}/${PORTNAME}.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
+ ${MKDIR} ${STAGEDIR}/var/db/acme
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/acme/hooks
+
+.include <bsd.port.mk>
diff --git a/security/acmetool/distinfo b/security/acmetool/distinfo
new file mode 100644
index 000000000000..7b6e77e88a1b
--- /dev/null
+++ b/security/acmetool/distinfo
@@ -0,0 +1,55 @@
+TIMESTAMP = 1491379017
+SHA256 (hlandau-acme-v0.0.59_GH0.tar.gz) = c84bf2d7ab20fdc16b9047ebb3bca48c8e1282f92605fa2eba08f7963ef6c3b4
+SIZE (hlandau-acme-v0.0.59_GH0.tar.gz) = 131840
+SHA256 (alecthomas-template-a0175ee_GH0.tar.gz) = 18330bd4bf73af704ec42953b6106e256b58314c7931bcd5aedf41b470ee3dc8
+SIZE (alecthomas-template-a0175ee_GH0.tar.gz) = 55261
+SHA256 (alecthomas-units-2efee857_GH0.tar.gz) = 0c0a9c2c0010470e6d4e8ed5b3f59506b785cd2ca1c40773cf679f28b202dc55
+SIZE (alecthomas-units-2efee857_GH0.tar.gz) = 3440
+SHA256 (hlandau-goutils-0cdb66a_GH0.tar.gz) = 76efbb51ee4d2d615aa31bc1b2c01f8c650d0a478007754f0b9e32dc036a2f23
+SIZE (hlandau-goutils-0cdb66a_GH0.tar.gz) = 6397
+SHA256 (hlandau-buildinfo-337a29b_GH0.tar.gz) = b2678ee8f07d0dcfb96ddc47fc7d5c3ee6896eb4951dc35a22b56b647ee34789
+SIZE (hlandau-buildinfo-337a29b_GH0.tar.gz) = 2601
+SHA256 (hlandau-dexlogconfig-244f29b_GH0.tar.gz) = 55ce7d2b431a55c3827c5df975b4d8194e61ae5b5a2c273385355ec351cde4c3
+SIZE (hlandau-dexlogconfig-244f29b_GH0.tar.gz) = 1888
+SHA256 (hlandau-xlog-197ef79_GH0.tar.gz) = 0db8bcf21a74fdfd26a0890e4e9a2c2486754eb1cd168c3d798b4f171088ce72
+SIZE (hlandau-xlog-197ef79_GH0.tar.gz) = 6396
+SHA256 (hlandau-easyconfig-v1.0.15_GH0.tar.gz) = 66637ef7147e31683305ed3e9d5d19e7be98959bd45a3c5cb1d5dbb4aaa6163f
+SIZE (hlandau-easyconfig-v1.0.15_GH0.tar.gz) = 9351
+SHA256 (jmhodges-clock-880ee4c_GH0.tar.gz) = 1f80d14a42f1f30341a7040460cada7f555b1157f1ee96c826f104f46676aeb0
+SIZE (jmhodges-clock-880ee4c_GH0.tar.gz) = 5759
+SHA256 (mattn-go-isatty-30a891c_GH0.tar.gz) = 063e52b4690657d818a1a3a2097c7e8dc94ae95b1aa6a242b3096834fd1519b7
+SIZE (mattn-go-isatty-30a891c_GH0.tar.gz) = 1952
+SHA256 (mattn-go-runewidth-14207d2_GH0.tar.gz) = e665c10f4ccefe1d320fe8fe69403754c499fe79bc737f8f1d199d86ecfb7efb
+SIZE (mattn-go-runewidth-14207d2_GH0.tar.gz) = 22365
+SHA256 (coreos-go-systemd-e97b35f_GH0.tar.gz) = 5c46dbdfb9e22451f5a351c2b168d00f7d53ad37bb119ff66d40954e19abb521
+SIZE (coreos-go-systemd-e97b35f_GH0.tar.gz) = 53614
+SHA256 (ogier-pflag-45c278ab_GH0.tar.gz) = f5d30003954fc8fa2f81617cf5712bbb75926f8d854bd81f9b433650a2f3675a
+SIZE (ogier-pflag-45c278ab_GH0.tar.gz) = 15817
+SHA256 (peterhellberg-link-24c1495e_GH0.tar.gz) = 5cbb5be02a5df1cb0fe493bf483135efb413e6cd1e375f7ab9c175aa2c4cfcd7
+SIZE (peterhellberg-link-24c1495e_GH0.tar.gz) = 4194
+SHA256 (satori-go.uuid-b061729_GH0.tar.gz) = cdbe332ab1504109f04c64400cc1bb46fa8883754e92aa8ccc06b4da24c04345
+SIZE (satori-go.uuid-b061729_GH0.tar.gz) = 7608
+SHA256 (shiena-ansicolor-a422bbe9_GH0.tar.gz) = c632e2a88cfc9957cf435e7ea62d424e040f269911cd2680dec92acdd9b89c77
+SIZE (shiena-ansicolor-a422bbe9_GH0.tar.gz) = 7317
+SHA256 (golang-crypto-bed1280_GH0.tar.gz) = bf0e0f42fd7cb742892efd88bc9fd76bd96a4c979628c527a93abeced5e96092
+SIZE (golang-crypto-bed1280_GH0.tar.gz) = 1306334
+SHA256 (golang-net-41bba8d_GH0.tar.gz) = 003c999bb8c3d73cc3dae0ca48e8afcb77cf58cb6e2b25b4486ff602deacb8eb
+SIZE (golang-net-41bba8d_GH0.tar.gz) = 770083
+SHA256 (alecthomas-kingpin-v2.2.3_GH0.tar.gz) = 1950744e84f83796d39298c2a85c3895b1bf37c4e01c2fdb9f81db309c8da33c
+SIZE (alecthomas-kingpin-v2.2.3_GH0.tar.gz) = 43770
+SHA256 (mitchellh-go-wordwrap-ad45545_GH0.tar.gz) = f9ddaffa2229c278a6b61ba3f73b6d08695ef55e1cfea7d139e53728ea4d13ec
+SIZE (mitchellh-go-wordwrap-ad45545_GH0.tar.gz) = 2737
+SHA256 (cheggaaa-pb-v1.0.11_GH0.tar.gz) = 7deece92a4cc3db13e9049c0b71ef5c70b4f9052e8717fc554713c793a3f2a16
+SIZE (cheggaaa-pb-v1.0.11_GH0.tar.gz) = 10774
+SHA256 (go-yaml-yaml-a3f3340_GH0.tar.gz) = e2a3af32b0d55b2426229ea6efca85e4219209225f05fb57af55834a2dee2d1a
+SIZE (go-yaml-yaml-a3f3340_GH0.tar.gz) = 60720
+SHA256 (hlandau-svcutils-v1.0.10_GH0.tar.gz) = 8d00888d4f2cfba67afd6f40db442135791e7c8b5000af147f850e691c976e66
+SIZE (hlandau-svcutils-v1.0.10_GH0.tar.gz) = 10099
+SHA256 (hlandau-service-v2.0.16_GH0.tar.gz) = 2043784e128c6e32663903dad10c79621f2ff9ed607c2a652200b84c8e17c298
+SIZE (hlandau-service-v2.0.16_GH0.tar.gz) = 14005
+SHA256 (hlandau-configurable-v1.0.1_GH0.tar.gz) = 6252b96e836deece85e8af5d2fa9fc7f5a82f7b795d005f7a3b7804c8b43b388
+SIZE (hlandau-configurable-v1.0.1_GH0.tar.gz) = 2691
+SHA256 (tylerb-graceful-v1.2.15_GH0.tar.gz) = d8c4ff8f2d85fe265d7507ef9f71c6c29102c1a043b9c2a65cc9d3072227f31f
+SIZE (tylerb-graceful-v1.2.15_GH0.tar.gz) = 15028
+SHA256 (square-go-jose-v1.1.0_GH0.tar.gz) = 62360cffdce3e5b385e22bea52531dd4338237c0f62ea5da0e952dc5f89be94d
+SIZE (square-go-jose-v1.1.0_GH0.tar.gz) = 260576
diff --git a/security/acmetool/pkg-descr b/security/acmetool/pkg-descr
new file mode 100644
index 000000000000..3fff7d40b3a6
--- /dev/null
+++ b/security/acmetool/pkg-descr
@@ -0,0 +1,7 @@
+Acmetool is an easy-to-use command line tool for automatically acquiring
+certificates from ACME servers (such as Let's Encrypt). It is designed
+to flexibly integrate into your webserver setup to enable automatic
+verification, however, unlike the official Let's Encrypt client, it
+doesn't modify your web server configuration.
+
+WWW: https://github.com/hlandau/acme/
diff --git a/security/acmetool/pkg-message b/security/acmetool/pkg-message
new file mode 100644
index 000000000000..dac797e87792
--- /dev/null
+++ b/security/acmetool/pkg-message
@@ -0,0 +1,5 @@
+============================================================
+Use "acmetool quickstart" for initial configuration.
+
+See https://github.com/hlandau/acme for more details
+about how to configure and use the client.
diff --git a/security/acmetool/pkg-plist b/security/acmetool/pkg-plist
new file mode 100644
index 000000000000..ba09b985e182
--- /dev/null
+++ b/security/acmetool/pkg-plist
@@ -0,0 +1,6 @@
+man/man8/acmetool.8.gz
+bin/acmetool
+@dir /var/db/acme
+@dir /var/db/
+@dir libexec/acme
+@dir libexec/acme/hooks