aboutsummaryrefslogtreecommitdiff
path: root/security/aescrypt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-11-15 13:01:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-11-15 13:01:11 +0000
commit13571918af2a21a0d51daf8e816597a8d8522f02 (patch)
tree28c53beaaefbf5e0e48a9233016c87a8a433135b /security/aescrypt
parent142b841e2deac18206ce369cfe467ff5c946076d (diff)
downloadports-13571918af2a21a0d51daf8e816597a8d8522f02.tar.gz
ports-13571918af2a21a0d51daf8e816597a8d8522f02.zip
Support staging.
Notes
Notes: svn path=/head/; revision=333863
Diffstat (limited to 'security/aescrypt')
-rw-r--r--security/aescrypt/Makefile21
-rw-r--r--security/aescrypt/pkg-descr4
-rw-r--r--security/aescrypt/pkg-plist2
3 files changed, 18 insertions, 9 deletions
diff --git a/security/aescrypt/Makefile b/security/aescrypt/Makefile
index 44c3ba4cfd10..8589694576d3 100644
--- a/security/aescrypt/Makefile
+++ b/security/aescrypt/Makefile
@@ -16,15 +16,22 @@ COMMENT= Command-line AES encryption/decryption suite
GNU_CONFIGURE= yes
MAKE_ENV+= BINGRP=wheel
-NO_STAGE= yes
-MAN1= aescrypt.1 aesget.1
-MANCOMPRESSED= yes
+BINS= aescrypt aesget
-.if !defined(NOPORTDOCS)
-post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+do-install:
+.for f in ${BINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${f}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+.endfor
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/security/aescrypt/pkg-descr b/security/aescrypt/pkg-descr
index 898844a51c17..ed8eed031e35 100644
--- a/security/aescrypt/pkg-descr
+++ b/security/aescrypt/pkg-descr
@@ -11,5 +11,5 @@ From the aescrypt README.html:
management, public key signatures, etc. are all expected to be
done external to this program.
-Author: Eric Lee Green <eric@estinc.com>
-WWW: http://aescrypt.sourceforge.net/
+Author: Eric Lee Green <eric@estinc.com>
+WWW: http://aescrypt.sourceforge.net/
diff --git a/security/aescrypt/pkg-plist b/security/aescrypt/pkg-plist
index c76b0b361e8f..748cdd2b5e89 100644
--- a/security/aescrypt/pkg-plist
+++ b/security/aescrypt/pkg-plist
@@ -1,4 +1,6 @@
bin/aescrypt
bin/aesget
+man/man1/aescrypt.1.gz
+man/man1/aesget.1.gz
%%PORTDOCS%%%%DOCSDIR%%/README.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%