aboutsummaryrefslogtreecommitdiff
path: root/security/aescrypt
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2008-06-08 17:54:35 +0000
committerPeter Pentchev <roam@FreeBSD.org>2008-06-08 17:54:35 +0000
commit36f1dfc9ac5a6f8080a424ddde216380c6b80e8b (patch)
tree7c9d7db5e3329a54bb0d53e23830eab4d379dec3 /security/aescrypt
parent2f430bb6d4ed113cd4a294d45e6c053645ce1f31 (diff)
downloadports-36f1dfc9ac5a6f8080a424ddde216380c6b80e8b.tar.gz
ports-36f1dfc9ac5a6f8080a424ddde216380c6b80e8b.zip
Perform some much-needed work on aescrypt that somehow lingered for
seven years... - make aesget actually work with the default keysize (initialize it!) - do not overflow the key filename buffers while parsing command-line options - break out common code into a single file - make the read()/write() loops a bit more robust - fix lots of compiler warnings - use snprintf() instead of strcpy()/strcat() - write mdoc manual pages for aescrypt(1) and aesget(1) - install the binaries and the manual pages with the correct permission mode
Notes
Notes: svn path=/head/; revision=214507
Diffstat (limited to 'security/aescrypt')
-rw-r--r--security/aescrypt/Makefile18
-rw-r--r--security/aescrypt/distinfo3
-rw-r--r--security/aescrypt/pkg-plist4
3 files changed, 19 insertions, 6 deletions
diff --git a/security/aescrypt/Makefile b/security/aescrypt/Makefile
index 1133e75bd5e6..da24852b10d9 100644
--- a/security/aescrypt/Makefile
+++ b/security/aescrypt/Makefile
@@ -7,17 +7,27 @@
PORTNAME= aescrypt
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://aescrypt.sourceforge.net/
-MASTER_SITE_SUBDIR=aescrypt
+MASTER_SITES= SF
+
+PATCH_SITES= http://devel.ringlet.net/security/aescrypt/patches/ \
+ http://people.FreeBSD.org/~roam/ports/patches/security/aescrypt/
+PATCHFILES= aescrypt-0.7-roam-whopper-01.patch.gz
MAINTAINER= roam@FreeBSD.org
COMMENT= A command-line AES encryption/decryption suite
GNU_CONFIGURE= yes
+MAKE_ENV+= BINGRP=wheel
+
+MAN1= aescrypt.1 aesget.1
+MANCOMPRESSED= yes
+.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${PREFIX}/share/doc/aescrypt
- ${INSTALL_DATA} ${WRKSRC}/README.html ${PREFIX}/share/doc/aescrypt
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/security/aescrypt/distinfo b/security/aescrypt/distinfo
index 0e749639a2dd..c0cd70077473 100644
--- a/security/aescrypt/distinfo
+++ b/security/aescrypt/distinfo
@@ -1,3 +1,6 @@
MD5 (aescrypt-0.7.tar.gz) = cbec5d7f00a289944397a8079c1d3c6c
SHA256 (aescrypt-0.7.tar.gz) = 7b17656cbbd76700d313a1c36824a197dfb776cadcbf3a748da5ee3d0791b92d
SIZE (aescrypt-0.7.tar.gz) = 62455
+MD5 (aescrypt-0.7-roam-whopper-01.patch.gz) = 3e5c7d68f60c324183b29075dc66bf40
+SHA256 (aescrypt-0.7-roam-whopper-01.patch.gz) = bae520d041ac1ee4229162eb200765aff0099f3f4f5c90229a9d477a6420290a
+SIZE (aescrypt-0.7-roam-whopper-01.patch.gz) = 7418
diff --git a/security/aescrypt/pkg-plist b/security/aescrypt/pkg-plist
index e2c849959cab..c76b0b361e8f 100644
--- a/security/aescrypt/pkg-plist
+++ b/security/aescrypt/pkg-plist
@@ -1,4 +1,4 @@
bin/aescrypt
bin/aesget
-share/doc/aescrypt/README.html
-@dirrm share/doc/aescrypt
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%