aboutsummaryrefslogtreecommitdiff
path: root/security/amap
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-29 13:32:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-29 13:32:55 +0000
commitbb2f0fc5cbad475c8cb79ad2b72e40cdcffab27d (patch)
tree76612550779a71bd9d5d9066da96ed6407fb02f5 /security/amap
parent604f6c31af50c5cfeafe4ba3c9129383b61ef261 (diff)
downloadports-bb2f0fc5cbad475c8cb79ad2b72e40cdcffab27d.tar.gz
ports-bb2f0fc5cbad475c8cb79ad2b72e40cdcffab27d.zip
Update to 4.0
PR: 55011 Submitted by: maintainer Approved by: fjoe (mentor) (implicit)
Notes
Notes: svn path=/head/; revision=85855
Diffstat (limited to 'security/amap')
-rw-r--r--security/amap/Makefile6
-rw-r--r--security/amap/distinfo2
-rw-r--r--security/amap/files/patch-Makefile.am14
-rw-r--r--security/amap/files/patch-amap-inc.h12
-rw-r--r--security/amap/files/patch-amap.h21
-rw-r--r--security/amap/files/patch-amapcrap.c13
-rw-r--r--security/amap/files/patch-configure11
-rw-r--r--security/amap/pkg-plist11
8 files changed, 41 insertions, 49 deletions
diff --git a/security/amap/Makefile b/security/amap/Makefile
index f517cc9f2790..29229e503b28 100644
--- a/security/amap/Makefile
+++ b/security/amap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amap
-PORTVERSION= 2.7
+PORTVERSION= 4.0
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/
@@ -19,7 +19,7 @@ USE_REINPLACE= yes
MAN1= amap.1
post-patch:
- ${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}|' ${WRKSRC}/amap.c
+ ${REINPLACE_CMD} -e 's|PREFIX|${PREFIX}|' ${WRKSRC}/amap.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/amap ${PREFIX}/bin/
@@ -31,7 +31,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/amap.1 ${MANPREFIX}/man/man1/
. if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-. for i in README BUGS TODO CHANGES LICENSE
+. for i in README TODO CHANGES LICENSE IGNORE VOTE
${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
. endfor
. endif
diff --git a/security/amap/distinfo b/security/amap/distinfo
index 7069ab48f432..bd04171961d1 100644
--- a/security/amap/distinfo
+++ b/security/amap/distinfo
@@ -1 +1 @@
-MD5 (amap-2.7.tar.gz) = 742448f85d6abf0897a7d0a703b66328
+MD5 (amap-4.0.tar.gz) = c92a0f159c1ccd34f63e932b81a5b660
diff --git a/security/amap/files/patch-Makefile.am b/security/amap/files/patch-Makefile.am
index 762b08c49eff..9ac9c477a6bb 100644
--- a/security/amap/files/patch-Makefile.am
+++ b/security/amap/files/patch-Makefile.am
@@ -1,15 +1,13 @@
---- Makefile.am.orig Tue Jun 10 17:02:49 2003
-+++ Makefile.am Tue Jun 10 17:03:35 2003
-@@ -1,9 +1,9 @@
+--- Makefile.am.orig Mon Jul 14 17:38:18 2003
++++ Makefile.am Tue Jul 29 13:58:40 2003
+@@ -1,8 +1,8 @@
CC=gcc
+ LIB=-lpcre -L./pcre-3.9/ -I./pcre-3.9/
-OPT=-O2
+OPT=${CFLAGS}
- OPT_DEBUG=-ggdb -Wall
+ OPT_DEBUG=-ggdb -Wall -lefence
-DIR=/usr/local/bin
+DIR=${PREFIX}/bin
SCRIPTS=appdefs.trig appdefs.resp appdefs.rpc
--MANDIR=/usr/local/man/man1
-+MANDIR=${MANPREFIX}/man/man1
MANPAGE=amap.1
- all: strip
-
+ all: pcre strip
diff --git a/security/amap/files/patch-amap-inc.h b/security/amap/files/patch-amap-inc.h
index 1ed9f6551709..de7d2917e6ac 100644
--- a/security/amap/files/patch-amap-inc.h
+++ b/security/amap/files/patch-amap-inc.h
@@ -1,14 +1,10 @@
---- amap-inc.h.orig Sun Jun 29 20:31:38 2003
-+++ amap-inc.h Sun Jun 29 20:31:50 2003
-@@ -12,10 +12,9 @@
+--- amap-inc.h.orig Tue Jul 29 14:26:51 2003
++++ amap-inc.h Tue Jul 29 14:27:05 2003
+@@ -13,7 +13,6 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <sys/socket.h>
-#include <arpa/inet.h>
--#include <netdb.h>
+ #include <netdb.h>
#include <netinet/in.h>
#include <arpa/inet.h>
-+#include <netdb.h>
- #include <fcntl.h>
- #include <time.h>
- #include <errno.h>
diff --git a/security/amap/files/patch-amap.h b/security/amap/files/patch-amap.h
index a16afe2ea5da..a9c06fcaf727 100644
--- a/security/amap/files/patch-amap.h
+++ b/security/amap/files/patch-amap.h
@@ -1,12 +1,11 @@
---- amap.h.orig Tue Jun 10 17:05:40 2003
-+++ amap.h Tue Jun 10 17:06:25 2003
-@@ -57,7 +57,8 @@
- //-----------------------------------------
+--- amap.h.orig Tue Jul 22 13:54:37 2003
++++ amap.h Tue Jul 29 14:06:27 2003
+@@ -24,7 +24,7 @@
+ #define AMAP_EMAIL "amap-dev@thc.org"
+ #define AMAP_RESOURCE "www.thc.org"
- // where are my appdefs files? all entries must end with a slash!
--char *searchpath[14] = { "./", "/etc/", "/usr/etc/", "/usr/local/etc/",
-+char *searchpath[15] = { "./", "PREFIX/share/amap/", "/etc/", "/usr/etc/",
-+ "/usr/local/etc/",
- "/opt/etc/", "/usr/local/amap/", "/opt/amap/",
- "/usr/local/lib/", "/usr/local/lib/amap/",
- "/usr/lib/amap/", "/usr/local/bin/",
+-#define AMAP_APPDEF_PATH "/usr/local/bin"
++#define AMAP_APPDEF_PATH "PREFIX/bin"
+ #define AMAP_BUFSIZE 1024 // standard buffer size
+ #define AMAP_BUFSIZE_BIG 16348 // big standard buffer size
+ #define AMAP_REGEX_OPTIONS ( PCRE_MULTILINE | PCRE_CASELESS )
diff --git a/security/amap/files/patch-amapcrap.c b/security/amap/files/patch-amapcrap.c
deleted file mode 100644
index 0afc2b578e08..000000000000
--- a/security/amap/files/patch-amapcrap.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- amapcrap.c.orig Sun Jun 29 20:26:03 2003
-+++ amapcrap.c Sun Jun 29 20:26:13 2003
-@@ -15,9 +15,9 @@
- #include <stdio.h>
- #include <string.h>
- #include <netdb.h>
--#include <netinet/in.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in.h>
- #include <sys/stat.h>
- #include <sys/time.h>
- #include <sys/resource.h>
diff --git a/security/amap/files/patch-configure b/security/amap/files/patch-configure
new file mode 100644
index 000000000000..9e58b25500f0
--- /dev/null
+++ b/security/amap/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jul 29 14:10:16 2003
++++ configure Tue Jul 29 14:15:56 2003
+@@ -135,7 +135,7 @@
+ XLIBS="$XLIBS -lresolv"
+ fi
+
+-for i in /usr/man /usr/share/man /usr/local/man /usr/local/share/man ; do
++for i in ${MANPPREFIX}/man /usr/man /usr/share/man /usr/local/man /usr/local/share/man ; do
+ if [ -d $i ]; then
+ MANDIR=$i
+ fi
diff --git a/security/amap/pkg-plist b/security/amap/pkg-plist
index ac51e68460f2..72c42230dc4e 100644
--- a/security/amap/pkg-plist
+++ b/security/amap/pkg-plist
@@ -4,10 +4,11 @@ bin/amapcrap
share/amap/appdefs.resp
share/amap/appdefs.rpc
share/amap/appdefs.trig
-%%PORTDOCS%%share/doc/amap/README
-%%PORTDOCS%%share/doc/amap/BUGS
-%%PORTDOCS%%share/doc/amap/TODO
-%%PORTDOCS%%share/doc/amap/CHANGES
-%%PORTDOCS%%share/doc/amap/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/IGNORE
+%%PORTDOCS%%%%DOCSDIR%%/VOTE
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%@dirrm share/doc/amap
@dirrm share/amap