aboutsummaryrefslogtreecommitdiff
path: root/security/apg/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-12-23 10:54:46 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-12-23 10:54:46 +0000
commitbc5522df11427253c369119e1bab5deeb4b2b404 (patch)
tree73c48d5889e626410381fe2780740cebef87a052 /security/apg/Makefile
parent9c39e404f20feb519e2fc7a1cfef7e7e70c932f2 (diff)
downloadports-bc5522df11427253c369119e1bab5deeb4b2b404.tar.gz
ports-bc5522df11427253c369119e1bab5deeb4b2b404.zip
Fix a segfault when using the -y option. While I'm here:
- remove the MD5 checksum from the distfile - note upstream's BSD license - OPTIONSify the support for CrackLib - add a descriptive patch header to the existing patch-aa - remove the packetstorm master site, it only seems to carry a much older version of apg - bump PORTREVISION for the segfault fix PR: 153382 (the segfault fix) Submitted by: David Boyd <David.Boyd@insightbb.com>
Notes
Notes: svn path=/head/; revision=266786
Diffstat (limited to 'security/apg/Makefile')
-rw-r--r--security/apg/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/apg/Makefile b/security/apg/Makefile
index 4c1724c7d7b2..0de420042717 100644
--- a/security/apg/Makefile
+++ b/security/apg/Makefile
@@ -7,20 +7,25 @@
PORTNAME= apg
PORTVERSION= 2.3.0b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
-MASTER_SITES= http://www.adel.nursat.kz/apg/download/ \
- ${MASTER_SITE_PACKETSTORM}
+MASTER_SITES= http://www.adel.nursat.kz/apg/download/
MASTER_SITE_SUBDIR= UNIX/misc
MAINTAINER= roam@FreeBSD.org
COMMENT= An automated password generator
+OPTIONS= CRACKLIB "CrackLib support for password quality" off
+
+.include <bsd.port.options.mk>
+
.if defined(WITH_CRACKLIB)
LIB_DEPENDS= crack.1:${PORTSDIR}/security/cracklib
MAKE_ARGS= -DWITH_CRACKLIB
.endif
+LICENSE= BSD
+
MAN1= apg.1 apgbfm.1
MAN8= apgd.8
DOCS= APG_TIPS pronun.txt rfc0972.txt rfc1750.txt