aboutsummaryrefslogtreecommitdiff
path: root/security/apg
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-01-20 00:13:18 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-01-20 00:13:18 +0000
commit1264b6c7b002e9f18cd811907863e9c0973b5295 (patch)
tree780b10790008debe2f6211b020de2116d144e4b6 /security/apg
parent6225e192c4bd58721b294e44559028c17edb72cf (diff)
downloadports-1264b6c7b002e9f18cd811907863e9c0973b5295.tar.gz
ports-1264b6c7b002e9f18cd811907863e9c0973b5295.zip
apg is an automated generator for pronounceable passwords.
Notes
Notes: svn path=/head/; revision=37355
Diffstat (limited to 'security/apg')
-rw-r--r--security/apg/Makefile20
-rw-r--r--security/apg/distinfo1
-rw-r--r--security/apg/files/patch-aa32
-rw-r--r--security/apg/files/patch-ab15
-rw-r--r--security/apg/pkg-comment1
-rw-r--r--security/apg/pkg-descr6
-rw-r--r--security/apg/pkg-plist2
7 files changed, 77 insertions, 0 deletions
diff --git a/security/apg/Makefile b/security/apg/Makefile
new file mode 100644
index 000000000000..b273fb47b6bd
--- /dev/null
+++ b/security/apg/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: apg
+# Date created: 1 September 2000
+# Whom: roam@orbitel.bg
+#
+# $FreeBSD$
+#
+
+PORTNAME= apg
+PORTVERSION= 1.1.61b
+CATEGORIES= security
+MASTER_SITES= http://www.adel.nursat.kz/apg/download/
+
+MAINTAINER= roam@orbitel.bg
+
+USE_GMAKE= yes
+
+MAN1= apg.1
+MAN8= apgd.8
+
+.include <bsd.port.mk>
diff --git a/security/apg/distinfo b/security/apg/distinfo
new file mode 100644
index 000000000000..89d8eb85d244
--- /dev/null
+++ b/security/apg/distinfo
@@ -0,0 +1 @@
+MD5 (apg-1.1.61b.tar.gz) = 44301e3c689985a16aceb5ffc1afe245
diff --git a/security/apg/files/patch-aa b/security/apg/files/patch-aa
new file mode 100644
index 000000000000..9cda39ff5e78
--- /dev/null
+++ b/security/apg/files/patch-aa
@@ -0,0 +1,32 @@
+--- Makefile 2000/09/30 14:55:17 1.1.1.1
++++ Makefile 2001/01/17 14:12:15 1.3
+@@ -1,12 +1,13 @@
+ # You can modify CC variable if you have compiler other than GCC
+ # But the code was designed and tested with GCC
+-CC = gcc
++CC ?= gcc
+
+ # compilation flags
+-FLAGS = -Wall
++CFLAGS ?= -Wall
+
+ # Install dirs
+-INSTALL_PREFIX = /usr/local
++PREFIX ?= /usr/local
++INSTALL_PREFIX = ${PREFIX}
+ APG_BIN_DIR = /bin
+ APG_MAN_DIR = /man/man1
+ APGD_BIN_DIR = /sbin
+@@ -41,10 +42,10 @@
+ cygwin: standalone
+
+ cliserv: ${SOURCES} ${HEADERS}
+- ${CC} ${FLAGS} ${CS_LIBS} -DCLISERV -o ${CS_PROGNAME} ${SOURCES}
++ ${CC} ${CFLAGS} ${CS_LIBS} -DCLISERV -o ${CS_PROGNAME} ${SOURCES}
+
+ standalone: ${SOURCES} ${HEADERS}
+- ${CC} ${FLAGS} -o ${PROGNAME} ${SOURCES}
++ ${CC} ${CFLAGS} -o ${PROGNAME} ${SOURCES}
+
+ strip:
+ strip ${PROGNAME}
diff --git a/security/apg/files/patch-ab b/security/apg/files/patch-ab
new file mode 100644
index 000000000000..d09733b34ef3
--- /dev/null
+++ b/security/apg/files/patch-ab
@@ -0,0 +1,15 @@
+--- apg.c 2001/01/17 09:01:19 1.1.1.3
++++ apg.c 2001/01/15 11:33:01 1.2
+@@ -342,9 +342,10 @@
+ char * seq;
+ UINT32 prom = 0L;
+
+- printf ("\nPlease enter some random data (only first 4 are significant)\n");
++ printf ("\nPlease enter some random data (only the first %d characters "
++ "are significant)\n", sizeof(prom));
+ seq = (char *)getpass("(eg. your old password):>");
+- if (strlen(seq) < 4)
++ if (strlen(seq) < sizeof(prom))
+ bcopy((void *)seq, (void *)&prom, (int)strlen(seq));
+ else
+ bcopy((void *)seq, (void *)&prom, sizeof(prom));
diff --git a/security/apg/pkg-comment b/security/apg/pkg-comment
new file mode 100644
index 000000000000..36d8f52994a1
--- /dev/null
+++ b/security/apg/pkg-comment
@@ -0,0 +1 @@
+An automated password generator
diff --git a/security/apg/pkg-descr b/security/apg/pkg-descr
new file mode 100644
index 000000000000..380942a2ff0d
--- /dev/null
+++ b/security/apg/pkg-descr
@@ -0,0 +1,6 @@
+An automated password generator, using several strong algorithms
+for random and/or pronounceable password generation, and a built-in
+pseudo-random number generator.
+
+WWW: http://www.adel.nursat.kz/apg/
+Author: Adel I. Mirzazhanov <a-del@iname.com>
diff --git a/security/apg/pkg-plist b/security/apg/pkg-plist
new file mode 100644
index 000000000000..9b3f0158f995
--- /dev/null
+++ b/security/apg/pkg-plist
@@ -0,0 +1,2 @@
+bin/apg
+sbin/apgd