aboutsummaryrefslogtreecommitdiff
path: root/security/asignify
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2015-01-14 18:35:31 +0000
committerAndrej Zverev <az@FreeBSD.org>2015-01-14 18:35:31 +0000
commit58b27a0787e9d45bd707c01cf64f39fb881915e7 (patch)
tree94b9c50832c31746a42fb6c37bbab21812deb867 /security/asignify
parent644d0b322f2c01082820866d51088687828ec025 (diff)
downloadports-58b27a0787e9d45bd707c01cf64f39fb881915e7.tar.gz
ports-58b27a0787e9d45bd707c01cf64f39fb881915e7.zip
New port: security/asignify
Asignify tool is heavily inspired by signify used in OpenBSD. However, the main goal of this project is to define high level API for signing files, validating signatures and encrypting using public keys cryptography. Asignify is designed to be portable and self-contained with zero external dependencies. It uses blake2b as the hash function and ed25519 implementation from tweetnacl. Key features: - Zero dependencies (libc and C compiler are likely required though), so it could be easily used in embedded systems. - Modern cryptography primitives (ed25519, blake2 and sha512 namely). - Ability to encrypt files with the same keys using curve25519 based cryptobox. - Protecting secret keys by passwords using PBKDF2-BLAKE2 routine. - Asignify can convert ssh ed25519 private keys to the native format and verify signatures using just ssh ed25519 public keys (without intermediate conversions). - Asignify provides high level API for application developers for signing, verifying, encrypting and keys generation. - All keys, signatures and encrypted files contain version information allowing to change cryptographical primitives in the future without loosing of backward compatibility.
Notes
Notes: svn path=/head/; revision=377035
Diffstat (limited to 'security/asignify')
-rw-r--r--security/asignify/Makefile19
-rw-r--r--security/asignify/distinfo2
-rw-r--r--security/asignify/pkg-descr23
-rw-r--r--security/asignify/pkg-plist7
4 files changed, 51 insertions, 0 deletions
diff --git a/security/asignify/Makefile b/security/asignify/Makefile
new file mode 100644
index 000000000000..ef0729881f47
--- /dev/null
+++ b/security/asignify/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= asignify
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://highsecure.ru/distfiles/
+
+MAINTAINER= vsevolod@FreeBSD.org
+COMMENT= Yet another signify tool
+
+LICENSE= BSD2CLAUSE
+
+USES= tar:xz libtool
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/security/asignify/distinfo b/security/asignify/distinfo
new file mode 100644
index 000000000000..77b22cd60b83
--- /dev/null
+++ b/security/asignify/distinfo
@@ -0,0 +1,2 @@
+SHA256 (asignify-1.0.tar.xz) = b94e60d160ae1b7d61292d8305d71ac0d5e3b37fb8ae4645fe698bcd0338115c
+SIZE (asignify-1.0.tar.xz) = 267804
diff --git a/security/asignify/pkg-descr b/security/asignify/pkg-descr
new file mode 100644
index 000000000000..5271d364dd72
--- /dev/null
+++ b/security/asignify/pkg-descr
@@ -0,0 +1,23 @@
+Asignify tool is heavily inspired by signify used in OpenBSD. However, the main
+goal of this project is to define high level API for signing files, validating
+signatures and encrypting using public keys cryptography. Asignify is designed
+to be portable and self-contained with zero external dependencies. It uses
+blake2b as the hash function and ed25519 implementation from tweetnacl.
+
+Key features:
+
+- Zero dependencies (libc and C compiler are likely required though), so it
+ could be easily used in embedded systems.
+- Modern cryptography primitives (ed25519, blake2 and sha512 namely).
+- Ability to encrypt files with the same keys using curve25519 based cryptobox.
+- Protecting secret keys by passwords using PBKDF2-BLAKE2 routine.
+- Asignify can convert ssh ed25519 private keys to the native format and verify
+ signatures using just ssh ed25519 public keys (without intermediate
+ conversions).
+- Asignify provides high level API for application developers for signing,
+ verifying, encrypting and keys generation.
+- All keys, signatures and encrypted files contain version information allowing
+ to change cryptographical primitives in the future without loosing of
+ backward compatibility.
+
+WWW: https://github.com/vstakhov/asignify/
diff --git a/security/asignify/pkg-plist b/security/asignify/pkg-plist
new file mode 100644
index 000000000000..0db4024f2791
--- /dev/null
+++ b/security/asignify/pkg-plist
@@ -0,0 +1,7 @@
+bin/asignify
+include/asignify.h
+lib/libasignify.a
+lib/libasignify.so
+lib/libasignify.so.1
+lib/libasignify.so.1.0.0
+man/man1/asignify.1.gz