aboutsummaryrefslogtreecommitdiff
path: root/security/aws-c-auth
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-23 12:43:44 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-25 14:04:51 +0000
commit7d42f97bb9975993a2fa46e126cafbbe9dfb7b7a (patch)
tree41cddb9dbfef7e46d93f692bc40f2d4f33d89406 /security/aws-c-auth
parentc4ba600cdabc8ea3436cdd07253a11f70837112a (diff)
downloadports-7d42f97bb9975993a2fa46e126cafbbe9dfb7b7a.tar.gz
ports-7d42f97bb9975993a2fa46e126cafbbe9dfb7b7a.zip
security/aws-c-auth: Add new port
C99 library implementation of AWS client-side authentication: standard credentials providers and signing.
Diffstat (limited to 'security/aws-c-auth')
-rw-r--r--security/aws-c-auth/Makefile31
-rw-r--r--security/aws-c-auth/distinfo3
-rw-r--r--security/aws-c-auth/files/patch-CMakeLists.txt10
-rw-r--r--security/aws-c-auth/pkg-descr4
-rw-r--r--security/aws-c-auth/pkg-plist18
5 files changed, 66 insertions, 0 deletions
diff --git a/security/aws-c-auth/Makefile b/security/aws-c-auth/Makefile
new file mode 100644
index 000000000000..11fd4d325486
--- /dev/null
+++ b/security/aws-c-auth/Makefile
@@ -0,0 +1,31 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
+
+PORTNAME= aws-c-auth
+PORTVERSION= 0.6.5
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= C99 library implementation of AWS client-side authentication
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libaws-c-common.so:devel/aws-c-common \
+ libaws-c-cal.so:security/aws-c-cal \
+ libaws-c-io.so:devel/aws-c-io \
+ libaws-c-compression.so:devel/aws-c-compression \
+ libaws-c-http.so:devel/aws-c-http \
+ libaws-c-sdkutils.so:devel/aws-c-sdkutils \
+ libs2n.so:security/s2n
+
+USES= cmake compiler:c11 ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= awslabs
+
+CMAKE_ARGS+= -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_PREFIX_PATH=${LOCALBASE}
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/security/aws-c-auth/distinfo b/security/aws-c-auth/distinfo
new file mode 100644
index 000000000000..10481bb57371
--- /dev/null
+++ b/security/aws-c-auth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634978482
+SHA256 (awslabs-aws-c-auth-v0.6.5_GH0.tar.gz) = e4adf562691ac9d1972529bbad9f5abc544085eee8be748f463bd15f976e148e
+SIZE (awslabs-aws-c-auth-v0.6.5_GH0.tar.gz) = 245880
diff --git a/security/aws-c-auth/files/patch-CMakeLists.txt b/security/aws-c-auth/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ec65dc056c87
--- /dev/null
+++ b/security/aws-c-auth/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2021-10-23 10:33:37 UTC
++++ CMakeLists.txt
+@@ -111,6 +111,7 @@ target_link_libraries(${PROJECT_NAME} PUBLIC ${DEP_AWS
+ aws_prepare_shared_lib_exports(${PROJECT_NAME})
+
+ install(FILES ${AWS_AUTH_ROOT_HEADERS} DESTINATION "include/aws/auth" COMPONENT Development)
++install(FILES ${AWS_AUTH_PRIVATE_HEADERS} DESTINATION "include/aws/auth/private" COMPONENT Development)
+
+ if (BUILD_SHARED_LIBS)
+ set (TARGET_DIR "shared")
diff --git a/security/aws-c-auth/pkg-descr b/security/aws-c-auth/pkg-descr
new file mode 100644
index 000000000000..7ea1001d1257
--- /dev/null
+++ b/security/aws-c-auth/pkg-descr
@@ -0,0 +1,4 @@
+C99 library implementation of AWS client-side authentication:
+standard credentials providers and signing.
+
+WWW: https://github.com/awslabs/aws-c-auth
diff --git a/security/aws-c-auth/pkg-plist b/security/aws-c-auth/pkg-plist
new file mode 100644
index 000000000000..d8925714ca3c
--- /dev/null
+++ b/security/aws-c-auth/pkg-plist
@@ -0,0 +1,18 @@
+include/aws/auth/auth.h
+include/aws/auth/aws_imds_client.h
+include/aws/auth/credentials.h
+include/aws/auth/exports.h
+include/aws/auth/private/aws_profile.h
+include/aws/auth/private/aws_signing.h
+include/aws/auth/private/credentials_utils.h
+include/aws/auth/private/key_derivation.h
+include/aws/auth/private/sigv4_http_request.h
+include/aws/auth/signable.h
+include/aws/auth/signing.h
+include/aws/auth/signing_config.h
+include/aws/auth/signing_result.h
+lib/aws-c-auth/cmake/aws-c-auth-config.cmake
+lib/aws-c-auth/cmake/shared/aws-c-auth-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/aws-c-auth/cmake/shared/aws-c-auth-targets.cmake
+lib/libaws-c-auth.so
+lib/libaws-c-auth.so.1.0.0