aboutsummaryrefslogtreecommitdiff
path: root/security/barnyard2
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-05-14 19:09:58 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-05-14 19:09:58 +0000
commit0df3874092254caf88ff63a54903542e17d6981b (patch)
tree7ed3ac2fc5f208dcf5d778b96749c4c6a65edbf6 /security/barnyard2
parentd79d568a73c0d7080b494b5889ab364d5de987be (diff)
downloadports-0df3874092254caf88ff63a54903542e17d6981b.tar.gz
ports-0df3874092254caf88ff63a54903542e17d6981b.zip
- add OPTION tcl (default off) to allow sguil* ports build against barnyard2
PR: ports/156341 Submitted by: Brandon <m37a11 _at_ gmail.com> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=274123
Diffstat (limited to 'security/barnyard2')
-rw-r--r--security/barnyard2/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index bd6e5d5a9c92..0edab4669138 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -17,7 +17,8 @@ COMMENT= An output system for Snort or Suricata that parses unified2 files
OPTIONS= MYSQL "Enable MySQL support" on \
POSTGRESQL "Enable PostgreSQL support" off \
SNORT "Depend on security/snort" off \
- SURICATA "Depend on security/suricata" off
+ SURICATA "Depend on security/suricata" off \
+ TCL "Enable TCL support" off
USE_RC_SUBR= barnyard2.sh
GNU_CONFIGURE= yes
@@ -30,6 +31,12 @@ PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
.include <bsd.port.pre.mk>
+.if defined(WITH_TCL)
+USE_TCL= yes
+CONFIGURE_ARGS+= --with-tcl=${PREFIX}/lib/tcl8.4
+LIB_DEPENDS+= tcl84.1:${PORTSDIR}/lang/tcl84
+.endif
+
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql \