aboutsummaryrefslogtreecommitdiff
path: root/security/base
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /security/base
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'security/base')
-rw-r--r--security/base/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/base/Makefile b/security/base/Makefile
index 201e071b9cdf..accd7233ad5d 100644
--- a/security/base/Makefile
+++ b/security/base/Makefile
@@ -13,9 +13,9 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/docs/GPL
RUN_DEPENDS= ${ADODB_DIR}/adodb.inc.php:databases/adodb5 \
- ${LOCALBASE}/share/pear/Image/Graph.php:graphics/pear-Image_Graph \
- ${LOCALBASE}/share/pear/Mail.php:mail/pear-Mail \
- ${LOCALBASE}/share/pear/Mail/mime.php:mail/pear-Mail_Mime
+ ${LOCALBASE}/share/pear/Image/Graph.php:graphics/pear-Image_Graph@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/Mail.php:mail/pear-Mail@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/Mail/mime.php:mail/pear-Mail_Mime@${PHP_FLAVOR}
USE_PHP= gd gettext pcre session zlib ctype