aboutsummaryrefslogtreecommitdiff
path: root/security/bdes/Makefile
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-02-05 20:12:49 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-02-05 20:12:49 +0000
commit87dbbc37330aae1d427024513a60d3dd313e601e (patch)
tree40fabb88213b889fd6a969c0ec8a1b8392bd16d9 /security/bdes/Makefile
parent3b98917313305e679460363b1d95578270d359b9 (diff)
downloadports-87dbbc37330aae1d427024513a60d3dd313e601e.tar.gz
ports-87dbbc37330aae1d427024513a60d3dd313e601e.zip
security/bdes: New port
- Add port so we can remove bdes from base Reviewed by: allanjude, rene Approved by: allanjude Differential Revision: D9435
Notes
Notes: svn path=/head/; revision=433449
Diffstat (limited to 'security/bdes/Makefile')
-rw-r--r--security/bdes/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/security/bdes/Makefile b/security/bdes/Makefile
new file mode 100644
index 000000000000..25ec6da4d639
--- /dev/null
+++ b/security/bdes/Makefile
@@ -0,0 +1,29 @@
+# Created by: Bernard Spil <brnrd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bdes
+PORTVERSION= 1993
+CATEGORIES= security
+MASTER_SITES= http://phobos69.inf.uni-konstanz.de/download/tools/ \
+ LOCAL/brnrd
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= brnrd@FreeBSD.org
+COMMENT= Encrypt/decrypt using the Data Encryption Standard (DES)
+
+LICENSE= BSD2CLAUSE
+
+USES= ssl tar
+WRKSRC= ${WRKDIR}/bdes.src
+
+PLIST_FILES= bin/bdes man/man1/bdes.1.gz
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -I${OPENSSLINC} -c bdes.c
+ cd ${WRKSRC} && ${CC} -o bdes bdes.o ${OPENSSLLIB}/libcrypto.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bdes ${STAGEDIR}${PREFIX}/bin/bdes
+ ${INSTALL_MAN} ${WRKSRC}/bdes.1 ${STAGEDIR}${MANPREFIX}/man/man1/bdes.1
+
+.include <bsd.port.mk>