aboutsummaryrefslogtreecommitdiff
path: root/security/bearssl
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-09-29 15:24:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-09-29 15:24:58 +0000
commitc8170d0aafb766240a64d8079203e90ca8011cea (patch)
tree905e5fcf5d53166ac754168fcdef412f341c8c3c /security/bearssl
parentf4f7a5fb8bf7751a29379e95e5bde9894c41ed07 (diff)
downloadports-c8170d0aafb766240a64d8079203e90ca8011cea.tar.gz
ports-c8170d0aafb766240a64d8079203e90ca8011cea.zip
Update to 0.5 [1]
While here: port related changes: - Respect PREFIX - Build a real shared library (with SONAME) PR: 222483 [1] Submitted by: takefu@airport.fm [1]
Notes
Notes: svn path=/head/; revision=450903
Diffstat (limited to 'security/bearssl')
-rw-r--r--security/bearssl/Makefile16
-rw-r--r--security/bearssl/distinfo6
-rw-r--r--security/bearssl/pkg-plist18
3 files changed, 22 insertions, 18 deletions
diff --git a/security/bearssl/Makefile b/security/bearssl/Makefile
index 5a0f68150815..bbbd144c449c 100644
--- a/security/bearssl/Makefile
+++ b/security/bearssl/Makefile
@@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= bearssl
-PORTVERSION= 0.4
-PORTREVISION= 2
+PORTVERSION= 0.5
CATEGORIES= security devel
MASTER_SITES= https://bearssl.org/
-MAINTAINER= feld@FreeBSD.org
+MAINTAINER= bapt@FreeBSD.org
COMMENT= Implementation of TLS/SSL in C
LICENSE= MIT
+LIBBEARSSL= libbearssl.so.0
-MAKE_ARGS= CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS} -fPIC" LDDLL="${CC}"
+MAKE_ARGS= CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS} -fPIC" LDDLL="${CC}" LDDLLFLAGS="-shared -Wl,-soname=${LIBBEARSSL}" \
+ BEARSSLDLL=${LIBBEARSSL}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/build/brssl ${STAGEDIR}${LOCALBASE}/bin/
- ${INSTALL_LIB} ${WRKSRC}/build/libbearssl.so ${STAGEDIR}${LOCALBASE}/lib/
- (cd ${WRKSRC}/inc && ${COPYTREE_SHARE} \* ${STAGEDIR}${LOCALBASE}/include)
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/brssl ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_LIB} ${WRKSRC}/${LIBBEARSSL} ${STAGEDIR}${PREFIX}/lib/
+ ${RLN} ${STAGEDIR}${PREFIX}/lib/${LIBBEARSSL} ${STAGEDIR}${PREFIX}/lib/libbearssl.so
+ (cd ${WRKSRC}/inc && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/include)
.include <bsd.port.mk>
diff --git a/security/bearssl/distinfo b/security/bearssl/distinfo
index 7ad6a99090e6..5b7d1ceb1c6b 100644
--- a/security/bearssl/distinfo
+++ b/security/bearssl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491764060
-SHA256 (bearssl-0.4.tar.gz) = 674d69ca6811a4a091de96d5866e22f06ffbf8d3765f0e884d9daeb80aa904d4
-SIZE (bearssl-0.4.tar.gz) = 633401
+TIMESTAMP = 1506696986
+SHA256 (bearssl-0.5.tar.gz) = 400f7027f309f5c0e3784ad1f5a612cfadfa108a33d867f50c75974cabd7830c
+SIZE (bearssl-0.5.tar.gz) = 666905
diff --git a/security/bearssl/pkg-plist b/security/bearssl/pkg-plist
index 8d24a802b9b6..ca34880d6731 100644
--- a/security/bearssl/pkg-plist
+++ b/security/bearssl/pkg-plist
@@ -1,13 +1,15 @@
bin/brssl
-include/bearssl_ssl.h
-include/bearssl_rand.h
-include/bearssl_hmac.h
-include/bearssl_ec.h
include/bearssl.h
+include/bearssl_aead.h
+include/bearssl_block.h
+include/bearssl_ec.h
include/bearssl_hash.h
-include/bearssl_x509.h
-include/bearssl_rsa.h
-include/bearssl_prf.h
+include/bearssl_hmac.h
include/bearssl_pem.h
-include/bearssl_block.h
+include/bearssl_prf.h
+include/bearssl_rand.h
+include/bearssl_rsa.h
+include/bearssl_ssl.h
+include/bearssl_x509.h
+lib/libbearssl.so.0
lib/libbearssl.so