aboutsummaryrefslogtreecommitdiff
path: root/security/beecrypt
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-06-21 23:59:06 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-06-21 23:59:06 +0000
commitb45254882452f982b4d1f2b3c7e88d45c1369430 (patch)
tree7c85e576aeed863a80332b7f6450e02defa303a5 /security/beecrypt
parente286eb242129d068921b5b8ea324c6160a8d0a59 (diff)
downloadports-b45254882452f982b4d1f2b3c7e88d45c1369430.tar.gz
ports-b45254882452f982b4d1f2b3c7e88d45c1369430.zip
Turn "WITH_OPENMP" into a proper OPTION.
Notes
Notes: svn path=/head/; revision=358758
Diffstat (limited to 'security/beecrypt')
-rw-r--r--security/beecrypt/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/security/beecrypt/Makefile b/security/beecrypt/Makefile
index 0284f84b277b..96b6f9b5f92e 100644
--- a/security/beecrypt/Makefile
+++ b/security/beecrypt/Makefile
@@ -16,15 +16,16 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--without-java
USE_LDCONFIG= yes
+OPTIONS_DEFINE= OPENMP
+OPENMP_CONFIGURE_ENABLE= openmp
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
-.if defined(WITH_OPENMP)
+.if ${PORT_OPTIONS:MOPENMP}
@${ECHO_MSG} "Configuring for OpenMP support"
@${ECHO_MSG} "Any ports depending on beecrypt must be configured for OpenMP too."
-
-CONFIGURE_ARGS+= --enable-openmp
-.else
-CONFIGURE_ARGS+= --disable-openmp
.endif
# Configure tries to guess our CPU-features using Linux-centric logic.