aboutsummaryrefslogtreecommitdiff
path: root/security/beid/files
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-08-12 14:02:45 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-08-12 14:02:45 +0000
commitb7887f3ffdb8c2018cbc21400360f4ca08b4d57f (patch)
treed3c6757ab772236e97f44a8d369220c0bcc9e0e6 /security/beid/files
parent7cf69138a4c0d6b63b7dd50a2ab58e93e2fd4acf (diff)
downloadports-b7887f3ffdb8c2018cbc21400360f4ca08b4d57f.tar.gz
ports-b7887f3ffdb8c2018cbc21400360f4ca08b4d57f.zip
Update Belgian eID middleware to 4.4.5. Enable the viewer application
and the Firefox extension. Rename the port from security/libbeid to security/beid now that it's more than just a library.
Notes
Notes: svn path=/head/; revision=476992
Diffstat (limited to 'security/beid/files')
-rw-r--r--security/beid/files/patch-common21
-rw-r--r--security/beid/files/patch-dialogs22
-rw-r--r--security/beid/files/patch-plugins_tools_chrome_pkcs11_beid-update-nssdb40
-rw-r--r--security/beid/files/patch-plugins_tools_eid-viewer_Makefile.am20
-rw-r--r--security/beid/files/patch-scripts_build-aux_genver.sh16
5 files changed, 119 insertions, 0 deletions
diff --git a/security/beid/files/patch-common b/security/beid/files/patch-common
new file mode 100644
index 000000000000..4bb5ca0972c0
--- /dev/null
+++ b/security/beid/files/patch-common
@@ -0,0 +1,21 @@
+--- cardcomm/pkcs11/src/common/logbase.cpp.orig 2017-05-16 16:28:03 UTC
++++ cardcomm/pkcs11/src/common/logbase.cpp
+@@ -639,6 +639,7 @@ namespace eIDMW
+ utilStringNarrow(filename).
+ c_str(), "a");
+ #else
++ (void)bWchar;
+ m_f = fopen(utilStringNarrow(filename).c_str(),
+ "a, ccs=UTF-8");
+ if (m_f == NULL)
+--- cardcomm/pkcs11/src/common/util.cpp.orig 2017-05-16 16:28:03 UTC
++++ cardcomm/pkcs11/src/common/util.cpp
+@@ -221,7 +221,7 @@ namespace eIDMW
+ pid = getpid();
+
+ if (snprintf
+- (linkname, sizeof(linkname), "/proc/%i/exe",
++ (linkname, sizeof(linkname), "/proc/%i/file",
+ pid) < 0)
+ {
+ /* This should only happen on large word systems. I'm not sure
diff --git a/security/beid/files/patch-dialogs b/security/beid/files/patch-dialogs
new file mode 100644
index 000000000000..9175b66c8185
--- /dev/null
+++ b/security/beid/files/patch-dialogs
@@ -0,0 +1,22 @@
+--- cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-badpin.c.orig 2017-10-27 12:42:43 UTC
++++ cardcomm/pkcs11/src/dialogs/dialogsgtk/beid-badpin.c
+@@ -43,7 +43,7 @@ int main(int argc, char *argv[]) {
+ // create new message dialog with CANCEL button in standard places, in center of user's screen
+ ///////////////////////////////////////////////////////////////////////////////////////////////////////////////////
+
+- char* msg;
++ char const *msg;
+ int attempts;
+
+ if ((argc == 2) && (argv[1] != NULL) && (strlen(argv[1]) == 1)
+--- cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.c.orig 2017-10-27 12:42:43 UTC
++++ cardcomm/pkcs11/src/dialogs/dialogsgtk/parent.c
+@@ -12,7 +12,7 @@ ssize_t get_parent_path(char *exec_path, size_t exec_p
+ ssize_t exec_path_len = -1;
+ pid_t ppid = getppid();
+
+- snprintf(proc_path, sizeof(proc_path) - 1, "/proc/%d/exe", ppid);
++ snprintf(proc_path, sizeof(proc_path) - 1, "/proc/%d/file", ppid);
+ if ((exec_path_len = readlink(proc_path, exec_path, exec_path_size - 1)) != -1) {
+ exec_path[exec_path_len] = '\0';
+ } else {
diff --git a/security/beid/files/patch-plugins_tools_chrome_pkcs11_beid-update-nssdb b/security/beid/files/patch-plugins_tools_chrome_pkcs11_beid-update-nssdb
new file mode 100644
index 000000000000..90e4789933ba
--- /dev/null
+++ b/security/beid/files/patch-plugins_tools_chrome_pkcs11_beid-update-nssdb
@@ -0,0 +1,40 @@
+--- plugins_tools/chrome_pkcs11/beid-update-nssdb.orig 2018-07-20 12:53:45 UTC
++++ plugins_tools/chrome_pkcs11/beid-update-nssdb
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#! /bin/sh
+ #
+ # The MIT License (MIT)
+ #
+@@ -26,15 +26,17 @@
+ # Copyright(c) Wouter Verhelst, 2018
+
+ NSSDB=$HOME/.pki/nssdb
+-MODUTIL="/usr/bin/modutil -force -dbdir sql:$NSSDB"
+-CERTUTIL="/usr/bin/certutil -d sql:$NSSDB"
++MODUTIL="/usr/bin/modutil"
++CERTUTIL="/usr/bin/certutil"
+ LIBS=$(ld --verbose | grep SEARCH | awk '{ gsub(/;/,"\n"); print }' | awk -F '\"' '/SEARCH_DIR\(\"=?/ { gsub(/=/,""); print $2 }')
+ PKCS11=libbeidpkcs11.so.0
+
++[ -e $CERTUTIL -a -e $MODUTIL ] || exit
++
+ if [ ! -f $NSSDB/cert9.db ]; then
+ echo "Initializing new database"
+ mkdir -p $NSSDB
+- $CERTUTIL -N --empty-password
++ $CERTUTIL -d sql:$NSSDB -N --empty-password
+ fi
+
+ for DIR in $LIBS; do
+@@ -45,8 +47,8 @@ for DIR in $LIBS; do
+ echo "ID-card support for Google Chrome/Chromium/Opera already enabled"
+ else
+ echo "Enabling ID-card functionality in Google Chrome/Chromium/Opera via $LIB"
+- $MODUTIL -delete "Belgium eID"
+- $MODUTIL -add "Belgium eID" -libfile $LIB -mechanisms FRIENDLY
++ $MODUTIL -force -dbdir sql:$NSSDB -delete "Belgium eID"
++ $MODUTIL -force -dbdir sql:$NSSDB -add "Belgium eID" -libfile $LIB -mechanisms FRIENDLY
+ fi
+ exit
+ fi
diff --git a/security/beid/files/patch-plugins_tools_eid-viewer_Makefile.am b/security/beid/files/patch-plugins_tools_eid-viewer_Makefile.am
new file mode 100644
index 000000000000..65bda43d28e9
--- /dev/null
+++ b/security/beid/files/patch-plugins_tools_eid-viewer_Makefile.am
@@ -0,0 +1,20 @@
+--- plugins_tools/eid-viewer/Makefile.am.orig 2018-07-20 12:53:45 UTC
++++ plugins_tools/eid-viewer/Makefile.am
+@@ -51,6 +51,8 @@ libeidviewer_la_SOURCES = \
+ cache/cache.cpp \
+ conversions/bbannumconv.h \
+ conversions/bbannumconv.cpp \
++ conversions/booldecode.h \
++ conversions/booldecode.cpp \
+ conversions/genderconv.h \
+ conversions/genderconv.cpp \
+ conversions/hexnumconv.cpp \
+@@ -74,6 +76,8 @@ libeidviewer_la_SOURCES = \
+ conversions/specconv.cpp \
+ conversions/specorgconv.h \
+ conversions/specorgconv.cpp \
++ conversions/toxmlmemberoffamilyconv.h \
++ conversions/toxmlmemberoffamilyconv.cpp \
+ conversions/valdate.h \
+ conversions/valdate.cpp \
+ conversions/workpermitconv.h \
diff --git a/security/beid/files/patch-scripts_build-aux_genver.sh b/security/beid/files/patch-scripts_build-aux_genver.sh
new file mode 100644
index 000000000000..9ab9c47a3469
--- /dev/null
+++ b/security/beid/files/patch-scripts_build-aux_genver.sh
@@ -0,0 +1,16 @@
+--- scripts/build-aux/genver.sh.orig 2017-10-27 12:42:43 UTC
++++ scripts/build-aux/genver.sh
+@@ -1,11 +1,11 @@
+ #!/bin/sh
+
+-GITDESC=$(git describe --dirty|sed -e 's/-/./g' 2>/dev/null)
++GITDESC=$(git describe --dirty 2>/dev/null | sed -e 's/-/./g')
+ VERCLEAN=$(echo $GITDESC|sed -Ee 's/^.*v([0-9]+\.[0-9]+(\.[0-9]+|bp)).*$/\1/')
+
+ GITDESC="$VERCLEAN-$GITDESC"
+
+-if [ -z "$GITDESC" ]; then
++if [ "$GITDESC" = "-" ]; then
+ if [ -f ".version" ]; then
+ GITDESC=$(cat .version)
+ else