aboutsummaryrefslogtreecommitdiff
path: root/security/botan110
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-09-26 23:37:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-09-26 23:37:19 +0000
commitd65ed1ce9528ae10a48111e934f44395ea29db08 (patch)
tree6a1466e2a46e7e486e689fd9290f657cc465d23d /security/botan110
parent95e5ce00a078b2a26f7622fa0587066bff8d84b8 (diff)
downloadports-d65ed1ce9528ae10a48111e934f44395ea29db08.tar.gz
ports-d65ed1ce9528ae10a48111e934f44395ea29db08.zip
Notes
Diffstat (limited to 'security/botan110')
-rw-r--r--security/botan110/Makefile23
-rw-r--r--security/botan110/files/patch-src_ssl_tls__record.h31
2 files changed, 37 insertions, 17 deletions
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index ae5b8f0017da..cc2a26721332 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -3,7 +3,7 @@
PORTNAME= botan
PORTVERSION= 1.10.13
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 110
@@ -15,14 +15,14 @@ COMMENT= Portable, easy to use, and efficient C++ crypto library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/doc/license.txt
-OPTIONS_DEFINE= SSL GMP ECC DOCS
-OPTIONS_DEFAULT= SSL GMP ECC
-ECC_DESC= ECC support
+OPTIONS_DEFINE= SSL GMP DOCS
+OPTIONS_DEFAULT= SSL GMP
USES= compiler gmake python:build tar:tgz
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-bzip2 --with-zlib
+CONFIGURE_ARGS= --prefix=${PREFIX} --cc ${CHOSEN_COMPILER_TYPE} \
+ --with-tr1-implementation=system --with-bzip2 --with-zlib
MAKE_ARGS= CXX="${CXX}" LIB_OPT="${CXXFLAGS}"
USE_LDCONFIG= yes
PLIST_FILES= bin/botan-config-1.10 lib/libbotan-1.10.a lib/libbotan-1.10.so lib/libbotan-1.10.so.1 \
@@ -41,24 +41,13 @@ CONFIGURE_ARGS+=--with-openssl
.endif
.if ${PORT_OPTIONS:MGMP}
+USES+= localbase:ldflags
LIB_DEPENDS+= libgmp.so:math/gmp
CONFIGURE_ARGS+=--with-gnump
-MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
-.endif
-
-.if ${PORT_OPTIONS:MECC}
-BROKEN= fails to build with boost 1.65, see bug 220760
-BUILD_DEPENDS+= ${LOCALBASE}/include/boost/tr1/memory.hpp:devel/boost-libs
-CONFIGURE_ARGS+=--with-tr1-implementation=boost
-CXXFLAGS+= -I${LOCALBASE}/include
-.else
-CONFIGURE_ARGS+=--with-tr1-implementation=none
.endif
.include <bsd.port.pre.mk>
-CONFIGURE_ARGS+=--cc ${COMPILER_TYPE}
-
post-patch:
${REINPLACE_CMD} -e "s|#!/usr/bin/env python|#!${PYTHON_CMD}|" \
${WRKSRC}/configure.py
diff --git a/security/botan110/files/patch-src_ssl_tls__record.h b/security/botan110/files/patch-src_ssl_tls__record.h
new file mode 100644
index 000000000000..52fb1cb46dfd
--- /dev/null
+++ b/security/botan110/files/patch-src_ssl_tls__record.h
@@ -0,0 +1,31 @@
+--- src/ssl/tls_record.h.orig 2016-04-28 13:27:08 UTC
++++ src/ssl/tls_record.h
+@@ -17,8 +17,15 @@
+
+ #if defined(BOTAN_USE_STD_TR1)
+
+-#if defined(BOTAN_BUILD_COMPILER_IS_MSVC)
++#if defined(_LIBCPP_VERSION) || defined(BOTAN_BUILD_COMPILER_IS_MSVC)
+ #include <functional>
++ #if defined(_LIBCPP_VERSION)
++ namespace std {
++ namespace tr1 {
++ using std::function;
++ }
++ }
++ #endif
+ #else
+ #include <tr1/functional>
+ #endif
+@@ -31,7 +38,11 @@
+
+ namespace Botan {
+
++#if defined(_LIBCPP_VERSION)
++using namespace std::placeholders;
++#else
+ using namespace std::tr1::placeholders;
++#endif
+
+ /**
+ * TLS Record Writer