aboutsummaryrefslogtreecommitdiff
path: root/security/botan2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-01-15 17:17:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-01-15 17:17:01 +0000
commit16f65b21ddc0d1050712a925d5bd13e54b1d44e3 (patch)
tree960dd4ccd6bac6326147b474612d8cf7f08bc8a5 /security/botan2
parent8fbe622103ab2ee62ae414d923a19d0f9a5ee3e6 (diff)
downloadports-16f65b21ddc0d1050712a925d5bd13e54b1d44e3.tar.gz
ports-16f65b21ddc0d1050712a925d5bd13e54b1d44e3.zip
Update security/botan2 to 2.4.0
- Fix build on aarch64 - While I'm here: - Strip shared library in post-install: - Do not silence installation message - Bump PORTREVISION of dependent ports for shlib change Changes: https://botan.randombit.net/news.html PR: 225085 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer)
Notes
Notes: svn path=/head/; revision=459096
Diffstat (limited to 'security/botan2')
-rw-r--r--security/botan2/Makefile22
-rw-r--r--security/botan2/distinfo6
-rw-r--r--security/botan2/files/patch-src_lib_prov_openssl_openssl__rsa.cpp10
-rw-r--r--security/botan2/pkg-plist11
4 files changed, 27 insertions, 22 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index f871f059a57d..7aaf70103858 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= botan
-DISTVERSION= 2.3.0
+DISTVERSION= 2.4.0
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 2
@@ -15,8 +15,6 @@ LICENSE_FILE= ${WRKSRC}/license.txt
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs
-BROKEN_aarch64= fails to compile: ./src/lib/block/aes/aes_armv8/aes_armv8.cpp:40:25: use of undeclared identifier 'vaeseq_u8'
-
OPTIONS_DEFINE= SQLITE3 SSL DOCS
OPTIONS_DEFAULT= SSL
OPTIONS_SUB= yes
@@ -42,13 +40,25 @@ SSL_USES= ssl
SSL_CONFIGURE_WITH= openssl
SSL_VARS= BROKEN_SSL= openssl-devel
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == aarch64
+CONFIGURE_ARGS+= --cc-abi="-march=armv8-a+crypto"
+.endif
+
+.if ${ARCH} == i386 || ${ARCH} == amd64
+PLIST_SUB+= HAS_RDRAND_RNG=""
+.else
+PLIST_SUB+= HAS_RDRAND_RNG="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^optimization_flags .*|optimization_flags "${CXXFLAGS}"|' \
${WRKSRC}/src/build-data/cc/clang.txt
-post-stage:
-.for i in bin/botan lib/libbotan-2.so.3.3.0
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${i}
+post-install:
+.for i in bin/botan lib/libbotan-2.so.4.4.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${i}
.endfor
.include <bsd.port.mk>
diff --git a/security/botan2/distinfo b/security/botan2/distinfo
index 88d9e953624b..2e18783e41a1 100644
--- a/security/botan2/distinfo
+++ b/security/botan2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508527395
-SHA256 (Botan-2.3.0.tgz) = 39f970fee5986a4c3e425030aef50ac284da18596c004d1a9cce7688c4e6d47c
-SIZE (Botan-2.3.0.tgz) = 5947072
+TIMESTAMP = 1515446913
+SHA256 (Botan-2.4.0.tgz) = ed9464e2a5cfee4cd3d9bd7a8f80673b45c8a0718db2181a73f5465a606608a5
+SIZE (Botan-2.4.0.tgz) = 6530714
diff --git a/security/botan2/files/patch-src_lib_prov_openssl_openssl__rsa.cpp b/security/botan2/files/patch-src_lib_prov_openssl_openssl__rsa.cpp
deleted file mode 100644
index 66ffc7fe17a9..000000000000
--- a/security/botan2/files/patch-src_lib_prov_openssl_openssl__rsa.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/lib/prov/openssl/openssl_rsa.cpp.orig 2017-11-11 07:42:40 UTC
-+++ src/lib/prov/openssl/openssl_rsa.cpp
-@@ -17,6 +17,7 @@
-
- #include <functional>
- #include <memory>
-+#include <cstdlib>
-
- #include <openssl/rsa.h>
- #include <openssl/x509.h>
diff --git a/security/botan2/pkg-plist b/security/botan2/pkg-plist
index d798b6cdfae2..de85c14daecf 100644
--- a/security/botan2/pkg-plist
+++ b/security/botan2/pkg-plist
@@ -8,6 +8,7 @@ include/botan-2/botan/asn1_alt_name.h
include/botan-2/botan/asn1_attribute.h
include/botan-2/botan/asn1_obj.h
include/botan-2/botan/asn1_oid.h
+include/botan-2/botan/asn1_print.h
include/botan-2/botan/asn1_str.h
include/botan-2/botan/asn1_time.h
include/botan-2/botan/assert.h
@@ -105,6 +106,7 @@ include/botan-2/botan/filters.h
include/botan-2/botan/fpe_fe1.h
include/botan-2/botan/gcm.h
include/botan-2/botan/gf2m_small_m.h
+include/botan-2/botan/ghash.h
include/botan-2/botan/gmac.h
include/botan-2/botan/gost_28147.h
include/botan-2/botan/gost_3410.h
@@ -151,6 +153,7 @@ include/botan-2/botan/mul128.h
include/botan-2/botan/mutex.h
include/botan-2/botan/name_constraint.h
include/botan-2/botan/newhope.h
+include/botan-2/botan/nist_keywrap.h
include/botan-2/botan/noekeon.h
include/botan-2/botan/numthry.h
include/botan-2/botan/oaep.h
@@ -196,10 +199,12 @@ include/botan-2/botan/polyn_gf2m.h
include/botan-2/botan/pow_mod.h
include/botan-2/botan/prf_tls.h
include/botan-2/botan/prf_x942.h
+include/botan-2/botan/psk_db.h
+include/botan-2/botan/psk_db_sql.h
include/botan-2/botan/pssr.h
include/botan-2/botan/pubkey.h
include/botan-2/botan/rc4.h
-include/botan-2/botan/rdrand_rng.h
+%%HAS_RDRAND_RNG%%include/botan-2/botan/rdrand_rng.h
include/botan-2/botan/reducer.h
include/botan-2/botan/rfc3394.h
include/botan-2/botan/rfc6979.h
@@ -296,7 +301,7 @@ include/botan-2/botan/xts.h
include/botan-2/botan/zlib.h
lib/libbotan-2.a
lib/libbotan-2.so
-lib/libbotan-2.so.3
-lib/libbotan-2.so.3.3.0
+lib/libbotan-2.so.4
+lib/libbotan-2.so.4.4.0
%%PYTHON_SITELIBDIR%%/botan2.py
libdata/pkgconfig/botan-2.pc