aboutsummaryrefslogtreecommitdiff
path: root/security/botan2
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-11-16 10:21:25 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-11-16 10:21:25 +0000
commit98812670ffdd6dbcdd5dd32e20893c07160f6202 (patch)
tree7b3e72be36a2bf6f530d572e47c076713282bb7e /security/botan2
parent38743c36bf884c4f7f7faeb08b7ae81c67320c96 (diff)
downloadports-98812670ffdd6dbcdd5dd32e20893c07160f6202.tar.gz
ports-98812670ffdd6dbcdd5dd32e20893c07160f6202.zip
security/botan2: fix build on arm
processor_rng is only implemented on x86 and powerpc64 PR: 251160 Approved by: Ralf van der Enden (maintainer)
Notes
Notes: svn path=/head/; revision=555460
Diffstat (limited to 'security/botan2')
-rw-r--r--security/botan2/Makefile6
-rw-r--r--security/botan2/pkg-plist2
2 files changed, 7 insertions, 1 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 74bb8578f847..7f83d842536f 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -75,6 +75,12 @@ PLIST_SUB+= HAS_RDRAND_RNG=""
PLIST_SUB+= HAS_RDRAND_RNG="@comment "
.endif
+.if ${ARCH} == i386 || ${ARCH} == amd64 || ${ARCH:Mpowerpc64*}
+PLIST_SUB+= HAS_PROCESSOR_RNG=""
+.else
+PLIST_SUB+= HAS_PROCESSOR_RNG="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^optimization_flags .*|optimization_flags "${CXXFLAGS}"|' \
${WRKSRC}/src/build-data/cc/clang.txt
diff --git a/security/botan2/pkg-plist b/security/botan2/pkg-plist
index fabed9168bca..25a2f1da8c0f 100644
--- a/security/botan2/pkg-plist
+++ b/security/botan2/pkg-plist
@@ -212,7 +212,7 @@ include/botan-2/botan/polyn_gf2m.h
include/botan-2/botan/pow_mod.h
include/botan-2/botan/prf_tls.h
include/botan-2/botan/prf_x942.h
-include/botan-2/botan/processor_rng.h
+%%HAS_PROCESSOR_RNG%%include/botan-2/botan/processor_rng.h
include/botan-2/botan/psk_db.h
include/botan-2/botan/psk_db_sql.h
include/botan-2/botan/pssr.h