aboutsummaryrefslogtreecommitdiff
path: root/security/bzrtp/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-15 19:41:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-15 19:43:15 +0000
commite756e5218f1d2368747e40cb9e60c03bfdcc72bc (patch)
tree2763dff336d12359b0a6c42f65ce8ba0164fe99b /security/bzrtp/Makefile
parent975d9e8938ad54db545081c3f167b644090f0c2f (diff)
downloadports-e756e5218f1d2368747e40cb9e60c03bfdcc72bc.tar.gz
ports-e756e5218f1d2368747e40cb9e60c03bfdcc72bc.zip
Diffstat (limited to 'security/bzrtp/Makefile')
-rw-r--r--security/bzrtp/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/security/bzrtp/Makefile b/security/bzrtp/Makefile
index aad5ebaa03d2..cfd364b40253 100644
--- a/security/bzrtp/Makefile
+++ b/security/bzrtp/Makefile
@@ -1,23 +1,27 @@
PORTNAME= bzrtp
-PORTVERSION= 1.0.6
-PORTREVISION= 2
+PORTVERSION= 5.1.32
CATEGORIES= security
-MASTER_SITES= https://www.linphone.org/releases/sources/bzrtp/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= ZRTP support library (RFC 6189)
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libbctoolbox.so:net/bctoolbox
USES= cmake cpe gnome sqlite
CPE_VENDOR= ${PORTNAME}_project
+USE_GITLAB= yes
+GL_SITE= https://gitlab.linphone.org/BC
+GL_ACCOUNT= public
+GL_COMMIT= ab352db967d3f2bd0037564079e5cb4df0bd3460
USE_GNOME= libxml2
USE_LDCONFIG= yes
-CMAKE_ARGS= -DENABLE_STATIC=NO -DENABLE_STRICT=NO
+CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
+ -DENABLE_STATIC=NO \
+ -DENABLE_STRICT=NO
post-patch:
@${REINPLACE_CMD} 's/<alloca\.h>/<stdlib.h>/' ${WRKSRC}/src/zidCache.c