aboutsummaryrefslogtreecommitdiff
path: root/security/certificate-transparency
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-11 18:29:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-11 18:29:54 +0000
commitd0acbae40751e976a1cadc516b2e423c4ddf8a79 (patch)
tree35fef2a3fdc1780123448ae0d3a73b0e64cb9d10 /security/certificate-transparency
parentfe76f1a4a9b1f6d7ef2d6be8517bc6298963f590 (diff)
downloadports-d0acbae40751e976a1cadc516b2e423c4ddf8a79.tar.gz
ports-d0acbae40751e976a1cadc516b2e423c4ddf8a79.zip
- Add LICENSE_FILE
- Add missing dependency on snappy - Switch to USES=localbase - Cosmetic fixes
Notes
Notes: svn path=/head/; revision=517279
Diffstat (limited to 'security/certificate-transparency')
-rw-r--r--security/certificate-transparency/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/security/certificate-transparency/Makefile b/security/certificate-transparency/Makefile
index 855e796d888a..58aab494bf89 100644
--- a/security/certificate-transparency/Makefile
+++ b/security/certificate-transparency/Makefile
@@ -3,15 +3,16 @@
PORTNAME= certificate-transparency
PORTVERSION= 20161015
-PORTREVISION= 39
+PORTREVISION= 40
CATEGORIES= security
MAINTAINER= ports@FreeBSD.org
COMMENT= Open framework for monitoring and auditing SSL certificates
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS?= libevent.so:devel/libevent \
+LIB_DEPENDS= libevent.so:devel/libevent \
libevhtp.so:www/libevhtp \
libgtest.so:devel/googletest \
libgflags.so:devel/gflags \
@@ -23,21 +24,17 @@ LIB_DEPENDS?= libevent.so:devel/libevent \
libobjecthash.so:devel/objecthash \
libprotobuf.so:devel/protobuf \
libsqlite3.so:databases/sqlite3 \
- libtcmalloc.so:devel/google-perftools
+ libtcmalloc.so:devel/google-perftools \
+ libsnappy.so:archivers/snappy
-USES= autoreconf compiler:c++11-lib gmake pkgconfig ssl
+USES= autoreconf compiler:c++11-lib gmake localbase:ldflags pkgconfig ssl
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= "CFLAGS+=-I${LOCALBASE}/include CXXFLAGS+=-lgtest CXXFLAGS+=-lgmock"
MAKE_FLAGS+= "V=1"
USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= 28478cb
-CPPFLAGS+= "-I${LOCALBASE}/include"
-CPPFLAGS+= "-I${LOCALBASE}/include/evhtp"
-LDFLAGS+= "-L${LOCALBASE}/lib"
-
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} == base