aboutsummaryrefslogtreecommitdiff
path: root/security/cfs
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2000-07-18 03:20:08 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2000-07-18 03:20:08 +0000
commitad3c55ffddb1d80708e5024a0699765d902db2be (patch)
tree97b6237b254441c56382a23b7ce44211c66d2b31 /security/cfs
parent463306f7e24a953ab96039837e502b1c70ca4967 (diff)
downloadports-ad3c55ffddb1d80708e5024a0699765d902db2be.tar.gz
ports-ad3c55ffddb1d80708e5024a0699765d902db2be.zip
Use new style start/stop rc.d script
Unrestrict port since we are able to distribute crypto
Notes
Notes: svn path=/head/; revision=30764
Diffstat (limited to 'security/cfs')
-rw-r--r--security/cfs/Makefile3
-rw-r--r--security/cfs/files/cfsd.sh19
2 files changed, 20 insertions, 2 deletions
diff --git a/security/cfs/Makefile b/security/cfs/Makefile
index 531d1eb71ca9..3b60880f1f4e 100644
--- a/security/cfs/Makefile
+++ b/security/cfs/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= green@FreeBSD.org
ALL_TARGET= cfs
MAN1= cattach.1 cdetach.1 cmkdir.1 cpasswd.1 cfssh.1
MAN8= ccat.8 cfsd.8 cname.8
-RESTRICTED= "contains crypto code"
NO_WRKSUBDIR= yes
@@ -30,6 +29,6 @@ do-install:
${INSTALL_MAN} ${MAN8} ${PREFIX}/man/man8; \
${MKDIR} ${PREFIX}/share/doc/cfs; \
${INSTALL_DATA} README.install notes.ms ${PREFIX}/share/doc/cfs; \
- ${INSTALL_SCRIPT} cfsd.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${FILESDIR}/cfsd.sh ${PREFIX}/etc/rc.d
.include <bsd.port.mk>
diff --git a/security/cfs/files/cfsd.sh b/security/cfs/files/cfsd.sh
new file mode 100644
index 000000000000..488962b97f43
--- /dev/null
+++ b/security/cfs/files/cfsd.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/sbin/cfsd ] && ${PREFIX}/sbin/cfsd > /dev/null 2>&1 && echo -n ' cfsd'
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0