aboutsummaryrefslogtreecommitdiff
path: root/security/chaosreader
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 08:12:41 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 08:12:41 +0000
commit0b90608912ebdb20a6578bfc69ef09c42e3caed8 (patch)
treefea6611c24d17984897a9b0756414ad278661252 /security/chaosreader
parentcd390572570ce6c662bd379ffb5e58bd660a4f1e (diff)
downloadports-0b90608912ebdb20a6578bfc69ef09c42e3caed8.tar.gz
ports-0b90608912ebdb20a6578bfc69ef09c42e3caed8.zip
- Support staging
- Use shebangfix
Notes
Notes: svn path=/head/; revision=346245
Diffstat (limited to 'security/chaosreader')
-rw-r--r--security/chaosreader/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/security/chaosreader/Makefile b/security/chaosreader/Makefile
index bcbf00bb1154..fcfbbb87de10 100644
--- a/security/chaosreader/Makefile
+++ b/security/chaosreader/Makefile
@@ -14,22 +14,18 @@ MAINTAINER= pauls@utdallas.edu
COMMENT= Tool to extract data from tcpdump logs
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
PLIST_FILES= bin/${PORTNAME} bin/sshkeydata
+SHEBANG_FILES= chaosreader sshkeydata
-NO_STAGE= yes
post-extract:
- ${CP} ${DISTDIR}/${PORTNAME}${PORTVERSION} ${WRKDIR}/${PORTNAME}
- ${CP} ${DISTDIR}/sshkeydata0.20 ${WRKDIR}/sshkeydata
-
-post-patch:
- ${REINPLACE_CMD} s:/usr/bin/perl:${PERL}: \
- ${WRKDIR}/${PORTNAME} ${WRKDIR}/sshkeydata
+ @${CP} ${DISTDIR}/${PORTNAME}${PORTVERSION} ${WRKDIR}/${PORTNAME}
+ @${CP} ${DISTDIR}/sshkeydata0.20 ${WRKDIR}/sshkeydata
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKDIR}/sshkeydata ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/sshkeydata ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>