aboutsummaryrefslogtreecommitdiff
path: root/security/chroot_safe
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-10 15:24:38 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-10 15:24:38 +0000
commit614914611ffc7b75a0230af28326bd38d5b8ae1b (patch)
treecc162890c050ffac35676bdeb1a47b05d18ff1fa /security/chroot_safe
parent24581968747e1637cef3f8b0e26f92ac19b93677 (diff)
downloadports-614914611ffc7b75a0230af28326bd38d5b8ae1b.tar.gz
ports-614914611ffc7b75a0230af28326bd38d5b8ae1b.zip
Stagify.
Notes
Notes: svn path=/head/; revision=357335
Diffstat (limited to 'security/chroot_safe')
-rw-r--r--security/chroot_safe/Makefile4
-rw-r--r--security/chroot_safe/files/patch-Makefile.in21
2 files changed, 22 insertions, 3 deletions
diff --git a/security/chroot_safe/Makefile b/security/chroot_safe/Makefile
index e9f7421501ea..703f8c8059ec 100644
--- a/security/chroot_safe/Makefile
+++ b/security/chroot_safe/Makefile
@@ -13,11 +13,9 @@ COMMENT= Tool to chroot softwares easily
GNU_CONFIGURE= YES
-MAN1= chroot_safe.1
-PLIST_FILES= sbin/chroot_safe libexec/chroot_safe/chroot_safe.so
+PLIST_FILES= man/man1/chroot_safe.1.gz sbin/chroot_safe libexec/chroot_safe/chroot_safe.so
PLIST_DIRS= libexec/chroot_safe
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|CXX=g++|CXX?=c++|' \
-e 's|-o chroot_safe.so|chroot_safe.cpp -o chroot_safe.so|' \
diff --git a/security/chroot_safe/files/patch-Makefile.in b/security/chroot_safe/files/patch-Makefile.in
new file mode 100644
index 000000000000..231ffa1daaa1
--- /dev/null
+++ b/security/chroot_safe/files/patch-Makefile.in
@@ -0,0 +1,21 @@
+--- Makefile.in.orig 2014-06-10 23:22:42.806836167 +0800
++++ Makefile.in 2014-06-10 23:23:07.477835933 +0800
+@@ -18,12 +18,12 @@ clean:
+ rm -f *.o *.so *~
+
+ install: all
+- $(install) -m 0755 -d $(libexec)
+- $(install) -m 0755 -s chroot_safe.so $(libexec)/chroot_safe.so
+- $(install) -m 0755 -d $(sbin)
+- $(install) -m 0750 chroot_safe $(sbin)/chroot_safe
+- $(install) -m 0755 -d $(man)
+- $(install) -m 0444 chroot_safe.1 $(man)/chroot_safe.1
++ $(install) -m 0755 -d $(DESTDIR)$(libexec)
++ $(install) -m 0755 -s chroot_safe.so $(DESTDIR)$(libexec)/chroot_safe.so
++ $(install) -m 0755 -d $(DESTDIR)$(sbin)
++ $(install) -m 0750 chroot_safe $(DESTDIR)$(sbin)/chroot_safe
++ $(install) -m 0755 -d $(DESTDIR)$(man)
++ $(install) -m 0444 chroot_safe.1 $(DESTDIR)$(man)/chroot_safe.1
+
+ distclean: clean
+ rm -f chroot_safe config.log config.status Makefile chroot_safe.1