aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-12 02:25:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-12 02:25:07 +0000
commit7bfae932f73e6929fd4fc0afd04e81199c58df00 (patch)
treeae010486371dd984317b78c829a6c1566d322249 /security/clamav
parent43c9b0c5bc539452cc0f4da23f4ff1e08646554f (diff)
downloadports-7bfae932f73e6929fd4fc0afd04e81199c58df00.tar.gz
ports-7bfae932f73e6929fd4fc0afd04e81199c58df00.zip
Notes
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index f4282d01975b..dfa58f8d7000 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:devel/libltdl \
libcurl.so:ftp/curl
-USES= cpe gmake gnome libtool ncurses pathfix pkgconfig ssl
+USES= compiler cpe gmake gnome libtool ncurses pathfix pkgconfig ssl
USE_RC_SUBR= clamav-clamd clamav-freshclam
USE_LDCONFIG= yes
@@ -144,6 +144,8 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(MilterSocket) */tmp.*$$|\1 ${CLAMAV_MILTER_SOCKET}|' \
-e 's|^\#?(ClamdSocket).*$$|\1 unix:${CLAMAV_CLAMD_SOCKET}|'
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lthr|g' \
-e 's|LC_REVISION=22|LC_REVISION=24|' \
@@ -152,7 +154,7 @@ post-patch:
${WRKSRC}/etc/clamd.conf.sample \
${WRKSRC}/etc/freshclam.conf.sample \
${WRKSRC}/etc/clamav-milter.conf.sample
-.if exists(/usr/lib/libstdc++.so)
+.if ${CHOSEN_COMPILER_TYPE} == gcc
@${REINPLACE_CMD} -e 's|-Wno-logical-op-parentheses||' \
-e 's|-Wno-dangling-else||' \
${WRKSRC}/libclamav/Makefile.am \
@@ -184,4 +186,4 @@ post-install:
${STAGEDIR}${RUNDIR}
(cd ${WRKSRC}/docs/html; ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/html)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>