aboutsummaryrefslogtreecommitdiff
path: root/security/cops
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-15 17:35:29 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-15 17:35:29 +0000
commit20177ec86da5af1fb4641397477ff82d3d04446c (patch)
tree53aaba01597670fba446ecd59dd5015d2b7393b7 /security/cops
parente3a4c1fea689674c5a9cc60afd3f8e69309b3007 (diff)
downloadports-20177ec86da5af1fb4641397477ff82d3d04446c.tar.gz
ports-20177ec86da5af1fb4641397477ff82d3d04446c.zip
Fix MASTER_SITES; add WWW. Add MAINTAINER while I'm here.
PR: 19932 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=30667
Diffstat (limited to 'security/cops')
-rw-r--r--security/cops/Makefile36
-rw-r--r--security/cops/distinfo2
-rw-r--r--security/cops/files/patch-ab12
-rw-r--r--security/cops/pkg-descr2
-rw-r--r--security/cops/pkg-plist165
5 files changed, 131 insertions, 86 deletions
diff --git a/security/cops/Makefile b/security/cops/Makefile
index c79429a8d248..d4f7f27ba89b 100644
--- a/security/cops/Makefile
+++ b/security/cops/Makefile
@@ -8,10 +8,17 @@
PORTNAME= cops
PORTVERSION= 1.04
CATEGORIES= security
-MASTER_SITES= ftp://coast.cs.purdue.edu/pub/tools/unix/cops/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+MASTER_SITES= http://www.fish.com/cops/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}+
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/.//g}+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= reconfig
+MAKEFILE= makefile
+MAKE_ARGS= EXECUTABLE="${EXECUTABLE}" C_SRC="${C_SRC}"
-WRKSRC= ${WRKDIR}/cops_104
EXECUTABLE= home.chk user.chk is_writable crc crc_check \
addto clearfiles filewriters members tilde is_able
C_SRC= home.chk.c user.chk.c is_able.c is_something.c \
@@ -19,18 +26,19 @@ C_SRC= home.chk.c user.chk.c is_able.c is_something.c \
crc.c crc_check.c
pre-build:
- (cd ${WRKSRC} ; ./reconfig)
- (cd ${WRKSRC} ; \
- ${SED} 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' < cops | ${SED} '/^$$SECURE\/passwd\.chk.*/d' | ${SED} 's,SECURE_USERS="foo@bar\.edu",SECURE_USERS="root@localhost",g' | ${SED} 's/passwd\.chk pass.chk //g' > cops.out ; \
- ${MV} cops.out cops ; ${CHMOD} u+x cops)
-
-do-build:
- (cd ${WRKSRC} ; make EXECUTABLE="${EXECUTABLE}" C_SRC="${C_SRC}")
+ ${SED} \
+ -e 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' \
+ -e '/^$$SECURE\/passwd\.chk.*/d' \
+ -e 's,SECURE_USERS="foo@bar\.edu",SECURE_USERS="root@localhost",g' \
+ -e 's/passwd\.chk pass.chk //g' \
+ ${WRKSRC}/cops > ${WRKSRC}/cops.out
+ ${MV} ${WRKSRC}/cops.out ${WRKSRC}/cops
do-install:
- (cd ${WRKSRC} ; ${RM} -rf ${PREFIX}/cops ; ${MKDIR} ${PREFIX}/cops ; \
- ${CP} -R * ${PREFIX}/cops ; \
- ${CHMOD} -R go-rwx ${PREFIX}/cops ; \
- ${RM} -rf ${PREFIX}/cops/*.old ${PREFIX}/cops/src)
+ ${MKDIR} ${PREFIX}/cops
+ ${TAR} -C ${WRKSRC} --exclude "*.old" -cf - . | \
+ ${TAR} -C ${PREFIX}/cops --unlink -xf -
+ ${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/cops
+ ${CHMOD} -R go-rwx ${PREFIX}/cops
.include <bsd.port.mk>
diff --git a/security/cops/distinfo b/security/cops/distinfo
index 5695b788f275..d796ee5ba01e 100644
--- a/security/cops/distinfo
+++ b/security/cops/distinfo
@@ -1 +1 @@
-MD5 (cops.1.04.tar.gz) = dc28e7985fc28fb61138470c11eecbe5
+MD5 (cops104+.tar.gz) = d994194c3ee14e4a71b1312e98643606
diff --git a/security/cops/files/patch-ab b/security/cops/files/patch-ab
index f8085d545af0..7e02909ab1e8 100644
--- a/security/cops/files/patch-ab
+++ b/security/cops/files/patch-ab
@@ -1,11 +1,11 @@
---- makefile.orig Wed Jun 3 22:17:30 1998
-+++ makefile Wed Jun 3 22:17:35 1998
-@@ -20,7 +20,7 @@
- SUPPORT = is_able.lst suid.stop crc_list
+--- makefile.orig Tue Mar 9 02:19:18 1993
++++ makefile Tue Jul 11 21:44:29 2000
+@@ -23,7 +23,7 @@
+ # C2 = -DC2
#
--CFLAGS = -O
-+#CFLAGS = -O
+-CFLAGS = -O $(C2)
++CFLAGS+ = $(C2)
# sequents need "-lseq" as well... uncomment this if you're running on one:
# SEQFLAGS = -lseq
diff --git a/security/cops/pkg-descr b/security/cops/pkg-descr
index b0effba9e35e..4c23d1d19bd9 100644
--- a/security/cops/pkg-descr
+++ b/security/cops/pkg-descr
@@ -6,5 +6,7 @@ area. The directory has no non-user privileges and cops is meant
to be run locally to that directory. The perl version of cops is
also included in a subdirectory.
+WWW: http://www.fish.com/cops/
+
- Oly
oly@world.std.com
diff --git a/security/cops/pkg-plist b/security/cops/pkg-plist
index 8377e5ab4247..92eb7cdaa301 100644
--- a/security/cops/pkg-plist
+++ b/security/cops/pkg-plist
@@ -1,3 +1,20 @@
+cops/MANIFEST
+cops/README.1
+cops/README.2.pl
+cops/README.2.sh
+cops/README.3
+cops/README.FIRST
+cops/XTRA_CREDIT
+cops/addto
+cops/bug.chk
+cops/bug.chk.aix
+cops/bug.chk.apollo
+cops/bug.chk.dec
+cops/bug.chk.next
+cops/bug.chk.sgi
+cops/bug.chk.sun
+cops/bug.chk.svr4
+cops/bug_cmp
cops/carp/How2Change
cops/carp/README
cops/carp/carp
@@ -31,35 +48,63 @@ cops/checkacct/rhosts.pl
cops/checkacct/setuid
cops/checkacct/sysV.m4
cops/checkacct/write
+cops/chk_strings
+cops/clearfiles
+cops/cops
+cops/cops_filter
+cops/cover_letter
+cops/crc
+cops/crc.chk
+cops/crc_check
+cops/crc_list
+cops/cron.chk
+cops/dev.chk
+cops/disclaimer
cops/docs/COPS.report
+cops/docs/COPS.report.ms
cops/docs/COPS.tex
cops/docs/CRC.README
cops/docs/KUANG.README
cops/docs/SUID.README
cops/docs/bug.chk
+cops/docs/bug.chk.1
cops/docs/cops
+cops/docs/cops.1
cops/docs/cron.chk
+cops/docs/cron.chk.1
cops/docs/dev.chk
+cops/docs/dev.chk.1
cops/docs/ftp.chk
cops/docs/group.chk
+cops/docs/group.chk.1
cops/docs/home.chk
+cops/docs/home.chk.1
cops/docs/is_able
+cops/docs/is_able.1
cops/docs/is_able.chk
+cops/docs/is_able.chk.1
cops/docs/is_writable
+cops/docs/is_writable.1
cops/docs/kuang.1
cops/docs/kuang.man
+cops/docs/kuang.man.ms
cops/docs/makefile
-cops/docs/makefile.old
cops/docs/misc.chk
-cops/docs/obligitory.album
-cops/docs/obligitory.joke
+cops/docs/misc.chk.1
+cops/docs/obligatory.album
+cops/docs/obligatory.joke
cops/docs/pass.chk
+cops/docs/pass.chk.1
cops/docs/pass_diff.chk
+cops/docs/pass_diff.chk.1
cops/docs/passwd.chk
+cops/docs/passwd.chk.1
cops/docs/rc.chk
+cops/docs/rc.chk.1
cops/docs/readme.C2
cops/docs/readme.apollo
-cops/docs/readme.filter
+cops/docs/readme.cfilter
+cops/docs/readme.filters
cops/docs/readme.ibm
cops/docs/readme.sequent
cops/docs/readme.shadow
@@ -68,18 +113,21 @@ cops/docs/readme.xenix
cops/docs/readme.yp
cops/docs/release.notes
cops/docs/root.chk
+cops/docs/root.chk.1
cops/docs/suid.man
+cops/docs/suid.man.ms
cops/docs/tilde
-cops/docs/warnings
cops/docs/user.chk
+cops/docs/user.chk.1
+cops/docs/warnings
cops/extensions/THINGS_2_DO
cops/extensions/YAR
cops/extensions/crypto-stuff
cops/extensions/netstuff
cops/extensions/passwords
cops/extensions/questions
-cops/extensions/writing.suid
cops/extensions/uucp.hardening
+cops/extensions/writing.suid
cops/extra_src/README
cops/extra_src/bad_dir.pl
cops/extra_src/diff_last.sh
@@ -91,14 +139,34 @@ cops/extra_src/trust.pl
cops/extra_src/uucp_1.shar
cops/extra_src/uucp_2.shar
cops/extra_src/uucp_quick.chk
+cops/file.paths
+cops/filewriters
+cops/ftp.chk
+cops/gen_fix
+cops/group.chk
+cops/home.chk
+cops/init_kuang
+cops/is_able
+cops/is_able.chk
+cops/is_able.lst
+cops/is_writable
+cops/kuang
+cops/kuang.pl.shar
+cops/makefile
+cops/makefile.orig
+cops/members
+cops/misc.chk
+cops/pass.words
+cops/pass_diff.chk
+cops/passwd.chk
+cops/patchlevel.h
cops/perl/README.kuang
cops/perl/README.sgi
cops/perl/chk_strings
cops/perl/chk_strings.pl
cops/perl/cops
-cops/perl/cops.orig
cops/perl/cops.cf
-cops/perl/cops.cf.orig
+cops/perl/cops.orig
cops/perl/cron.chk
cops/perl/dev.chk
cops/perl/fgrep.pl
@@ -116,12 +184,11 @@ cops/perl/is_able.pl
cops/perl/kuang
cops/perl/kuang.1
cops/perl/misc.chk
-cops/perl/pass.chk
cops/perl/pass.cache.pl
+cops/perl/pass.chk
cops/perl/passwd.chk
cops/perl/pathconf.pl
cops/perl/pathconf.sh
-cops/perl/prl.patch
cops/perl/rc.chk
cops/perl/reconfig.pl
cops/perl/root.chk
@@ -133,70 +200,38 @@ cops/perl/suid.chk
cops/perl/suid.stop
cops/perl/user.chk
cops/perl/yagrip.pl
-cops/MANIFEST
-cops/README.FIRST
-cops/README.1
-cops/README.2.pl
-cops/README.2.sh
-cops/README.3
-cops/XTRA_CREDIT
-cops/addto
-cops/bug.chk
-cops/bug.chk.aix
-cops/bug.chk.apollo
-cops/bug.chk.dec
-cops/bug.chk.next
-cops/bug.chk.sgi
-cops/bug.chk.sun
-cops/bug.chk.svr4
-cops/bug_cmp
-cops/chk_strings
-cops/clearfiles
-cops/cops
-cops/cops_filter
-cops/cover_letter
-cops/crc
-cops/crc_check
-cops/crc.chk
-cops/crc_list
-cops/cron.chk
-cops/dev.chk
-cops/disclaimer
-cops/file.paths
-cops/filewriters
-cops/ftp.chk
-cops/group.chk
-cops/home.chk
-cops/init_kuang
-cops/is_able
-cops/is_able.chk
-cops/is_able.lst
-cops/is_writable
-cops/kuang
-cops/kuang.pl.shar
-cops/makefile
-cops/makefile.orig
-cops/members
-cops/misc.chk
-cops/pass.words
-cops/pass_diff.chk
-cops/passwd.chk
-cops/patchlevel.h
cops/platform
cops/quick_start
cops/rc.chk
cops/reconfig
cops/res_diff
cops/root.chk
+cops/src/addto.c
+cops/src/clearfiles.c
+cops/src/conf.h
+cops/src/crack-fcrypt.c
+cops/src/crack-lib.c
+cops/src/crack.h
+cops/src/crc.c
+cops/src/crc_check.c
+cops/src/filewriters.c
+cops/src/home.chk.c
+cops/src/is_able.c
+cops/src/is_something.c
+cops/src/members.c
+cops/src/pass.c
+cops/src/tilde.c
+cops/src/user.chk.c
cops/suid.chk
cops/suid.stop
+cops/tilde
cops/user.chk
cops/yp_pass.chk
-cops/tilde
-@dirrm cops/carp
-@dirrm cops/checkacct
-@dirrm cops/docs
-@dirrm cops/extensions
-@dirrm cops/extra_src
+@dirrm cops/src
@dirrm cops/perl
+@dirrm cops/extra_src
+@dirrm cops/extensions
+@dirrm cops/docs
+@dirrm cops/checkacct
+@dirrm cops/carp
@dirrm cops