aboutsummaryrefslogtreecommitdiff
path: root/security/cops
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1996-11-17 19:29:55 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1996-11-17 19:29:55 +0000
commit2d0b362f2175066cea8129a535f6233f04eb630a (patch)
tree27d175ae3d042c2f231abc0258ecbda3120a0601 /security/cops
parent2edb6649ef465bda80d7410c7cc1a1180199cc2c (diff)
downloadports-2d0b362f2175066cea8129a535f6233f04eb630a.tar.gz
ports-2d0b362f2175066cea8129a535f6233f04eb630a.zip
Removed the hardcoded paths and used our variables instead (WRKSRC,PREFIX).
CATEGORIES+= --> CATEGORIES=
Notes
Notes: svn path=/head/; revision=4553
Diffstat (limited to 'security/cops')
-rw-r--r--security/cops/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/security/cops/Makefile b/security/cops/Makefile
index a0ade646c2c4..16ee4f2331cc 100644
--- a/security/cops/Makefile
+++ b/security/cops/Makefile
@@ -2,11 +2,13 @@
# Version required: 1.04
# Date created: 29 August 1996
# Whom: oly
+#
+# $Id$
+#
PKGNAME= cops-1.04
DISTNAME= cops_104
-CATEGORIES+= security
-
+CATEGORIES= security
MASTER_SITES= ftp://ftp.cert.org/pub/tools/cops/1.04/
EXTRACT_SUFX= .tar.Z
@@ -19,13 +21,18 @@ C_SRC = home.chk.c user.chk.c is_able.c is_something.c \
crc.c crc_check.c
pre-build:
- (cd work/${DISTNAME} ; ./reconfig)
- (cd work/${DISTNAME} ; sed 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' < cops | sed '/^$$SECURE\/passwd\.chk.*/d' | sed 's,SECURE_USERS="foo@bar\.edu",SECURE_USERS="root@localhost",g' | sed 's/passwd\.chk pass.chk //g' > cops.out ; mv cops.out cops ; chmod u+x cops)
+ (cd ${WRKSRC} ; ./reconfig)
+ (cd ${WRKSRC} ; \
+ sed 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' < cops | sed '/^$$SECURE\/passwd\.chk.*/d' | sed 's,SECURE_USERS="foo@bar\.edu",SECURE_USERS="root@localhost",g' | sed 's/passwd\.chk pass.chk //g' > cops.out ; \
+ mv cops.out cops ; chmod u+x cops)
do-build:
- (cd work/${DISTNAME} ; make EXECUTABLE="${EXECUTABLE}" C_SRC="${C_SRC}")
+ (cd ${WRKSRC} ; make EXECUTABLE="${EXECUTABLE}" C_SRC="${C_SRC}")
do-install:
- (cd work ; rm -rf /usr/local/cops ; ${MKDIR} /usr/local/cops ; cp -R ${DISTNAME}/* ${PREFIX}/cops ; chmod -R go-rwx ${PREFIX}/cops ; rm -f ${PREFIX}/cops/*.old ; rm -rf ${PREFIX}/cops/src)
+ (cd ${WRKDIR} ; rm -rf ${PREFIX}/cops ; ${MKDIR} ${PREFIX}/cops ; \
+ ${CP} -R ${DISTNAME}/* ${PREFIX}/cops ; \
+ chmod -R go-rwx ${PREFIX}/cops ; \
+ rm -rf ${PREFIX}/cops/*.old ${PREFIX}/cops/src)
.include <bsd.port.mk>