aboutsummaryrefslogtreecommitdiff
path: root/security/cops
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
commit4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/cops
parentb3b7323d8ef412f19e96f476f048c4f46aa36bab (diff)
downloadports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.tar.gz
ports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.zip
STAGE support, and general cleanups. Some of the changes are a
bit more aggressive, but at this point, if I'm staging your port, you've likely stopped caring what's done to it.
Notes
Notes: svn path=/head/; revision=352710
Diffstat (limited to 'security/cops')
-rw-r--r--security/cops/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/security/cops/Makefile b/security/cops/Makefile
index 21db0f0f467e..6166ee10a639 100644
--- a/security/cops/Makefile
+++ b/security/cops/Makefile
@@ -24,7 +24,6 @@ C_SRC= home.chk.c user.chk.c is_able.c is_something.c \
addto.c clearfiles.c filewriters.c members.c tilde.c \
crc.c crc_check.c
-NO_STAGE= yes
pre-build:
${SED} \
-e 's,^SECURE=/usr/foo/bar,SECURE=${PREFIX}/cops,g' \
@@ -35,10 +34,10 @@ pre-build:
${MV} ${WRKSRC}/cops.out ${WRKSRC}/cops
do-install:
- ${MKDIR} ${PREFIX}/cops
+ ${MKDIR} ${STAGEDIR}${PREFIX}/cops
${TAR} -C ${WRKSRC} --exclude "*.old" -cf - . | \
- ${TAR} -C ${PREFIX}/cops --unlink -xf -
- ${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/cops
- ${CHMOD} -R go-rwx ${PREFIX}/cops
+ ${TAR} -C ${STAGEDIR}${PREFIX}/cops --unlink -xf -
+ ${CHOWN} -R ${BINOWN}:${BINGRP} ${STAGEDIR}${PREFIX}/cops
+ ${CHMOD} -R go-rwx ${STAGEDIR}${PREFIX}/cops
.include <bsd.port.mk>